Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: S5 - Querverweisliste nicht komplett aufgelistet - "aufgerufener FB nicht vorhanden"

  1. #1
    Registriert seit
    30.03.2007
    Ort
    Hiddenhausen
    Beiträge
    114
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo !

    Ich bn dabei ein S5 Programm zu ändern, da zwei neue Zylinder mit Abfragen und diverse Lichttaster in die Maschine integriert werden sollen.
    Als ich mir die Querverweisliste anschauen wollte welche Merker frei sind, erscheint nach einiger Zeit "FB 64 - aufgerufener FB nicht vorhanden" und die Ausgabe bricht ab.
    Es werden ja zuerst die bearbeiteten Bausteine aufgelistet. Danach die im Programm vorhandenen Eingänge. Dann wieder die bearbeiteten Bausteine - dann die Ausgänge.
    Nachdem wieder die bearbeiteten Bausteine aufgelistet bricht die Ausgabe nach OB22 mit der Meldung ab. Das heißt, ich kann nicht sehen welche Merken, Timer und Zähler benutzt sind.
    Möchte ich mir im Edit-Modus den Baustein OB22 ansehen passiert das gleiche. Es erscheint erst garnichts - unten steht rot "FB 64".
    ONLINE besteht das gleiche Problem.

    Was kann ich tun ?!

    Evtl. den FB erstellen, einen NOP ausführen lassen und beenden ?

    Hucky
    Zitieren Zitieren S5 - Querverweisliste nicht komplett aufgelistet - "aufgerufener FB nicht vorhanden"  

  2. #2
    Hucky ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.03.2007
    Ort
    Hiddenhausen
    Beiträge
    114
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So. Ich bin in den FB64 mal reingegangen und habe einfach einen Namen vergeben und eine Endmarke gesetzt und gespeichert.
    Jetzt erscheint bei der Belegungsliste und der Querverweisliste "Falsche Parametrierung", aber ich komme zumindest in den OB22.
    Da steht sogar auf einmal etwas:

    Code:
    
         :AWL
         :A DB 51
         :L KF +1
         :T DW 64
         :SPA FB 64
    Name :Name
    ?
    ?
         :
         :
         :Be
    Kenne mich mit FBs nicht sonderlich aus.

    Hucky
    Geändert von Hucky (20.02.2012 um 10:35 Uhr)

  3. #3
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    Hast du schon mal unter Verwaltung->Xref erzeugen versucht..was passiert dann?
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  4. #4
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    aus welchem Baustein kommt denn der Codeschnipsel?
    Hast du es mittlerweile schon mit Xref versucht??
    stelle doch mal den FB hier rein...
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  5. #5
    Hucky ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.03.2007
    Ort
    Hiddenhausen
    Beiträge
    114
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Habe ich noch nicht probiert. Ich habe den Sprung zum FB 64 gelöscht. Den Baustein gibt es nicht, zumindest tauchte beim editieren nichts auf. Wann sollte der denn im OB22 angesprochen werden ? Wenn ich das richtig verstehe wird in das Doppelwort DW 64 der Wert 1 geladen und das wars. SPA wird soch garnicht ausgeführt weil kein VKE 1 da ist. Oder wie, oder was ?
    Zumindest komme ich erstmal an die Querverweisliste.
    Der Codeschnipsel ist aus OB22 - mehr steht da nicht.

    Hucky

  6. #6
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    also nochmal..der OB22 wir ja nur einmal bei Netzwiederkehr aufgerufen.
    Und da hast du den Aufruf für den FB64 sowohl im Editor als auch in der Steuerung gelöscht?!
    Der muß ja noch zumindest in der Steuerung sein, sonst würde Sie ja bei Netzwiederkehr auf STOP gehen!!
    Wie siehts im Editor aus?Kannst du den Baustein öffnen?Editor->Step5 Baustein öffnen->FB64 eingeben...
    ...hast du das OfflineProjekt mal mit der Steuerung verglichen??
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  7. #7
    Hucky ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.03.2007
    Ort
    Hiddenhausen
    Beiträge
    114
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Offline und online bis auf zwei Datenbausteine identisch !
    Ich habe noch die aktuelle Version, bevor ich mit dem umschreiben anfing.
    Laut Struktur wird im OB22 der FB64 aufgerufen. Ist allerdings mit diversen Fragezeichen hinterlegt.
    Öffne ich im Editmodus OB22 kommt die Fehlermeldung "aufgerufener FB nicht vorhanden" - nichts weiter.
    Öffne ich den FB64 steht da nur Name: usw. im Netzwerk 1. So als wenn ich den neu gestalten würde. Da steht nichts drin.
    Wenn ich da jetzt einfach ein :BE reinsetzte komme ich in den OB22 rein. Da steht dann drin was ich gepostet habe. Hatte das erst nicht richtig gemacht, daher die beiden Fragezeichen und die ":"
    Die MAschine läuft. Wäre jetzt mal interessant was passieren würde wenn man das Programm komplett drauf ziehen müsste.
    Aber in dem FB 64 ist definitiv nichts.

    Hucky

  8. #8
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    hört sich ja nicht so dolle an..gibt es noch den Maschinenhersteller ? Vielleicht könnte man das ganze dort einmal nachfragen? Was steht denn in der Symbolik-Ist dort der FB64 deklariert?
    für deine Programmänderung: Mußt du den OB22 bzw.FB64 überhaupt anfassen??
    Wie du es beschrieben hast doch eigentlich nicht..also "Never change a running system".
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  9. #9
    Hucky ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.03.2007
    Ort
    Hiddenhausen
    Beiträge
    114
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich muss da nichts mit machen.
    Ich kam nur an die Querverweisliste nicht dran.
    Wir haben von den Machinen noch ein paar ähnliche.
    Bei einer ist das gleiche, bei der anderen steht der selbe Code OHNE den SPA zu dem FB. Den gibts da garnicht. Denke das ist von Anfang an ein Bug von den Programmierern.
    Die Firma gibts noch, die Leute die sie Programme geschrieben haben bedingt. Zumindest hat sich einer mal selbstständig gemacht. Die MAschinen sind von 96, oder so. Wird bestimmt spaßig da mal nach zufragen.
    Falls wirklich mal das programm abpfeift kann ich immer noch auf das "Original", zumindest der letzte Stand VOR meiner Änderung zufreifen. Also alles nicht ganz so schlimm.

    Hucky

  10. #10
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    so wie der fb aufgerufen wird handelt es sich mit 99%iger sicherheit um den kommunikationsbaustein für ein op zb 5,15,7,17 welches noch mit comtext projektiert wurde und eine cpu der gruppe 1. z.b. ag100 100u.
    wenn ich mich recht erinnere bewirkt die 1 im dw64 einen neuanlauf des op.

    das kann man getrost weglassen. hab ich noch nie gemacht.

    und nochmal zu nicht vorhandenen bausteinen. es ist nunmal so, dass du einen baustein nicht öffnen kannst wenn dort ein nicht vorhandener baustein aufgerrufen wird. dan einfach den baustein erzeugen und gut ist. da der baustein aber afgrufen wird, wird er ja auch benötigt. es kann sich hier dann um fb's handeln die fest in der cpu hinterlegt sind. am besten also zur anlage gehen und einen ag-abzug machen. dann werden auch diese fb's mit in das offlineprojekt kopiert
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

Ähnliche Themen

  1. Antworten: 9
    Letzter Beitrag: 18.09.2013, 08:35
  2. Antworten: 0
    Letzter Beitrag: 26.12.2011, 15:40
  3. "CONT_C" SFB41 läuft nicht in PLCSIM, aber FB41
    Von TagebauCoder im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.08.2010, 21:00
  4. Step7 "Mastersystem einfügen" nicht vorhanden
    Von Thomas_v2.1 im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 20.06.2007, 16:49
  5. Antworten: 4
    Letzter Beitrag: 29.11.2006, 08:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •