Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: CPU312 - Netzwerk Fehlfunktion

  1. #1
    Registriert seit
    05.10.2006
    Beiträge
    324
    Danke
    11
    Erhielt 8 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    wir haben immer im gleichen Netzwerk das Problem, dass bei trivialen Aufgaben z.B.

    U e2.1
    u e7.7
    = M33.3

    die Zuweisung zum M33.3 nicht erfolgt, obwohl beide Zustände "True" sind.
    Wenn man die gleiche Anweisung in ein anderes Netzwerk kopiert funktioniert alles.

    Dies kann über jeglichen Zuweisungsoperand erfolgen, d.h. dies muss nicht der Merker 33.3 sein,
    sondern kann jeglicher Ausgang oder jeglicher Merker sein.
    Immer im gleichen Netzwerk (14) tritt dieses Problem auf.

    Hat von euch jemand schon mal von diesem Problem gehört oder hatte den gleichen Fall?

    Habe alles auch schon in einen anderen FC kopiert und auch ein neues Projekt angelegt bzw.
    den Rechner getauscht, andere CPU312 benutzt und auch im PLCSim konnte dieses Problem nachvollzogen werden!

    Grüße Pico
    Geändert von Pico1184 (20.02.2012 um 11:23 Uhr)
    Zitieren Zitieren CPU312 - Netzwerk Fehlfunktion  

  2. #2
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Beitrag

    Hallo,

    das sieht so aus, als wenn Du in einem Netzwerk vor dem NW 14 eine Abfrage hast, der nichts zugewiesen wird.
    In dem Fall wird ja das VKE mitgenommen und mit Deiner Abfrage der beiden Eingänge verknüpft.

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)

  3. #3
    Registriert seit
    11.04.2008
    Ort
    Bayern
    Beiträge
    523
    Danke
    26
    Erhielt 67 Danke für 67 Beiträge

    Standard

    Schreibe mal zum testen folgendes
    Code:
    CLR
    U E2.1
    U E7.7
    = M33.3

  4. #4
    Registriert seit
    19.12.2008
    Beiträge
    336
    Danke
    19
    Erhielt 28 Danke für 28 Beiträge

    Standard

    @Netmaster:
    nicht eher "SET" ?

  5. #5
    Registriert seit
    06.07.2009
    Beiträge
    41
    Danke
    5
    Erhielt 2 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Lupo Beitrag anzeigen
    @Netmaster:
    nicht eher "SET" ?
    CLR würde schon zutreffen, wenn ein vorhergehendes VKE 1 ist.
    Damit wird VKE = 0 gesetzt.

Ähnliche Themen

  1. Biete CPU312
    Von Lebenslang im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 25.07.2010, 14:11
  2. Uhrzeit und CPU312
    Von tigger im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 12.12.2008, 11:18
  3. keine Verbindung zur CPU312
    Von Robot-Sun im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 17.11.2007, 11:53
  4. OP73 -> CPU312 Ausfallüberwachung?
    Von nico im Forum HMI
    Antworten: 3
    Letzter Beitrag: 22.03.2007, 10:21
  5. Antworten: 3
    Letzter Beitrag: 26.07.2006, 14:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •