Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 4 von 4 ErsteErste ... 234
Ergebnis 31 bis 37 von 37

Thema: Problem mit Positionierung des Hochregallagers

  1. #31
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    du sagtest das es das->64303
    http://www.christiani.de/product_inf...oducts_id/1094
    HRL ist ?!
    Dann ruf doch mal bei Christiani an,und schilder dein Problem(vielleicht steht auch was in der Bedienungsanleitung)Hat schon jemand anders damit gearbeitet?
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  2. #32
    drej8363 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.11.2011
    Ort
    Siegen
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja genau das ist es von Christiani,
    bis jetzt haben viele mitgearbeitet der erste hatte wie ich mitgekriegt habe, das ganze vernünftig heingekriegt, allerdings hat er in AWL realisiert,was aber nicht wirklich mein Ding ist, dann haben alle Nachfolger von dem rumkopiert. Ich vermute hat eigentlich bis jetzt keiner nachgeprüft, ob der Zähler wirklich funktioniert bzw. ob die ganzen Fächer anzufahren sind. In der Bedienungsanleitung sind meistens allgemeine Infos zu der Funktionsbeschreibung usw. Ich habe aber jetzt das Rechts- und Linksfahren mit der Einschaltverzögerung realisiert, damit der Befehl z.B. nach 100ms kommt, so wie es aussieht scheint er ja funktionieren zu wollen. Steht aber immer noch unter Verdacht
    Falls es weiterhin nicht klappen sollte, werden wir in der Mechanik was ändern müssen, damit das HRL nach der Grundfahrt für Anfahren der weiteren Fächer an dieser Position nicht an den Endanschlag kommt..

    Besten Dank

  3. #33
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    Was soll die Einschaltverzögerung bewirken??
    Das Problem scheint doch zu sein, dass wenn du die Pos erreicht hast..den Motor sofort ausschaltest..er noch ein klein wenig weiter fährt..so dass die Pos nicht mehr exakt stimmt?!!
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  4. #34
    drej8363 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.11.2011
    Ort
    Siegen
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Genau so ist es!!
    Die Einschaltverzögerung ist da um das Anfahren an die jeweiligen Richtungen den Impuls erst freigeben, wenn die eingegebene Zeit vorbei ist, wenn ich für Rechtsfahren mit einer Einschaltverzögerung von 100ms einschalte solles funktionieren oder?

  5. #35
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    Ich glaube wir reden aneinader vorbei.
    Warum willst du die Impulse verzögert freigeben, wenn der Motor sich noch gar nicht bewegt hat.
    Es scheint doch so zu sein,das wenn du den Motor ausschaltest,er sich tatsächlich DANN noch ein wenig weiterbewegt und dadurch noch weitere Impulse reinkommen. Somi ist Sollpos nicht mehr Istpos?! Deswegen mit Schleichfahrt langsam an die Sollposition heranfahren, so dass Soll exakt Ist.
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  6. #36
    drej8363 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.11.2011
    Ort
    Siegen
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Die Einschaltverzögerung ist für Vorwärts- oder Rückwärtszählen , das Regalbediengerät fährt genau über ein Loch hinaus, deswegen kommen die Impulse für Vorwärtszählen erst dann, wenn die Zeit vorbei ist. ich habe mit dem Eingang der Lichtschranke für die Bestimmung der Position eine positive Flanke gebildet, dann das Anfahren in eine Richtung mit der Einschaltverzögerung realisiert, d.h. der läuft an und erst wenn die vorgegebene Zeit vorbei ist, fängt mein Zähler an zu zählen..
    So wie es aussieht, funktioniert mein Zähler und mit Anfahren an die Fächer habe ich bis jetzt keine Probleme bekommen.. Ich gehe davon aus, dass es zumindest so weiterlaufen wird..
    Ich verlasse mich einfach auf mein Glück

  7. #37
    drej8363 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.11.2011
    Ort
    Siegen
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin Rheumakay,

    ich habe eine Bitte an Dich, und zwar bin gerad dabei einen Funktionsbaustein für automatisches Einlagern der Würfel am Hochregallager zu realisieren:
    Zuerst, das Anfahren an die Fächer versuche ich mit nem Zähler zu realisieren und im Weiteren habe ich keine Ahnung wie ich das ganze realisieren muss?
    Ich freue mich auf jeden Hinweis..

Ähnliche Themen

  1. Problem mit der Anbinung des Touchpanels
    Von patrick_123 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 13.12.2010, 18:19
  2. impulsgesteuerte Positionierung mit EL2521
    Von Daberer im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 25.08.2010, 12:17
  3. Antworten: 2
    Letzter Beitrag: 19.03.2010, 08:02
  4. Antworten: 1
    Letzter Beitrag: 23.03.2009, 03:53
  5. Positionierung mit Simatic S7 und SEW Movidrive A
    Von nico im Forum SEW-EURODRIVE
    Antworten: 16
    Letzter Beitrag: 13.09.2007, 21:33

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •