Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 6 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 59

Thema: S7 300 geht in Stop , wenn MPI kabel zum PC angeschlossen wird !

  1. #11
    Registriert seit
    17.06.2010
    Ort
    nähe Memmingen
    Beiträge
    610
    Danke
    93
    Erhielt 116 Danke für 100 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hast du dein mpi-kabel auf die profibus schnittstelle eingesteckt? evtl. wurde der dadurch gestört und dann geht die cpu auf stop
    sofern nicht abgefangen durch fehler-ob´s.
    lies doch mal den baugruppenzustand aus, da ist die fehlerursache festgehalten.

  2. #12
    Registriert seit
    09.03.2012
    Beiträge
    93
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    pc hatt ja keine verbindung hergestellt !, bei test der MPI Schnittstelle satnd da falsche ipadresse oder falscher intrupt? aber bei der anlage davor auch eine s7/300 gings... leider steht die maschine sehr selten und sobald ich da wieder rangehe stoppt sie , muss ich also erstmal verschieben , ... nächste woche di kommt vielleicht jemand der sich damit besser auskennt, kenn die anlagen erst seit einer woche... a
    aber also wie gesagt OB82-87 sind vorhanden und nicht leer...

  3. #13
    Registriert seit
    09.03.2012
    Beiträge
    93
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    nachtrag war am profibus und mpi schnittstelle dran

  4. #14
    Registriert seit
    06.10.2003
    Beiträge
    3.409
    Danke
    449
    Erhielt 504 Danke für 407 Beiträge

    Standard

    Zitat Zitat von ich988 Beitrag anzeigen
    ..Mir hat mein SPS-Lehrmeister auch gesagt, dass wenn sowas auftritt einfach den OB leer einfügen.
    Warum auch nicht? Würde mich wirklich interessieren...
    Es kann z.Bsp. vorkommen, daß alle angesteuerten Ausgänge anfangen zu flattern. Zumindest, wenn der Profibus betroffen ist. Den Rest kannst du die ausmalen.
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  5. #15
    Registriert seit
    20.02.2008
    Beiträge
    332
    Danke
    16
    Erhielt 40 Danke für 37 Beiträge

    Standard

    Zitat Zitat von Onkel Dagobert Beitrag anzeigen
    Es kann z.Bsp. vorkommen, daß alle angesteuerten Ausgänge anfangen zu flattern. Zumindest, wenn der Profibus betroffen ist. Den Rest kannst du die ausmalen.
    OK, ich habe da jetzt mal ein paar Minuten darüber nachgedacht. Meine Frage - wie gesagt, ich lasse mich gerne aufklären - ist: Wie fängt man das ab, ohne die CPU zu stoppen. Wobei ich schon sagen würde: Das ist ein Extremfall.

    Man könnte ja z.B. alle Ausgänge des betroffenen Slaves abschalten, Gibt es dafür eine schöne schlanke Methode, die allein mit dem entsprechenden OB auskommt?

  6. #16
    Registriert seit
    06.10.2003
    Beiträge
    3.409
    Danke
    449
    Erhielt 504 Danke für 407 Beiträge

    Standard

    Zitat Zitat von asci25 Beitrag anzeigen
    ..Wie fängt man das ab, ohne die CPU zu stoppen. Wobei ich schon sagen würde: Das ist ein Extremfall...
    Meinst du mit "Extremfall" daß die Ausgänge flattern? Extrem ist es, aber nicht selten. Man braucht nur mal an einem ausgereitzen Bus einen Abschlußwiderstand öffnen, oder wie hier eine Stichleitung (PG) anschließen, und schon geht's los.

    Normalerweise sollte die CPU in so einem Fall auf Stopp gehen. Nun gibt es natürlich auch Anlagen, bei denen bei Slave-Ausfall der Rest weiterlaufen kann bzw. soll. Solche Anlagen habe ich auch. Ich muß gestehen, ich habe auch noch nichts dagegen unternommen. Bei diesen Anlagen habe ich auch entsprechende OBs im Programm, die den CPU-Stopp verhindern.

    Es gibt, glaube ich, eine Systemfunktion mit der man einzelne Busteilnehmer abschalten kann. Im Fehler-OB kann man ermitteln, welche das sind. Ein weiterer Gedanke wäre, die Ausfälle pro Zeit zu ermitteln. Gibt es z.Bsp. innerhalb von drei Sekunden mehrere Ausfälle, könnte man die CPU stoppen. Beim Abschalten eines Slaves passiert dann nichts. Ganz sauber ist das aber nicht. In den drei Sekunden kann schon einiges passieren.

    Wie gesagt, ich muß das auch noch umsetzen, suche auch eine einfache Lösung.


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  7. #17
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard

    Zitat Zitat von Torsten2012 Beitrag anzeigen
    nachtrag war am profibus und mpi schnittstelle dran
    Aber wehn die CPU ein 317-2DP is ist es mochlich dass die MPI schnitstelle auch als Profibus konfiguriert ist.

  8. #18
    Registriert seit
    09.06.2008
    Beiträge
    138
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard

    OK das Flattern tritt aber nicht wegen dem fehlerhaften OB-Abfangen, sondern wegen einer Hardware-Störung am Bus auf.
    Das ist natürlich nicht so einfach, denn selbst wenn man den Teilnehmer deaktiviert, kann dies zu einem flattern führen.
    Letztendlich müsste man den letzten Wert an den die Baugruppe ausgibt halten. Dies ist aber ohne Kommunikation zu ihr nicht möglich.
    Daher dürfte es in diesem Fall bei mir flattern.

  9. #19
    Registriert seit
    30.10.2009
    Ort
    10 km vom Herzen der Natur
    Beiträge
    1.626
    Danke
    120
    Erhielt 340 Danke für 255 Beiträge

    Standard

    @TE
    Probier mal aus, was passiert, wenn Du Deinen Laptop ans Netz hängst, bevor Du ihn an die SPS ansteckst. Vielleicht hat Dein Rechner irgendeine Spannung auf dem Gehäuse, die sich dann über die CPU entlädt.

  10. #20
    Registriert seit
    06.10.2003
    Beiträge
    3.409
    Danke
    449
    Erhielt 504 Danke für 407 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von ich988 Beitrag anzeigen
    ..Das ist natürlich nicht so einfach, denn selbst wenn man den Teilnehmer deaktiviert, kann dies zu einem flattern führen...
    Nein. Wenn der Bus instabil wird, dann kann der Master angesprochende Slaves zeitweise nicht mehr erreichen. Der Slave reagiert darauf und schaltet im Normalfall seine Ausgänge auf false. Da man den Master durch die OB-Aufrufe entmündigt hat, mastert er munter weiter. Ein paar Bus-Zyklen später wird rein zufällig der Slave wieder erreicht und die Ausgänge werden wieder gesetzt. Dieses Spiel setzt sich dann fort. So kommt es zum Flattern. Wenn man den Ausfall jedoch erkennt und den Slave deaktiviert, dann wird er vom Master nicht mehr angesprochen. Dann flattert nichts mehr.

    Zitat Zitat von ich988 Beitrag anzeigen
    ..Letztendlich müsste man den letzten Wert an den die Baugruppe ausgibt halten...
    Bei einigen Slaves kann man konfigurieren daß der letzte Zustand bei einem Kommunikations-Ausfall gehalten wird. Das macht der Slave dann selbst, denn ganz so dumm ist er ja auch nicht. In der Regel ist das jedoch noch gefährlicher.
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

Ähnliche Themen

  1. Antworten: 8
    Letzter Beitrag: 09.01.2012, 11:35
  2. SPS geht in Stop, wenn DP Slave getrennt wird
    Von superkato im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 14.05.2011, 11:58
  3. Antworten: 27
    Letzter Beitrag: 15.03.2009, 20:33
  4. Antworten: 3
    Letzter Beitrag: 09.03.2008, 17:44
  5. CPU 318-2DP Stop bei aufstecken MPI Kabel
    Von Mike0815 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 28.03.2007, 22:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •