Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 15 von 15

Thema: Problem mit Flankenauswertung mit CPU 315 2PN/DP

  1. #11
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Tigerente1974 Beitrag anzeigen
    Wenn es diesen Bug wirklich gab/gibt, sollten die Siemensianer wirklich ernsthaft in Erwägung ziehen, lieber eine Backstube aufzumachen...
    Gugst Du:
    Update V3.3.2 (6ES7 314-1AG14-0AB0)

    Der obige CPU-Ausgabestand enthält funktionale Neuerungen wie z.B. Bausteinverschlüsselung oder Erweiterungen bei Status-Baustein.
    Hinweis zu Abhängigkeiten zu STEP7 und Aufwärtskompatibilität:
    Für den Betrieb dieser CPU ist STEP7 V5.2 SP1 oder höher erforderlich. Das Hardware Support Package HSP 218 sollte installiert werden.
    Für den vollen Funktionsumfang ist mindestens STEP7 V5.5 erforderlich. Das genannte HSP ist in STEP7 V5.5 SP1 enthalten. Die neuen Funktionalitäten benötigen die entsprechende STEP7-Unterstützung, sie sind mit früheren STEP7-Versionen nicht nutzbar.

    Mit dem Firmware-Update V3.3.2 werden die folgenden Änderungen wirksam:
    • Nach Netz-aus kommt es nicht mehr sporadisch zu Aktualwertverlusten durch Urlöschanforderung wegen Speichertausch (Ereignis-ID 16# 6526)
    • Die Remanenzsicherung bei Netz-aus wurde stabilisiert (betrifft hochsporadische Remanenzverluste mit Ereignis-ID 16# 4580 „Backup-Pufferinhalt inkonsistent“).
    • Bit-Verknüpfungen in großen Netzwerken werden nun auch an Segmentgrenzen korrekt ausgeführt.
    • Mehrere Bit-Verknüpfungen die das gleiche Byte betreffen werden ab sofort immer korrekt ausgeführt.
    • Die Befehlsabfolge „L MW 2, TAK, T MW 3, TAK“ funktioniert ab sofort auch wenn die Bereiche von „T“ und „L“ (wie im Beispiel) überlappend sind.
    • Ein SDB0 mit ungültiger Baudrate führt nicht mehr zum Defekt mit Z1=914A; stattdessen wird ab sofort die MPI-Default-Baudrate von 187,5 kBd voreingestellt.
    • Ein Netz-aus während Baustein online beobachten führt nicht mehr sporadisch zu einem Defekt mit Z1=0019 oder Z1=F104.
    • Bei Status-Baustein von großen Bausteinen (> 16 kByte) wird nun auch an Adressen größer 16 kByte die Statusinfo korrekt angezeigt.
    • Hinzufügen eines Schrittes in S7-Graph und anschließender Baustein-Download führt nicht mehr für einen Zyklus zu einem Bereichslängenfehler. Ab sofort können wieder mehrere Bausteine zusammen eingekettet werden.
    • Der SFC1 "READ_CLK" wandelt ab sofort die Jahreszahl immer korrekt in eine BCD-Zahl. Nachfolgende auf das BCD-Format aufsetzende Anweisungen (z.B. BTI „BCD-To-Integer“) führen somit nicht mehr zu Wandlungsfehlern (z.B. Ereignis-ID 16# 2521 „BCD-Wandlungsfehler).
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  2. #12
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    Hi Paule !
    Hatte der TE nicht die 315 im Einsatz ?
    Gruss
    kind regards
    SoftMachine

  3. #13
    Registriert seit
    06.10.2009
    Ort
    NRW
    Beiträge
    1.572
    Danke
    63
    Erhielt 259 Danke für 219 Beiträge

    Standard

    Ich bin fassungslos...
    Ich finde es nachvollziehbar, wenn komplizierte Funktionen nicht immer fehlerfrei sind. Aber bei den BASICS darf es nun wirklich nicht solche haarsträubenden Fehler geben.
    Das wäre ja so als ob ein Autobauer ein neues Modell rausbringt, bei dem ab sofort immer auch nach links gefahren wird, wenn das Lenkrad nach links bewegt wird.
    Gut dass Siemens keine Autos baut.
    Meine Motivation läuft nackig mit einem Cocktail über eine Wiese.

  4. #14
    SPS-freak1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.10.2010
    Beiträge
    325
    Danke
    15
    Erhielt 36 Danke für 31 Beiträge

    Standard

    Hallo,

    also ich hab das jetzt mal an den Siemens Support übergeben, mal sehen was die mir für eine Lösung präsentieren können... so kompliziert kanns ja nicht sein, alle anderen Steuerungen die ich kenne haben das ja auch gekonnt. Mal sehen ob nächste Woche die gleiche SPS mit einen anderen Programm auch so zicken macht.


    Bin natürlich gerne noch für weitere Vorschläge offen.

    Vielen dank schon mal

  5. #15
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von SoftMachine Beitrag anzeigen
    Hi Paule !
    Hatte der TE nicht die 315 im Einsatz ?
    Gruss
    In der Tat!
    Für die 315er gibt es aber auch eine neue Firmware mit der Kennzeichnung "Empfohlen zur Hochrüstung" und das schaut kein bisschen besser aus als von der 314er.

    @SPS-freak1, mich wundert es das Siemens dir nicht ein Firmwareupdate empfohlen hast, vor allem wenn du echt noch die Uralte 3.1.6 drauf hast.
    Das kommt bei Siemens ja noch fast vor "Guten Tag, was haben sie für ein Problem".
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

Ähnliche Themen

  1. TCP Kommunikation PAC3200 mit S7 315-2PN
    Von Guschdl im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 09.05.2014, 12:36
  2. Antworten: 4
    Letzter Beitrag: 12.03.2011, 19:08
  3. Antworten: 1
    Letzter Beitrag: 11.11.2010, 06:14
  4. Antworten: 5
    Letzter Beitrag: 20.04.2010, 21:09
  5. Antworten: 2
    Letzter Beitrag: 19.03.2008, 14:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •