Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 22

Thema: Master / Slave Betrieb zweier 315-2DP (6ES7 315 2AF03 0AB0 V1.2)

  1. #11
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin.

    Also wenn ich die E/As definiere, liegen die automatisch auf dem Rack auf Steckplatz 4 aufwärts. Das überlagert sich mit den tatsächlich vorhandenen E/As. Ist das zu vernachlässigen?!
    Nein. Nimm doch bitte bei der Kopplung Adressen, die noch nicht vergeben sind.
    (Geht das überhaupt? Wird bei vorhandenen Adressen nicht sofort gemeckert?)

    Worauf du auf jeden Fall noch achten solltest ist die Erreichbarkeit.
    Also bei der Slave-CPU in den Eigenschaften der Schnittstelle, diese auf Slave stellen. (Hast du ja bereits gemacht)
    Darunter solltest du den Haken bei Inbetriebnahme, (erreichbarkeit)..., ich weiß grad nicht auswendig wie das dort heißt, anklicken.
    Ansonsten könntest du die CPU über Bus nicht mehr erreichen.

    Die Slave-CPU als vorhandene Station in der Master-CPU einbinden und koppeln. Die E/A-Adressen einstellen und dann sollte das schon laufen.
    Soweit zur Theorie.

    Ach ja, übertrage doch bitte bei einer CPU (Master) noch einen leeren OB82 und OB86.

    Das Problem ist, dass wenn beide CPU´s gestartet werden ist eine schneller hochgefahren.
    Fehlt der Master-CPU sein Slave (CPU) dann geht diese in den Stop. Fehlt der Slave-CPU sein Master, geht diese auch in den Stop.
    Du musst also hinkriegen, dass eine von beiden nicht mehr in den Stop geht, damit die sich "begrüßen" können und melden können, dass alles i.O. ist.

    Bei dem Hardware-Konflikt bin ich mir nicht sicher. Ich würde auf die falschen E/A´s tippen.
    Ich meine mich erinnern zu können, dass die Adressen auch ausserhalb der PAE/PAA liegen sollten. Aber das ist jetzt rein spekulativ.

    Viel Glück

    P.S.:
    Was mir gerade noch auffällt. Die E/A´s liegen auf Steckplatz 4?
    Siehst du die auf Steckplatz 4 oder ist das nur "symbolisch" gemeint?
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

  2. #12
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Beitrag

    Also ich habe E/As verwendet die ich sonst nicht weiter verwende >127.7, die liegen auch außerhalb des PAE/PAA.
    Die Steckplatzproblematik ist mir aufgefallen als ich bei dem MS Betrieb die E/As bekannt gebe, dor steht dann Steckplatz 4 & 5 - diese Feld lässt sich nicht ändern?!

    Beide CPUs laufen ja, jedoch meldet die Slave CPU mir einen Fehler "SF" LED blinkt. Lt. Buagruppendiagnose gibt es ein Problem mit "Soll/Istausbau"

    Müssen die E/As zur Kopplung nun wirklich verbaut sein oder sind die nur virtuell angelegt?

    Gruß
    DerMatze
    Geändert von DerMatze (26.03.2012 um 15:25 Uhr)

  3. #13
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Beitrag

    Ich habe herausgefunden, dass die E/As zur Kopplung nicht physikalisch vorhanden sein müssen - diese werden von der CPU "generiert".

    Eine Änderung habe ich eben noch in der Konfig vorgenommen, die Länge der Bytes auf eins begrenzt - mal sehen ob es Fehlerfrei läuft...?

    Anhang 17041Anhang 17042

    mfg
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  4. #14
    Registriert seit
    24.03.2010
    Beiträge
    126
    Danke
    3
    Erhielt 26 Danke für 21 Beiträge

    Standard

    Hallo,

    mit Steckplatz 4 ist weder der lokale Steckplatz 4 noch der Steckplatz 4 in der remote- CPU gemeint. Das bezieht sich
    auf den virtuellen Steckplatz im DP- Datenmodell.
    Hast Du beide CPUs in einem gemeinsamen S7- Projekt? Wenn ja, kann eigentlich nichts schiefgehen.

    Soll-/Istausbau Fehlermeldung in der Master CPU kommt, wenn entweder
    - Die aktuelle Baugruppenkennung des Slaves nicht zur Projektierung des Slaves passt,
    da reicht manchmal auch schon die Bestellnummer
    - Der EA Ausbau des Slaves nicht zur Projektierung passt.

    mfg
    Erdmann

  5. #15
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Zitat Zitat von erdmann Beitrag anzeigen
    mit Steckplatz 4 ist weder der lokale Steckplatz 4 noch der Steckplatz 4 in der remote- CPU gemeint. Das bezieht sich
    auf den virtuellen Steckplatz im DP- Datenmodell.
    Hallo Erdmann,
    also kann ich die "Steckplatzgeschichte" vernachlässigen.
    Zitat Zitat von erdmann Beitrag anzeigen
    Hast Du beide CPUs in einem gemeinsamen S7- Projekt? Wenn ja, kann eigentlich nichts schiefgehen.
    Ja beide CPUs sind in einem Projekt, sie sollen sich später ein HMI "teilen" bzw soll der Master die Slavedaten zum HMI senden...
    Zitat Zitat von erdmann Beitrag anzeigen
    Soll-/Istausbau Fehlermeldung in der Master CPU kommt, wenn entweder
    - Die aktuelle Baugruppenkennung des Slaves nicht zur Projektierung des Slaves passt,
    da reicht manchmal auch schon die Bestellnummer
    Das muss ich dann nochmal genau prüfen. Gibt es den Fehler evtl auch schon bei untersciedlichem Firmwarestand?

    mfg
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  6. #16
    Registriert seit
    24.03.2010
    Beiträge
    126
    Danke
    3
    Erhielt 26 Danke für 21 Beiträge

    Standard

    Hallo,

    Das ist dem Soll/Ist hat bei DP folgende Bewandnis:
    a) Jeder Slave hat eine fest vorgegebene Kennung (16bit) - nicht veränderbar.
    Bei der Projektierung des Masters wird diese Kennung aus der GSD Datei entnommen.
    Beim Anlauf des DP fragt der Master die Kennung beim Slave ab. Stimmen beide nicht
    überein => Rot und nichts geht. Simatic Slaves sind normalerweise 0x80yy
    Manchmal reicht eine Abweichung der Bestellnummer und Siemens hat eine neue
    ID vergeben.
    b) Jeder Slave hat eine Anzahl Eingänge und eine Anzahl Ausgänge sowie einen zugehörigen
    Typ (Byte, Wort, Konsistenz). Bei eine CPU als Slave ist das (beim Slave) programmierbar.
    Bei der Projektierung des Masters werden die entsprechenden Anzahlen E/A sowie die
    Kennungen festgelegt.
    Beim Anlauf des DP fragt der Master die Kennungen beim Slave ab. Stimmen die
    Kennungen nicht überein => Rot und nichts geht.
    Mehr Möglichkeiten für Soll/Ist Abweichung gibt es nicht.
    Genauere Diagnose ist dem Step7 leider nicht zu entlocken.
    Anzahl E/A sowie Konsistenz kann's bei Dir nicht sein, bei 1Byte E und 1Byte A
    kann man keine Fehler mit der Konsistenz machen..

    mfg
    Erdmann

  7. #17
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard

    jedoch meldet die Slave CPU mir einen Fehler "SF" LED blinkt.
    Die SF-LED blinkt?!?!?!?
    Oder ist die "nur" an.

    Kontolliere wirklich mal deine Hardware. Da scheint noch was falsch zu sein z.B. falsche Bestellnummer.

    Gruß wolder
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

  8. #18
    Registriert seit
    14.02.2012
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Alles übersetzt und die entsprechende HW Konfig in die dazugehörige CPU geladen
    Hallo DerMatze,
    Ich kann aus deiner anfänglichen Beschreibung nicht erkennen, ob du die HW-Config der Master-CPU auch eingespielt hast.
    Da die Master-CPU keinen SF anzeigt, sieht es so aus , als wenn sie den Slave gar nicht kennt. Vergleiche einmach mal
    die HW-Konfig vom Master (Onl./Offl.).

  9. #19
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Daumen hoch

    Hallo Zusammen,

    Statusbericht:
    - Master CPU macht nach wie vor keine Probleme
    - Slave CPU mekerte, "SF" LED blinkt

    Ergriffene Maßnahmen:
    - HW Konfig überprüft = i.O.
    - Firmware der Slave CPU von v1.2 auf v1.2.1 (gleicher Stand wie Master)
    - die Länge der E/As zur Kopplung auf ein WORD reduziert
    - alles übersetzt und gespeichert
    - jede CPU hat ihre Konfig bekommen

    beide CPUs gestartet = läuft OHNE FEHLER

    Der Fehler war wohl der, dass ich bei der Länge eine 32 eingetragen hatte. Nun habe ich E/A 128 1WORD lang, 130 1WORD lang und 132 1WORD lang - alles paletti.

    Vielen Dank für Eure Hilfe und Geduld!
    Gruß
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------
    Zitieren Zitieren Problem gelöst!  

  10. #20
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Bin ich blind?

    Bisher stand nirgendwo, dass du bei der Länge 32 eingegeben hast.
    Gesehen hab ich 1 Byte.

    Egal.
    Viel Glück weiterhin.
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

Ähnliche Themen

  1. Antworten: 9
    Letzter Beitrag: 18.02.2011, 06:47
  2. Firmware für CPU 315-2DP (6ES7 315-2AF03-0AB0)
    Von Holger Levetzow im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 06.10.2010, 07:55
  3. Biete:CPU 315-2 DP 6ES7 315-2AG10-0AB0
    Von Simaticfuzzy im Forum Suche - Biete
    Antworten: 2
    Letzter Beitrag: 30.04.2009, 16:08
  4. Antworten: 6
    Letzter Beitrag: 09.08.2007, 21:10
  5. Frage zu Master/Slave zweier CPU 315-2DP
    Von S7_Mich im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 15.11.2004, 12:58

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •