Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 22

Thema: Master / Slave Betrieb zweier 315-2DP (6ES7 315 2AF03 0AB0 V1.2)

  1. #1
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Ausrufezeichen


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    ich benötige zum Master / Slave Betrieb Hilfe.

    Ich habe bereits eine 315-2DP die auch schon eine Weile in Betrieb ist ==> Hausautomatisierung
    Jetzt habe ich eine weitere 315-2DP, die ich als Slave in den vorhanden Profibus integrieren möchte.
    Die zweite CPU soll eine Siemens Logo ablösen = Heizungs- & Solaranlagensteuerung.
    Soweit zum Vorhaben.

    In der HW Konfig habe ich die Slave CPU in den Profibus des Masters integriert, beide CPUs gekoppelt und E/As für die Kommunikation benannt - alles i.O.
    Alles übersetzt und die entsprechende HW Konfig in die dazugehörige CPU geladen. Und da beginnt mein Problem:
    die Master CPU meckert nicht, bis auf die RUN und die DC5V LED leuchtet/blinkt nix
    ABER
    bei der Slave CPU leuchtet die SF und die BUSF LED, die CPU ist dabei allerdings im RUN.

    Wenn ich den Baugruppenzustand (Strg+D) aufrufe, steht dort unter Diagnose, dass es eine "Soll/Istdifferenz" vorhanden ist!
    Das ist jedoch nicht der Fall. Denn ich habe die HW Konfig mal in ein sep. Projekt kopiert und dei CPU als Master deklariert ==> keine Fehler.

    Hat jemand von Euch eine Idee woran es liegen könnte?

    Vielen Dank.

    mfg
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------
    Zitieren Zitieren Master / Slave Betrieb zweier 315-2DP (6ES7 315 2AF03 0AB0 V1.2)  

  2. #2
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Hallo Zusammen,

    oder mal anders angesetzt.
    Ist auch ein Master / Master Betrieb möglich? Dann würde ich den Slave als zweiten Master betreiben, da die CPU mit der HW Konfig nicht mehr rumzickt - sobald sie Master ist...?!

    Wie funktioniert die Kopplung in diesem Fall?

    Vielen Dank

    Gruß
    DerMatze

  3. #3
    Registriert seit
    02.02.2012
    Ort
    Kaarst
    Beiträge
    126
    Danke
    10
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Hi Matze,

    eine Master-Master-Kopplung machst du ja eigentlich nur wenn du mit mehreren CPU's auf die selben z.B. ProfiBus-Antriebe zugreifen willst und somit Token-Passing machst!

    Was ich versuchen würde wäre, beide CPU's unabhängig erstmal als unvernetzt zu projektieren inner HW-Config und dann übers NetPro beide mit einem ProfiBus netzt verbindung und eine Verbindung projektieren!
    Dürfte funktionieren ... hab an sowas auch schon mal vor einiger Zeit gebastelt.

  4. #4
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Standard

    Hi Matze,
    ist da wirklich keine Differenz bei den konfig. Daten(Blöcke) für den DP Austausch..: Länge, wieviel Bytes(Wörter), Konsistenz usw.?
    Das muss bei beiden CPUs passen, Eing. Block CPU 1 = Ausg. Block CPU 2 und umgekehrt..

    Gruss: Vl.

  5. #5
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Zitat Zitat von vladi Beitrag anzeigen
    Daten(Blöcke) für den DP Austausch..: Länge, wieviel Bytes(Wörter), Konsistenz usw.?
    Hallo,

    ok danke für den Hinweis.
    Das werde ich mir nochmal ansehen. Aber beim Speichern und Übersetzen gab es keine Fehler Meldungen. Ich dachte der Soll/Istausbau Fehler kommt nur wenn die Hardware anders steckt als projetiert.

    mfg
    DerMatze

  6. #6
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Beitrag

    Zitat Zitat von vladi Beitrag anzeigen
    Hi Matze,
    ist da wirklich keine Differenz bei den konfig. Daten(Blöcke) für den DP Austausch..: Länge, wieviel Bytes(Wörter), Konsistenz usw.?
    Das muss bei beiden CPUs passen, Eing. Block CPU 1 = Ausg. Block CPU 2 und umgekehrt..

    Gruss: Vl.
    seltsam ist nur, dass die E/As zur Kopplung auf Steckplatz 4 bzw. 5 sein sollen. Da sind allerdings die DI/DA Baugruppen. Können die Probleme daher kommen?
    Die E/As zur Kopplung sind doch nur "virtuell" oder?

    mfg
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  7. #7
    Registriert seit
    11.12.2009
    Beiträge
    2.113
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Spricht was dagegen MPI und die Globaldatenliste zu nehmen? So hast du für beide nen getrennten Profibus, und Geschwindigkeit brauchst du sicher nicht bei der Hausautomation!

    Grüße

    Marcel

  8. #8
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Zitat Zitat von Matze001 Beitrag anzeigen
    Spricht was dagegen MPI und die Globaldatenliste zu nehmen? So hast du für beide nen getrennten Profibus, und Geschwindigkeit brauchst du sicher nicht bei der Hausautomation!

    Grüße

    Marcel
    Hallo,

    dann ist die MPI-Schnittstelle der CPU immer mit der CPU - CPU Verbindungsleitung belegt?! Und ich muss eine zusätzliche Leitung verlegen, die Slave CPU möchte ich in den vorhanden Profibus integrieren, da diese Leitung in der Nähe der Slave CPU ist bzw muss ich da sowieso noch eine legen und würde den kleinen Umweg machen.

    Momentan hänge ich noch bei der Kopplung der beiden CPUs, irgendwie k´hakt es in der HW Konfig...

    mfg
    DerMatze

  9. #9
    Registriert seit
    11.12.2009
    Beiträge
    2.113
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Das sind infos die ich nicht hatte

    Bei mir ist es leider schon Wieder ne Zeit lang her, wo ich das gemacht hab... glaube 4 Jahre oder so... ohje...

    Grüße

    Marcel

  10. #10
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Beitrag


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also wenn ich die E/As definiere, liegen die automatisch auf dem Rack auf Steckplatz 4 aufwärts. Das überlagert sich mit den tatsächlich vorhandenen E/As. Ist das zu vernachlässigen?!
    Am Master kann ich die E/As nur einstellen wenn ich sie mit dem Slave koppele oder geht das auch irdenwie anders?

    Gruß
    DerMatze

Ähnliche Themen

  1. Antworten: 9
    Letzter Beitrag: 18.02.2011, 06:47
  2. Firmware für CPU 315-2DP (6ES7 315-2AF03-0AB0)
    Von Holger Levetzow im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 06.10.2010, 07:55
  3. Biete:CPU 315-2 DP 6ES7 315-2AG10-0AB0
    Von Simaticfuzzy im Forum Suche - Biete
    Antworten: 2
    Letzter Beitrag: 30.04.2009, 16:08
  4. Antworten: 6
    Letzter Beitrag: 09.08.2007, 21:10
  5. Frage zu Master/Slave zweier CPU 315-2DP
    Von S7_Mich im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 15.11.2004, 12:58

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •