Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: I-Device mit zwei I-Controller

  1. #1
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Forum,

    Mein Ziel ist es ein Profinet-Netz aufzubauen in dem ich zwei CPUs 319F als I-Controller habe, die beide eine CPU 317F als I-Device als Kommunikationspartner haben sollen,

    Meine Vorgehensweise war folgende:
    Projekt CPU 317-F anlegen, I-Device zuweisen, GSD-Datei von der CPU erzeugen und dann als I-Device in die 319F einfügen.

    In der Projektierung sieht das alles gut aus, allerdings ist beim Test mit den Steuerungen dauerhaft ein Fehler auf der CPU und keine Kommunikation vorhanden.

    Hat jemand damit Erfahungen, wo der Fehler liegen kann?

    Vielen Dank für die Hilfe!!!
    Zitieren Zitieren I-Device mit zwei I-Controller  

  2. #2
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    57
    Erhielt 161 Danke für 147 Beiträge

    Standard

    Was du möchtest ist ein I-Device gleichzeitig als Shared Device betreiben.
    Hast du dein I-Device auch als Shared deklariert? (Haken in HW-Konfig)

    Sind für jeden Controler auch eigene Submodule im Device angelegt. Jedes Submodul kann immer nur an einem Controler betrieben werden.

    Du hast bei einem der Controler auch die Möglichkeit das Device, dass ja in zwei Projektierungen vorkommt miteinander zu koppeln. Somit wird der Zugriff auch überprüft, dass keine Überschneidungen stattfinden.

    mfg
    Centi
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  3. #3
    Zoomy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    danke für die Antwort,

    habe mittlerweile den Fehler gefunden.
    Die CPU 317F hat noch einen falschen Gerätenamen, bzw. nicht den Gerätenamen vom I-Controller übernommen.
    Manchmal sind die Dinge so einfach und man findet es doch nicht

  4. #4
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    57
    Erhielt 161 Danke für 147 Beiträge

    Standard

    Ist es nicht Voraussetzung erst die Geräte zu taufen?
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  5. #5
    Zoomy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja es ist Vorraussetzung. Die Anforderungvom Kunden war, dass alle CPUs in unterschiedlichen Projekten sind.
    Nun ist folgendes passiert, die 317 hat genause den defaultnamen (da testaufbau) bekommen wie eine 319 und wurde so bespielt.
    In der 319 wurde der Gerätename der 317 natürlich angepasst, was aber egal war, da das Gerät bereits getauft wurde.
    Ich habe nun erst das Gerät händisch umgetauft und siehe da es hat funktioniert.
    Zusätzlich habe ich jetzt die vergabe der IP-Adresse und des Gerätenamens vom Controller übernehmen lassen.

    Nun will ich noch eine Saftey-Kommunikation aufbauen, das funktioniert doch auch mit dem FB223 und FB224, analog zum PN/PN-Koppler, oder?

  6. #6
    Registriert seit
    04.04.2008
    Beiträge
    389
    Danke
    85
    Erhielt 39 Danke für 24 Beiträge

    Standard

    Hallo,

    ich schlag mich gerade mit dem gleichen Problem herum. Ich will zwei CPU314C-2PN/DP sich über Profinet unterhalten lassen. Dabei sollen vorerst nur 2 Byte Daten vom IO-Controller zum I-Device übergeben werden. Ich gehe vor, wie es in der Systembeschreibung 7/2010 von Siemens beschrieben ist. Komm aber nicht ganz klar. Habt ihr vielleicht noch ein anderes Projektierungsbeispiel?


    Gruß
    Earny

  7. #7
    Zoomy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Mein Projekt darf ich (von Kunden so gewünscht) nicht veröffentlichen, aber wenn du dein Projekt und dein aktuellen Stand hier veröffentlichst kann ich gerne mal rein schauen. Habe mich ja nun schon ein bisschen mit dem Thema auseinander gesetzt.

    P.S.: Hat jemand ein zwecks der Saftey-Kommunikation eine Idee? Bzw. wie kann ich das den überhaubt Testen ob die Bausteine die nicht sicheren Bausteine zu Saftey-Bits gewandelt haben...

  8. #8
    Registriert seit
    04.04.2008
    Beiträge
    389
    Danke
    85
    Erhielt 39 Danke für 24 Beiträge

    Standard

    hallo Zoomy,

    in der Anlage habe ich dir das S7-Projekt mitgeschickt.
    Die CPU der Simatic-Station2 soll das I-Device sein. Die Station1 der IO-Controller. Ich habe zuerst die Station2 projektiert. Die CPU2 soll Daten aus dem EW256 (der IO-Controller CPU1 soll da die Werte reinschreiben) bekommen (siehe OB1) und ins AW20 schreiben. Ich habe eine GSDXLM-Datei erzeugt und die dann installiert. Wenn ich dann in die Station1 wechsle, steht die Station2 im Hardware-Katalog zur Verfügung und kann auf das Profinetnetz gezogen werden. Sieht eigentlich gut aus.

    Wenn ich die Hardwarekonfigurationen und die Programme in die CPUs kopiere, gehen die auf Run, es gehen aber auf beiden CPUs rote LEDs an und eine Kommunikation kommt nicht zustande.

    Hast du eine Idee, was da falsch sein könnte?

    Gruß
    Earny
    Angehängte Dateien Angehängte Dateien

  9. #9
    Registriert seit
    08.03.2006
    Beiträge
    44
    Danke
    2
    Erhielt 4 Danke für 2 Beiträge

    Standard

    Hallo Earny,

    prüf' mal ob die Gerätenamen stimmen.

    Bei einem gemeinsamen Projekt mit einem Controller und einem Device in einem Projekt,
    ändert S7 beim Import der GSDXML-Datei den Gerätenamen,
    da dieser im Projekt schon vorhanden ist.
    Gruß Eumel

    Motivier' dich selbst, sonst motiviert dich keiner!

  10. #10
    Registriert seit
    04.04.2008
    Beiträge
    389
    Danke
    85
    Erhielt 39 Danke für 24 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo,

    die Gerätenamen sind unterschiedlich. Das habe ich überprüft.

    Gruß
    Earny

Ähnliche Themen

  1. Antworten: 8
    Letzter Beitrag: 30.04.2011, 17:46
  2. Profinet , ein Device, mehrere Controller
    Von snowbda im Forum Feldbusse
    Antworten: 1
    Letzter Beitrag: 02.04.2009, 20:23
  3. Antworten: 9
    Letzter Beitrag: 16.12.2007, 21:20
  4. IO-Controller mit einem IO-Controller
    Von udini im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 11.10.2007, 21:15

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •