Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Auf Slave CPU zugreifen

  1. #1
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Beitrag


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    ich habe zwei CPUs (315-2DP) im Master/Slave Betrieb laufen. Die CPUs sind via Profibus DP Schnittstelle miteinander verbunden.
    Wenn ich eine Programmänderung in die Slave CPU übertragen möchte, muss ich mich immer mittels MPI mit dieser verbinden. Eleganter wäre es wenn ich die Ethernetverbindung der Master CPU (PG<->CPU) dafür nutzen könnte. Geht das irgendwie, welche Einstellungen sind nötig?

    mfg
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------
    Zitieren Zitieren Auf Slave CPU zugreifen  

  2. #2
    Registriert seit
    11.04.2008
    Ort
    Bayern
    Beiträge
    523
    Danke
    26
    Erhielt 67 Danke für 67 Beiträge

    Standard

    315-2DP und Ethernet?

  3. #3
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Zitat Zitat von netmaster Beitrag anzeigen
    315-2DP und Ethernet?
    ja via CP LEAN
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  4. #4
    Registriert seit
    22.01.2008
    Ort
    Allgäu, da wo die Kühe schöner sind als die Mädels
    Beiträge
    1.774
    Danke
    50
    Erhielt 729 Danke für 434 Beiträge

    Standard

    wieso MPI? Du schreibst, die beiden sind über den Profibus verbunden, also kannst du auch über den Profibus die Daten auf die Slave CPU schieben.
    Du musst aber in der PG-PC Schnittstelle den Haken einzigster Master am Bus rausmachen.

    Über Ethernet wird das wohl nicht funktionieren. Du könntest mal versuchen, im Net-Pro eine PG-PC Station einzubauen, und dann das Netpro an die Master CPU übertragen.
    Vielleicht ist Siemens dann so schlau, dass durch geroutet werden kann.
    Gib Bescheid, ob das so funktioniert, würde mich auch interessieren
    Gruss Audsuperuser

    Herzlich Willkommen im Chat:
    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  5. #5
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Zitat Zitat von AUDSUPERUSER Beitrag anzeigen
    wieso MPI?
    Hallo,
    MPI deswegen weil ich die Slave CPU nicht über Profibus erreiche. Also stöpsel ich das PG an die Slave CPU auf MPI.

    Wünschenswert ist:
    PG --> via Ethernet auf CP LEAN --> CPU Master --> via Profibus --> CPU Slave

    Ich werde deinen Vorschalg mal ausprobieren...

    mfg + frohe Ostern
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  6. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von DerMatze Beitrag anzeigen
    Wünschenswert ist:
    PG --> via Ethernet auf CP LEAN --> CPU Master --> via Profibus --> CPU Slave
    Genau für solche Anwendungsfälle hat Siemens das S7-Routing mal erfunden ...
    Wenn Deine Baugruppen nicht zu alt sind, dann sollte das funktionieren.
    Welche Voraussetzungen müssen erfüllt sein und welche Baugruppen können eingesetzt werden, um die Funktion S7-Routing nutzen zu können?

    Du mußt beide CPU vollständig in Netpro vernetzt haben, dann übersetzen. Dabei werden die Routing-Tabellen erzeugt. Dann die Konfiguration in die Master-CPU laden.
    Eventuell muß die DP-Schnittstelle der Slave-CPU auch noch aktiv geschaltet werden:
    S7-Routing über PROFIBUS mit S7-300

    Und schau, daß Du auf dem CP343-1 Lean die aktuellste Firmwareversion hast, in einigen FW-Versionen ist das S7-Routing sehr "buggy".

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    DerMatze (09.04.2012)

  8. #7
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Zitat Zitat von PN/DP Beitrag anzeigen
    Wenn Deine Baugruppen nicht zu alt sind, dann sollte das funktionieren.
    Hallo Harald,
    also die CPUs sind beide 315-2AF03-0AB0 v 1.2.1 und unterstützen das Routing (lt.Siemens Tabelle)

    Zitat Zitat von PN/DP Beitrag anzeigen
    Und schau, daß Du auf dem CP343-1 Lean die aktuellste Firmwareversion hast, in einigen FW-Versionen ist das S7-Routing sehr "buggy".
    Der Lean hat Firmwarestand v2.0, lt. der Tabelle muss mindestens v1.0 gegeben sein - also sollte auch das funktionieren.
    Ich werde mal die "Häckchen" an den entsprechenden Stellen setzen und dan mal sehen ob es klappt...

    Danke für die Hinweise.

    Gruß + Frohe Ostern
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  9. #8
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Hallo Harald,

    danke für die Links, sie haben mir zur Problemlösung beigetragen.
    Ich habe bei der Slave CPU den Haken bei "Programmieren, Status/Steuern oder andere PG Funktionen und andere nichtprojektierte Kommunikationsverbindungen zulassen" gesetzt und siehe da
    ES FUNKTIONIERT - sogar über Ethernet/WLAN.

    Vielen Dank.

    mfg
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  10. #9
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Hallo Zusammen,

    ich muss das Thema an dieser Stelle doch noch einmal aufgreifen.
    Heute habe ich der Slave CPU ebenfalls einen CP LEAN gegönnt, da diese SPS mit einem Panel via Ethernet verbunden werden soll.
    Nun habe ich aber etwas festgestellt was sich meiner Kenntnis entzieht und ich es auch nicht nachvollziehen kann:
    nachdem der LEAN installiert ist und in der HW Konfig integriert wurde funktioniert das Routing über die Master SPS nicht mehr?!?!?!
    Zugriff auf die Slave SPS war so möglich:
    PG-->WLAN-->Router-->LAN-->CP/MasterSPS-->Profibus-->SlaveSPS
    Warum auch immer geht das jetzt nicht mehr, an der HW Konfig wurde keine Einstellung geändert - nur der Lean hinzugefügt.
    In NetPro wurden alle Ethernetteilnehmer vernetzt.
    Beide SPSen haben die aktuelle HW Konfig geladen.

    Auch im WinCC flex Projekt kann ich bei Verbindungen unter "Stationen" nur die Ethernetteilnehmer auswählen, Routing fehlt hier auch...

    Ich bin über jede Hilfe dankbar!!!

    MfG
    DerMatze
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  11. #10
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.626
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von DerMatze Beitrag anzeigen
    Warum auch immer geht das jetzt nicht mehr, an der HW Konfig wurde keine Einstellung geändert - nur der Lean hinzugefügt.
    In NetPro wurden alle Ethernetteilnehmer vernetzt.
    Ist in NetPro alles an einen Ethernet Netzwerk verbunden, obwohl es sind eigentlich getrennte Netzwerke ?
    In den Fall will NetPro den Verbindung über Ethernet führen.
    Ich gehe davon aus, sonnst hättest du ja den Slave CPU direkt über Ethernet programmieren können.

    edit: Harald, du hast über mein Schulter geguckt !

    EDIT: Jesper, ich habe Dir aber 1 Sekunde den Vortritt gelassen, allerdings hat das wohl die Forumsansicht so verwirrt, daß sie meint, Du hättest den letzten Beitrag in diesem Thema geschrieben ...
    Dann habe ich den dobbelte Ehre von den Antwort erstens zu geben UND auch den letzten Wort in den Diskussion zu haben.
    Geändert von JesperMP (05.10.2012 um 16:44 Uhr)
    Jesper M. Pedersen

  12. Folgender Benutzer sagt Danke zu JesperMP für den nützlichen Beitrag:

    DerMatze (06.10.2012)

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 12.07.2011, 15:47
  2. Mit Get Baustein auf cpu 315-2 dp zugreifen
    Von john321os im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 15.06.2010, 08:33
  3. Antworten: 4
    Letzter Beitrag: 18.12.2009, 14:34
  4. Antworten: 4
    Letzter Beitrag: 29.01.2007, 09:14
  5. Kommunikation zwischen Slave-CPU und Slave-CPU
    Von Ralle im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 18.04.2005, 10:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •