Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: KTP100 + 313C: Bereichszeiger Datum/Uhrzeit PLC

  1. #1
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.812
    Danke
    1.232
    Erhielt 1.101 Danke für 527 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    hat das schon einer hinbekommen?
    Mein KTP will einfach nicht die Zeit von der 300er übernehmen...

    In der SPS liegt eine Variable DATE_AND_TIME in nem DB, diese läst sich auch problemlos symbolisch an den Bereichzeiger anbinden.
    Die selbe Verbindung wie bei den restlichen variablen ist eingestellt.

    Mehr gibts da doch nicht zu tun, oder?
    Also bisher, und früher,... da ging das noch total einfach.

    Habe auch alternativ zu der DATE_AND_TIME schon einen Struct versucht der nur die von KTP benötigten 6 byte enthielt - ging auch nicht...
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)
    Zitieren Zitieren KTP100 + 313C: Bereichszeiger Datum/Uhrzeit PLC  

  2. #2
    Avatar von Markus
    Markus ist offline Administrator
    Themenstarter
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.812
    Danke
    1.232
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    ...achso TIA 11 SP2
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  3. #3
    Registriert seit
    29.03.2004
    Beiträge
    5.797
    Danke
    144
    Erhielt 1.707 Danke für 1.239 Beiträge

    Standard

    Evtl. ist das bei TIA ja auch noch so, bei WinCC flexible muss der Datenbaustein 4 Bytes länger sein. Also wenn man nur ein Date_and_time in einem DB hat muss man noch 4 Reservebytes mit 0 einfügen.

  4. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Markus (16.04.2012)

  5. #4
    Registriert seit
    13.10.2007
    Beiträge
    12.064
    Danke
    2.793
    Erhielt 3.288 Danke für 2.168 Beiträge

    Standard

    Ich kann zwar jetzt nichts zur Lössung beitragen, aber Siemens schwört doch das die Bedienung von TIA leichter und Intuitiver sein soll.
    Wenn jetzt nicht mal ein gestandener Programmier einfache Sachen wie Zeiten anbinden, nicht hinbekommt, Prost Mahlzeit Siemens.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  6. #5
    Avatar von Markus
    Markus ist offline Administrator
    Themenstarter
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.812
    Danke
    1.232
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    Hmm also der Date-and-Time ist am Ende des dB, habe jetzt noch ein dword mit 0 drangebet. Ohne Erfolg.
    Versuche es später nochmal mit struct, der Date-and-Time hat ja 8 Byte. Vielleicht stören die ms hinten drin...

    Danke mal soweit!
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  7. #6
    Avatar von Markus
    Markus ist offline Administrator
    Themenstarter
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.812
    Danke
    1.232
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    Mit dem struct der nach den 6 Bytes für Jahr,Monat,Tag,Stunde,Minute und Sekunde hinten noch 6 Bytes mit 0 hatte ging's. Da darf also nix drinn sein, mein probl waren wohl die Millisekunden ausm Date-and-Time...

    Danke für eure Hilfe!
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  8. Folgender Benutzer sagt Danke zu Markus für den nützlichen Beitrag:

    L410 (14.08.2014)

  9. #7
    Registriert seit
    16.08.2010
    Beiträge
    4
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vielen Dank für die Hilfe.
    Es klappt aber auch wenn man nach dem Date and Time 3 leere int anhängt.

Ähnliche Themen

  1. Datum Uhrzeit auslesen
    Von klauserl im Forum Simatic
    Antworten: 42
    Letzter Beitrag: 22.01.2011, 10:53
  2. Datum und Uhrzeit
    Von HDF im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 18.12.2009, 09:08
  3. WinCC Flex 2007 Bereichszeiger Datum/Uhrzeit
    Von Acidburn0815 im Forum HMI
    Antworten: 4
    Letzter Beitrag: 24.07.2008, 10:27
  4. Datum Uhrzeit
    Von Andy_speedy im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 10.06.2008, 12:37
  5. Uhrzeit und Datum
    Von Gosi01 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 19.10.2007, 11:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •