Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Weckalarm wird nicht bearbeitet

  1. #1
    Registriert seit
    04.10.2008
    Ort
    Nürnberg
    Beiträge
    98
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich habe da ein kleines Problem.
    Ich habe einen OB38 erstellt und die CPU eingespielt aber er wird nicht bearbeitet.
    In der hardwareconfig ist er parametriert und auf 10 mS eingestellt.
    Sagt bitte nicht dass ich erst einen Neustart machen muss das kann ich nämlich nicht.
    Damit keine Missverständnisse entstehen. Der Zeiten OB war in HW Config parametriert aber es war der entsprechende OB nicht in der CPU. Der wurde erst nach dem letztem Neustart eingespielt.
    Zitieren Zitieren Weckalarm wird nicht bearbeitet  

  2. #2
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.709
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    Hallo,
    ich gehe mal davon aus, dass du eine 317 o.ä. hast, die einen OB38 bearbeiten kann.
    Das Aufrufen des OB38 erfolgt wenn er vorhanden ist. Das Zeitintervall (falls du es geändert hast) setzt ein Neu-Übertragen der HW-Konfig voraus und das schaltet dann die CPU in Stop.
    In jedem Fall aber sollte der OB bearbeitet werden - woher weißt du, dass es nicht passiert ?

    Gruß
    Larry

  3. #3
    Uwe16 ist offline Benutzer
    Themenstarter
    Registriert seit
    04.10.2008
    Ort
    Nürnberg
    Beiträge
    98
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Larry,
    ich habe eine CPU 416. Ich habe die voreingestellten Werte d.h. der OB38 müsste im 10mS aufgerufen werden.
    Ich weiss dass er nicht bearbeitet wird weil ich im Status keine bearbeitung sehe und das Datenwort welches hochgezählt wird nicht bearbeitet wird.

  4. #4
    Registriert seit
    25.05.2009
    Ort
    Raum Zürich CH
    Beiträge
    85
    Danke
    15
    Erhielt 15 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Uwe16

    Du sagst, dass in der HW-Konfig der OB38 auf 10ms eingestellt ist und der OB38 geladen wurde. Damit müsste das ja eigentlich funktionieren.
    Aber du sagst auch, dass du keinen Neustart der CPU machen kannst.

    Ich vermute, dass die CPU beim Neustart prüft, ob der OB38 überhaupt vorhanden (geladen) ist und daraufhin die Bearbeitung aktiviert oder deaktiviert.
    Andernfalls würde die CPU möglicherweise einen nichtvorhandenen Baustein aufrufen wollen, ähnlich wie wenn du einen FB aufrufst der nicht geladen wurde.

    Somit würdest du um einen Neustart nicht herumkommen. Wie gesagt: Das ist nur eine Vermutung.
    Wenn das mit dem Neustart wirklich unmöglich oder aufwändig ist, würde ich mal den Siemens-Support kontaktieren.

    Gruss SW-Mech

Ähnliche Themen

  1. Eingang wird nicht bearbeitet
    Von namseg2 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 11.03.2011, 08:12
  2. Netzwerk wird nicht bearbeitet
    Von Servernexus im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 12.02.2011, 12:28
  3. Baustein wird nicht bearbeitet
    Von rabit im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 23.09.2010, 10:48
  4. Generierung wird nicht bearbeitet
    Von Outrider im Forum HMI
    Antworten: 2
    Letzter Beitrag: 18.12.2009, 08:23
  5. Anweisung wird nicht bearbeitet
    Von M-Arens im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 20.05.2005, 16:11

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •