Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Zykluszeit bei Vipa CPU

  1. #1
    Registriert seit
    29.10.2010
    Beiträge
    553
    Danke
    57
    Erhielt 39 Danke für 37 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    muss demnächst eine Anlage programmieren und ich weiß jetzt nicht, ob die CPU schnell genug ist. Vielleicht habt ihr schon ein bißchen Erfahrung und könnt mir sagen ob ich an die Grenzen stoße?

    Die Anlage hat einen Servomotor (SMC) der Klemmstücke unter einem Deprag Schrauber mit AST10 Steuerung herfährt. Der Schrauber schraubt eine Schraube rein, dann fährt der Servomotor ein paar Millimeter weiter und der Schrauber schraubt die nächste Schraube rein, bis das Klemmstück fertig ist. Dann kommt das nächste Klemmstück usw.

    Realisiert werden soll das ganze mit einer Vipa CPU 313SC.

    Wir sollen auf mindestens 50/min Takte kommen, also 50 Schrauben pro min.

    Ich will das ganze in S7 Graph programmieren.

    Bekomme ich Probleme mit der Steuerung, dass die nicht schnell genug ist oder geht das??


    Danke schon mal im vorraus.

    Tschö dennis
    Zitieren Zitieren Zykluszeit bei Vipa CPU  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    50/min = 1/1200ms

    1,2 Sekunden pro Takt.

    Wichtig sind da eher deine Sensoren usw..
    Wie lange steht das kürzeste Signal an der SPS an?
    Wie schnell muss reagiert werden?
    (Zeit haste ja genug für einen Takt)

  3. #3
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Also ich würde auch eher die mechanik als Problem ansehen, da bleiben mit verfahren und zustellen ja vieleicht noch 0,6s zum schrauben.
    Aus meiner Erfahrung mit Schraubern ist das kritisch.
    habt ihr das vom Schrauberhersteller bestätigt bekommen.
    Ich kenne das immer so.

    Maschinenbauer :Wir haben 1,2s taktzeit
    Lieferant : Kein Problem

    Bei der inbetriebnahme
    Taktzeit 3s.
    Maschinenbauer : Wir sind zu langsam.
    Lieferant: wieso wir schaffen es doch in 1,2s
    Maschinenbauer, Ja aber, Schraube laden, Zustellen spindel, verstellen Antrieb gehören ja auch zu Taktzeit.
    Lieferant: Das haben Sie so aber nicht gesagt.
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  4. #4
    dentech ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.10.2010
    Beiträge
    553
    Danke
    57
    Erhielt 39 Danke für 37 Beiträge

    Standard

    Die Anlage ist ja noch nicht mal zusammengebaut. Wir warten noch auf den Schrauber. Nur unserer externer Programmierer hat das vorher ohne S7 graph gemacht und hat mir gesagt, das man durch den Baustein schon 20ms verliert und jetzt wollte ich wissen, ob das aus eurer Erfahrung reicht oder nicht.

  5. #5
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Also die 20ms hängen schon mal von der CPU ab,
    Fakt ist aber das Graph einiges an Performance klaut, egal welche Art von Bausteinaufruf man bei Graph verwendet.

    Ich hatte eine Maschine vor 3-4jahren (also vor Firmware 3 von Siemens) da hatte ich über 20 Graph Ketten drin.
    Zykluszeit bei einer 315PN war um die 100ms, nachdem ich die Ketten z.B. für die Grundstellungsfahrt bei Automatik komplett abgeschaltet habe lage die Zykluszeit bei 65ms.
    Das heisst alleine der Aufruf einer nicht benötigten Kette hat schon eine Zyklusbelastung verursacht.

    Also wenn es hochperformant sein muß würde ich nicht auf Graph setzen.
    Ist meine Meinung.
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  6. #6
    Registriert seit
    21.07.2008
    Beiträge
    1.066
    Danke
    51
    Erhielt 140 Danke für 136 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Meinung von Jabba teile ich auch. Wenn etwas schnell ablaufen muss, dann nicht mit Graph arbeiten.

    Eine Schrittkette in SCL (z.B. mit CASE) ist schon ganz fix. In AWL kannst du es natürlich auf die Spitze treiben, jedoch leidet die "Lesbarkeit".

    Zu beachten ist auch die Kommunikation mit den Umrichtern. Über Profibus kann das schonmal etwas dauern, direkte E/A werden noch ein paar ms rausholen.

    So eine Anlage ist auf jeden Fall vor der Auslieferung getestet werden.

Ähnliche Themen

  1. Probleme mit MPI bei VIPA CPU
    Von mido im Forum Sonstige Steuerungen
    Antworten: 7
    Letzter Beitrag: 16.11.2009, 14:53
  2. Zykluszeit CPU auslese
    Von franzlurch im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 23.10.2007, 16:43
  3. Zykluszeit bei S7 Steuerungen
    Von quant81 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 31.07.2007, 12:43
  4. Zykluszeit bei OB`s
    Von slaesh im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 25.10.2005, 18:00
  5. CPU Zykluszeit
    Von steelbasic im Forum Feldbusse
    Antworten: 0
    Letzter Beitrag: 23.09.2005, 07:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •