Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Indizierter Zugriff SCL Portal V11

  1. #1
    Registriert seit
    20.04.2009
    Beiträge
    44
    Danke
    26
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Liebe SPS Freunde

    SCL in Portal V11

    Ich stehe vor einem sehr simplen Problem, jedoch finde ich den Fehler nicht.


    Ich will über eine Variabel ein Merkerwort aufrufen.

    MW[#test] := 10; ---> funktioniert nicht MW wird rot markiert

    MW[10] := 10; ---> funktioniert nicht MW wird rot markiert

    A[0,0] := false; ---> funktioniert nicht A wird rot markiert

    A[#test1,#test2] := false; ---> funktioniert nicht A wird rot markiert

    DB11.DW[#test] := 10; ---> funktioniert nicht DW wird rot markiert

    DB11.DW[10] := 10; ---> funktioniert nicht DW wird rot markiert


    Ich hoffe Ihr könnt mir sagen wo der Fehler liegt.

    Im Anhang findet ihr noch die Siemens Anleitung zu SCL aber eben ich benutze schon das Portal.

    Folgendes Thema wurde schon mal behandelt mit word_to_block jedoch muss es doch so möglich sein wenn es in der Anleitung steht oder täusche ich mich?

    http://www.sps-foren.de/showthread.p...austein-im-SCL
    http://www.sps-foren.de/showthread.p...Zugriff-auf-DB


    Danke im Voraus

    Gruss Freddy
    Angehängte Dateien Angehängte Dateien
    Geändert von Freddy (24.04.2012 um 16:17 Uhr)
    Zitieren Zitieren Indizierter Zugriff SCL Portal V11  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.262
    Danke
    537
    Erhielt 2.707 Danke für 1.956 Beiträge

    Standard

    Wenn ich recht erinnere wurde doch von eckiger auf runde Klammer umgestellt oder? Ich kann es nicht mehr genau sagen, probiere es doch bitte mal mit runden Klammern aus.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    Freddy (25.04.2012)

  4. #3
    Freddy ist offline Benutzer
    Themenstarter
    Registriert seit
    20.04.2009
    Beiträge
    44
    Danke
    26
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Ralle du bist super Danke vielmal

    Ich dachte zwar das hätte ich auch probiert aber wird wohl nur was ändliches gewesen sein =)


    Das Funktioniert wunderbar:

    wobei #h3 vom Datentyp INT / DINT sein muss

    EW(10) := 40;
    EW(#h3) := 40;
    MW(#h3) := 40;
    MD(#h3) := 40;
    AW(#h3) := 40;
    %DB1.DB(#h3):= 40;
    %DB1.DW(#h3):= 40;
    %DB1.DD(#h3):= 40;
    EX(124,1) := true;
    MX(124,1) := true;
    AX(124,1) := true;
    MX(#h3,#h3) := true;




    Gruss Freddy

  5. #4
    Freddy ist offline Benutzer
    Themenstarter
    Registriert seit
    20.04.2009
    Beiträge
    44
    Danke
    26
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hab da nochmals ne Frage:

    Ist es auch möglich auf Peripheriewörter usw. Zuzugreifen?

    PAW / PEW

    Danke im Voraus

    Gruss Manu

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 17.04.2012, 09:45
  2. TIA V11 SCL Problem mit DB zugriff
    Von epy im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.01.2012, 12:39
  3. indizierter Zugriff auf DB
    Von hammerheadbene im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 27.05.2010, 13:20
  4. Indizierter DB-Zugriff in FUP/KOP ?
    Von HoGe im Forum Programmierstrategien
    Antworten: 3
    Letzter Beitrag: 29.01.2010, 20:36
  5. Indizierter Zugriff auf Datenbaustein im SCL
    Von tarzipan7 im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 05.02.2008, 15:37

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •