Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 26 von 26

Thema: S7-300 als Rollosteuerung verwenden

  1. #21
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von DerMatze Beitrag anzeigen
    also so weit ich es grad vorm Auge habe, verstellst du die Neigung nur via Drehrichtungsumkehr. Also du fährst das Rollo bis auf die gewünschte Position runter, dann ein stück auf = Neigungsverstellung.
    Wenn du das ignorieren möchtest sind die Lamellen immer "zu". Solltest du es in deinem Rollobaustein mit berücksichtigen, kannst du z.B. ein Bit dafür verwenden ob du die Funktion aktiv haben willst oder eben nicht. Wenn aktiv dann fährt das Rollo bei erreichen der gewünschten Position automatisch etwas auf (Neigung).

    Abgesehen davon, dass sich der Herr http://www.sps-forum.de/member.php/42638-g.dominik schon länger nicht gemeldet hat
    muss klar zwischen einer Rollosteuerung und einer Jalousiesteuerung unterschieden werden. Beim Thread geht um eine Rollosteuerung.
    Typischerweise kann man aber jetzt Jalousiesteuerung zu einer Rollosteuerung abrüsten. Umgekehrt muss man da schon etwas
    Code investieren.

    Frank
    Grüße Frank

  2. #22
    g.dominik ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.05.2012
    Beiträge
    22
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Leute
    Hab jetz lang nichts getan, aber jetz möcht ichs noch mal probieren. Ich hab eine kleine Zeichnung von einem Raum angefertigt, aber ich habs noch nicht geschafft. Als Darstellungsart beim Programmieren habe ich FUP gewählt, weils irgendwie einfacher ist für einen "Beginner". Kann mir bitte jemand bei folgender Zeichnung helfen? (so dass ichs verstehe) Hierbei handelt es sich um den ersten Raum.
    Hilfreich für mich währe ein FUP Screen shot bzw. eine Datei mit einer kurzen beschreibunt. Die Wegzeiten der Rollos hab ich für auf und ab dazugeschrieben. Einen Windsensor und Helligkeitssensor hab ich auch.
    Danke für eure Hilfe!
    20120717_081824.jpg

  3. #23
    g.dominik ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.05.2012
    Beiträge
    22
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Habe gestern die Verbindung zur Steuerung aufgebaut. FUNKTIONIERT!
    Bin auch draufgekommen, dass E0.0 und A0.0 nicht geben kann. Heißt jetzt E0.0, E0.1,.. und A6.0, A6.1,...
    Kann mir beim oben genannten Problem keiner helfen?Welchen Timerbaustein ich nehmen muss, und wohin (und mit welchem Baustein) der Windsensor bzw. der Lichtsensor kommt?
    Danke für eure Hilfe

  4. #24
    Registriert seit
    29.11.2005
    Beiträge
    92
    Danke
    11
    Erhielt 11 Danke für 11 Beiträge

    Standard

    Moin,

    Am besten, du verwendest einen FB! Diesen brauchst Du dann nur einmal zu programmieren und kannst ihn im OB1 mehrfach für jeden Rolladen aufrufen.
    In diesem FB legst du zunächst deine Input- und output-Variablen an.

    Input: Taster auf, Taster ab, Sicherheit, Zeit auf, Zeit ab, etc.
    Output: Motor auf, Motor ab, akt. Position, etc.

    In diesem FB nimmst du dann jeweils ein RS-Glied fürs auf- bzw. abfahren.
    Diese werden jeweils über eine pos. Flanke vom Input der Taster gesetzt.
    Sobald diese gesetzt sind, lässt du eine Zeit ablaufen (TONR) mit der Zeit deiner Messung (evtl. umrechnen!).
    ACHTUNG! Verriegelungen einbauen! "Motor auf" und "Motor ab" dürfen auf KEINEN Fall gleichzeitig "1" sein!!!! (Stichwort : UND NICHT)
    Input "Sicherheit" setzt den Auffahrbefehl und resetet den Abfahrbefehl.

    Ich denke, das soll für den Anfang reichen! Wenn du erste Ergebnisse hast, stell diese doch kurz ein! Dann können wir darauf aufbauen!

    Ein kleiner Tipp noch: Nutze die F1-Taste! Objekt, welches nicht klar ist markieren und dann F1!

    MfG

    Der Boeby

  5. Folgender Benutzer sagt Danke zu Boeby für den nützlichen Beitrag:

    g.dominik (17.08.2012)

  6. #25
    g.dominik ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.05.2012
    Beiträge
    22
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die Antwort

    Gestern hab ich den ganzen Abend damit verbracht zu simulieren. Hat aber nicht funktioniert. Kam immer der Fehler "Die PG/PC Schnittstelle ist keiner Schnittstellenparagmetierung zugewisen". Hab´s leider noch nicht hinbekommen.
    Zum simulieren muss ich die Station nicht angeschlossen haben oder? Die Verbindung konnte auch noch nicht hergestellt werden. Hab gestern bei den "Erreichbaren Teilnehmern" nachgesehen, und musste feststellen, dass die Anlage nicht angeführt ist.
    Die Hardware hab ich schon lt. Anleitung konfiguriert.
    (Seckplatz 1 Netzteil, Steckplatz 2 COU, X2 DP Master, Stekcplatz 3 bleibt frei, Steckplatz 4-9 Eingagns und Ausgangskarten)
    Hat die eingegebene Hardware einfluss auf die Simulation?


    Da muss ich wol noch einiges an Zeit investieren.

  7. #26
    Registriert seit
    29.11.2005
    Beiträge
    92
    Danke
    11
    Erhielt 11 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hmm...

    Unter "Systemsteuerung" -> "PG/PC-Schnittstelle" nachschauen... sollte auf die PLC-Sim verweisen!

    Welche Version nutzt Du eigentlich?
    V5.5 oder schon V11?
    Und wie, Steckplatz 3 bleibt frei???

Ähnliche Themen

  1. Array als Grenze verwenden
    Von Bensen83 im Forum HMI
    Antworten: 4
    Letzter Beitrag: 21.03.2011, 09:28
  2. dw laden und als db.dw adressen verwenden
    Von Merlin9000 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 18.06.2008, 21:27
  3. IM171 als DP Master verwenden
    Von Phil im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 18.12.2007, 09:48
  4. Arrays als lokale Variable verwenden
    Von omignobi im Forum HMI
    Antworten: 3
    Letzter Beitrag: 30.09.2005, 08:54
  5. Ausgang als Eingang verwenden?
    Von Anonymous im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 07.05.2005, 18:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •