Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 13 von 13

Thema: Flankenauswertung funzt nicht

  1. #11
    Registriert seit
    17.05.2010
    Ort
    Paderborn
    Beiträge
    824
    Danke
    84
    Erhielt 125 Danke für 94 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Was ist eine Flanke?
    Eine Flanke erkennt die Signaländerung, entweder von "0" -> "1" oder von "1" -> "0"

    Eine Flanke kann und darf nur einen SPS-Zyklus den Zustand "1" haben.

    Und genau mit diesem Signal musst Du arbeiten!

    Ich programmier zwar keine S7-200 aber der Sinn sollte gleich sein:

    U E 0.0........Dein Ereignis kommt
    UN M 10.0....Flankensperrmerker
    = M 10.1......Die eigentliche Flanke
    S M 10.0......Der Spermerker wird gesetzt

    UN E 0.0......Das Ereignis geht
    R M 10.0......Der Sperrmerker wird nichtr mehr benötigt

    Das ist ein Beispiel für eine positive Flanke!
    Grüße
    Michael

    1001101110110100... Das ist meine Welt

  2. #12
    det ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.04.2011
    Ort
    NRW / OWL
    Beiträge
    139
    Danke
    2
    Erhielt 15 Danke für 15 Beiträge

    Standard

    Hallo zusammen,

    jetzt läuft es . Fragt mich bitte nicht warum. Das einzige was ich jetzt anders gemacht habe ist, das ich es in KOP programmiert habe statt AWL. Sollte doch eigentlich egal sein, oder?

    Ein Danke an Alle, die versucht haben zu helfen.

    Grüße Detlef
    Shit happens

  3. #13
    Registriert seit
    17.05.2010
    Ort
    Paderborn
    Beiträge
    824
    Danke
    84
    Erhielt 125 Danke für 94 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nicht ganz, es kann durchaus sein das die Befehlsreihenfolge etwas anders ist!
    Im KOP/FUP werden die Oprerationen bei der Übersetzung oft mit Klammern versehen. Falls es geht (in Step-7 geht es), stell doch mal die Ansicht von KOP auf AWL um und vergleiche mal die Abschnitte.
    Grüße
    Michael

    1001101110110100... Das ist meine Welt

Ähnliche Themen

  1. Negative Flankenauswertung funktioniert nicht
    Von Flacla im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 10.11.2011, 20:08
  2. Funktionstastenbit funzt nicht richtig!
    Von Chris_the_new im Forum HMI
    Antworten: 0
    Letzter Beitrag: 11.08.2010, 11:46
  3. Skript in flexible runtime funzt nicht
    Von DJMetro im Forum HMI
    Antworten: 3
    Letzter Beitrag: 31.05.2010, 15:32
  4. Antworten: 46
    Letzter Beitrag: 13.02.2009, 16:25
  5. Beitrag zum zitieren auswählen - funzt nich
    Von vierlagig im Forum Stammtisch
    Antworten: 19
    Letzter Beitrag: 03.07.2008, 22:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •