Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: AG_Send bei einer FDL Verbindung falsch aufrufen

  1. #1
    Registriert seit
    22.07.2006
    Beiträge
    132
    Danke
    24
    Erhielt 18 Danke für 12 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich darf mich gerade in das Thema FDL Verbindung einarbeiten.

    Der AG_Send Baustein wird in dem Projekt fälschlicherweise immer mit 1 aufgerufen.

    Wird dann nur ein Telegramm gesendet, oder andauernd? Eventuell mit inkonsistenten Daten?
    Zitieren Zitieren AG_Send bei einer FDL Verbindung falsch aufrufen  

  2. #2
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Wo steht denn der "1"er?


    Edit:
    Ich nehme an Du meinst den ACT, dazu Quelle SiemensSupport:
    In der S7-300 bzw. S7 400 CPU wird der Kommunikationsbaustein FC5/50 "AG_SEND/AG_LSEND am Eingangsparameter ACT mit einem Impuls "High" gestartet. Danach muss der Baustein am Eingang ACT mit "Low" solange durchlaufen werden, bis der asynchrone Kommunikationsauftrag entweder mit dem Ausgangsparameter DONE oder ERROR abgeschlossen wurde.

    Also ich retriggere den ACT mit
    O DONE
    O ERROR

    GrußKarl
    Geändert von borromeus (17.05.2012 um 11:10 Uhr)

  3. #3
    Merten1982 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    22.07.2006
    Beiträge
    132
    Danke
    24
    Erhielt 18 Danke für 12 Beiträge

    Standard

    gelöscht..............
    Geändert von Merten1982 (17.05.2012 um 11:39 Uhr)

  4. #4
    Merten1982 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    22.07.2006
    Beiträge
    132
    Danke
    24
    Erhielt 18 Danke für 12 Beiträge

    Standard

    ja den Eingang meine ich, die Frage war ja, wie das Verhalten ist, wenn die Vorgabe nicht beachtet wird.

  5. #5
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Weiss ich leider nicht...

    Siemens sagt nur:
    Send block FC5 "AG_SEND"
    FC5 is activated by the input parameter "ACT" when clock marker M10.7 has a rising edge and "SND_BUSY" is not set. "SND_BUSY" is set while the job is running and no function can be triggered during that time.
    This function block is particularly important because the function is asynchronous and can take several cycles. Constant activation of the function without waiting for it to terminate can cause a communication overload.


    http://support.automation.siemens.co...70&caller=view

    Heisst für mich: kann funktionieren, muss aber nicht.
    Sry...

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 26.10.2012, 17:28
  2. Problem mit FDL-Verbindung
    Von SPS_NEU im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 11.10.2011, 13:17
  3. FDL Verbindung
    Von hbedir im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 02.01.2010, 02:21
  4. fdl-verbindung mit s7-417-4
    Von mknoellner im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 18.05.2009, 08:58
  5. Antworten: 4
    Letzter Beitrag: 04.08.2006, 09:13

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •