Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Probleme mit CPU315 F 2PN/DP

  1. #1
    Registriert seit
    20.05.2012
    Beiträge
    2
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Männer,

    Ich habe folgendes Problem und weiß nicht wo ich ansetzen muss.

    Es geht um einen Umbau von einer CPU 315 F 2PN/DP 315-2FH13-0AB0 Version 2.6 mit einer FDO SM326-DO10x24VDC 2A 326-2BF01-0AB0 Karte

    auf eine CPU CPU 315 F 2PN/DP 3152FJ14-0AB0 Version 3.2 mit einer FDO SM326-DO10x24VDC 2A 326-2BF10-0AB0 Karte.

    Die neue CPU war bereits von meinem Vorgänger übertragen nur die FDO Karte habe ich nach Seriennummer in der Hardware angepasst und anschließend übertragen. Nach Speichern, Übersetzen und Initialisierungsvorgang habe ich die Hardware übertragen und folgenden SF-Fehler im Diagnosepuffer bekommen: Sicherheitsprogramm Interner CPU Fehler. Siehe auch Anhang...

    Ich weiß nicht ob es an den Safety FB,FC,DB's liegt da wurde die wurden ja neu initialisiert! Ich habe Sie schon mal nachgeladen aber damit hatte ich auch keinen Erfolg.
    Kann mir jemand weiter helfen? Printing _Hilfe zum Ereignis 4x7F_Stop_durch_Stopbefehl.pdfPrinting _Hilfe zum Ereignis 7xD1_Sicherheitsprogramm_Interner_CPU_Fehler.pdfDiagnosepuffer_Sicherheitsprogramm_Interner_CPU_Fehler.pdf
    Zitieren Zitieren Probleme mit CPU315 F 2PN/DP  

  2. #2
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Hi,

    hast du alle Möglichkeiten aus der Hilfe deiner PDFs überprüft?
    An der SM-Baugruppe ist ein Codierschalter (in Fachkreisen auch Mäuseklavier genannt), wurde der richtig eingestellt?

    Welchen Zweck diente der Umbau?

    MfG MK
    and we all support the team (S.King - Die Arena)

  3. Folgender Benutzer sagt Danke zu Sinix für den nützlichen Beitrag:

    Fabs (22.05.2012)

  4. #3
    Registriert seit
    28.10.2010
    Ort
    36205 Sontra
    Beiträge
    111
    Danke
    14
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hi,

    ich würde nacheinander alles in Betrieb nehmen (auch das Sicherheitsprogramm).
    Ggfs. erst mal nur SPS, dann 1. Teil Sicherheitsprogramm usw.......

    Irgendwann wird sich der Fehler wiederspiegeln, wenn die CPU technisch OK ist.
    Vielleicht verträgt sich da was nicht im Sicherheitsprogramm.

    Die Ausgangsbaugruppen erfordern auch bei verschiedenen Versionständen teilweise mehr Einstellungen, die in den Hardwareparametern angepasst werden müssen.


    Gruß

  5. Folgender Benutzer sagt Danke zu kliebisch.m für den nützlichen Beitrag:

    Fabs (22.05.2012)

  6. #4
    Fabs ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.05.2012
    Beiträge
    2
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Leute,

    Vielen dank für die Unterstützung. Ich hab den Programmfehler gestern Mittag behoben bekommen . Hab mir das Handbuch und die Getting Started heruntergeladen und zusammen mit Tipps das sehr viel geholfen!

    Die neue F-DO Karte hat mir nach der Hardawareanpassung neue FB's und DB's erzeugt. Auf einem neuen Nummernband.

    Fehler 1. Es waren noch die alten FB's und DB's in der CPU womit die neue Hardware aber nicht arbeiten konnte.

    Fehler 2. Der Kunde hat mir einen falschen Programmstand ausgehändigt. In diesem Projekt war die F DI Karte aus für mich unerklärlichen Gründen nicht konfiguriert. Dadurch warscheinlich auch ständiger Abbruch bei Neuinitialisierung

    Fehler 3. Nach dem Löschen der alten FB's und DB's aus der CPU und übertragen der neuen FB's und DB's hatte das Fehlerprogramm aber noch Zuweisungen aus alten DB's in den Netzwerken.

    Fehler 4. Ohne Neugenerierung des Sicherheitsprogramms und anschließendem Laden bringt ein normales übertragen der FB's und DB's nichts.

    Ich habe also das Komplette Programm mit Systemdaten auf der CPU gelöscht. Dann die Hardware nochmal neu konfiguriert (F-DI Karte und F-DO Karte) und anschließend übersetzen lassen und übertragen. Dann die alten Bausteine aus meinem Projekt gelöscht und die Zweisungen im Fehlerprogramm auf die neuen DB's angepasst. Anschließend das Sicherheitsprogramm neu generieren lassen und laden lassen. Und zum Schluß dann nochmals das komplette Programm (alle Bausteine) übertragen. --- Programmfehler im Sicherheitsprogramm behoben --- CPU und die Anlage funktionieren

    Vielen Dank nochmals
    MFG Fabs

Ähnliche Themen

  1. Beckhoff CX1010 an CPU315-2PN/DP über DP/DP Koppler
    Von Pinmaster im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 05.03.2012, 16:23
  2. TCC mit S7-300(CPU315-2PN/DP) verbinden
    Von PhilippGleich im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.02.2011, 13:42
  3. Antworten: 8
    Letzter Beitrag: 25.01.2010, 20:14
  4. Kopplung CPU315-2PN/DP -->PC
    Von PerfectWorld im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 20.06.2008, 22:50
  5. Cpu315-2pn/dp
    Von Lipperlandstern im Forum Feldbusse
    Antworten: 15
    Letzter Beitrag: 13.04.2008, 23:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •