Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Peripherie Austausch (WAGO -> Siemens)

  1. #1
    Registriert seit
    06.03.2009
    Beiträge
    13
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen.

    An einer Bestehenden Anlage soll eine WAGO Peripherie, wegen Lagerhaltung und Problemen, gegen eine ET200S getauscht werden.
    Nun zum Problem, der Adressbereich für die DI ist 128 - 129, beim Wago mit einem universalmodul Projektiert. Für Siemens werden 4 DI-Module benötigt, EB 128 lässt sich noch Projektieren. Aber EB 129 ist angeblich bellegt.
    In der Adressübersicht ist aber vorher eine Adresslücke bei 128 - 131.
    Woran könnte das liegen?

    CPU: 416-2DP
    Peripherie: IM 151-1 Standart

    mfg Manu81
    Zitieren Zitieren Peripherie Austausch (WAGO -> Siemens)  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.728
    Danke
    729
    Erhielt 1.161 Danke für 972 Beiträge

    Standard

    Du kannst ein Adressmodul nicht mit einer ungeraden Adresse parametrieren.
    Du könntest ja andere Module mit mehr Eingängen nehmen oder musst du ET200S mit 4 4DI Modulen benutzen

  3. #3
    Registriert seit
    03.04.2011
    Beiträge
    1
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,
    habe auch mal vor ein paar Jahre Wago-Klemmn gehen ET200s getauscht wegen Kontaktproblemen bei den Wago-Klemmen in H2S-belasteter Umgebung. Seitdem keine Probleme mehr - Das aber nur am Rande.

    ->"Du kannst ein Adressmodul nicht mit einer ungeraden Adresse parametrieren." ->
    Stimmt so nicht. Man kann problemlos mit EB129 anfangen. Nach dem Eintragen sollte man auf jeden Fall die Module markieren und die Adressen packen ausführen. Danach sind alle Adressen schon hintereinander ohne Lücken.

    Bei älteren CPUs ist diese Funktion nicht möglich (mußte ich beim damaligen Umrüsten der Wago-Klemmen feststellen). Dann hat man nach der Adressen EB128 immer ein Lücke von 4 Byte. Dieses läßt sich auch nicht durch ein Firmware-Update der CPU beheben - Siemens Support.
    Ich habe dann die gesamten Adressen im Programm umadressiert.
    Ob dieses der Fall ist, hängt vom alter der CPU ab.

    Ich hoffe, die Info hilft.
    Diese war übrigens mein erster Beitrag.

    mfg Luap

  4. Folgender Benutzer sagt Danke zu Luap6809 für den nützlichen Beitrag:

    Manu81 (29.06.2012)

  5. #4
    Manu81 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.03.2009
    Beiträge
    13
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Stimmt die CPU ist schon älter ca. 12 Jahre. (2 4DI Module können gepackt werden, danach macht er eine Lücke von 4 Byte)
    Das erklärt dann auch warum es bei einem kleinen Testprogramm (mit anderer CPU) funktioniert hat.

    Danke für die schnellen Antworten.

    mfg Manu81

  6. #5
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.728
    Danke
    729
    Erhielt 1.161 Danke für 972 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Luap6809 Beitrag anzeigen
    ...
    ->"Du kannst ein Adressmodul nicht mit einer ungeraden Adresse parametrieren." ->
    Stimmt so nicht. Man kann problemlos mit EB129 anfangen. Nach dem Eintragen sollte man auf jeden Fall die Module markieren und die Adressen packen ausführen. Danach sind alle Adressen schon hintereinander ohne Lücken.

    ...
    Stimmt. ET200S kann das so.
    Muss mich doch wohl mal wieder in S7 einarbeiten

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 25.11.2011, 10:38
  2. Siemens - Wago Pro/Contra
    Von Rama83 im Forum Simatic
    Antworten: 32
    Letzter Beitrag: 22.10.2011, 04:45
  3. Wago -Siemens Pro/Contra
    Von Rama83 im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 07.10.2011, 15:35
  4. Biete: Wago dezentrale Peripherie
    Von stony im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 06.02.2011, 10:10
  5. WAGO <==> Siemens
    Von hank12 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 15.06.2009, 14:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •