Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Problem mit flatternde Signale

  1. #1
    Registriert seit
    05.10.2010
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe folgendes Problem.

    Ich bekomme über eine Schnittstelle von einer SGM (Spritzgußmaschine) mehrere Signale.

    Wenn ich nur ein Signal bekomme ist alles in Ordnung. Kommen mehrere Signale gleichzeitig in einer Eingangsbaugruppe meiner S7-300 von der SGM an, fangen sie an zu flattern. Schnelles Blinken der LEDs.

    Woran kann das liegen?
    Zitieren Zitieren Problem mit flatternde Signale  

  2. #2
    Registriert seit
    13.10.2007
    Beiträge
    12.067
    Danke
    2.797
    Erhielt 3.288 Danke für 2.168 Beiträge

    Standard

    Vielleicht ein Kurzschluss an einen Eingang?

  3. #3
    Corvax ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.10.2010
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe schon die Baugruppe getauscht. Daran liegt das nicht.

    Kann es sein das eventuell die 24V und die 0V jeweils von der SGM und vom Schaltschrank mit der SPS sich in die Quere kommen?

  4. #4
    Registriert seit
    16.01.2011
    Beiträge
    12
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Corvax Beitrag anzeigen
    Hallo,

    ich habe folgendes Problem.

    Ich bekomme über eine Schnittstelle von einer SGM (Spritzgußmaschine) mehrere Signale.

    Wenn ich nur ein Signal bekomme ist alles in Ordnung. Kommen mehrere Signale gleichzeitig in einer Eingangsbaugruppe meiner S7-300 von der SGM an, fangen sie an zu flattern. Schnelles Blinken der LEDs.

    Woran kann das liegen?
    Wie ist die Schnittstelle aufgebaut? Über Koppelrelais oder direkt von der anderen Steuerung? Vll hast du irgentwo Potenzialverschleppungen...

  5. #5
    Registriert seit
    12.04.2005
    Ort
    Black Forest
    Beiträge
    1.345
    Danke
    28
    Erhielt 131 Danke für 118 Beiträge

    Standard

    Würde einmal den Minus überprüfen und schauen das die Signale Potentialgetrennt kommen!
    Also Du gibst 24 V rüber und die schalten deine 24V und geben das zurück, bzw über Optokoller fahren! Achtung bei Asiatischen Maschinen, die schalten meist den Minus

  6. #6
    Corvax ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.10.2010
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja, ich gebe die 24V zur SGM und diese werden über Relais geschaltet. Ansich dürfte dort keine Potentialverschleppung auftreten.
    Kann das momentan leider nicht nachprüfen. Dieses werde ich am Montag mal genau nachschauen.

  7. #7
    Registriert seit
    06.10.2003
    Beiträge
    3.451
    Danke
    454
    Erhielt 510 Danke für 412 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Prüfe auch, ob die A2-Anschlüsse der Relais wirklich mit der Masse der Maschine verbunden sind. Sind die A2 der Relais nur untereinander verbunden, dann hat man solche Effekte.
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

Ähnliche Themen

  1. .NET Treiber für den Zugriff auf E/A Signale mit C# oder VB.NET
    Von CSharper im Forum Werbung und Produktneuheiten
    Antworten: 2
    Letzter Beitrag: 05.06.2012, 09:33
  2. Amerikanische Encoder Signale?
    Von Hiran im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 15.05.2011, 19:50
  3. Profibus Signale auslesen
    Von Ragnaroek18 im Forum Feldbusse
    Antworten: 8
    Letzter Beitrag: 08.12.2010, 13:44
  4. Antworten: 4
    Letzter Beitrag: 27.08.2010, 00:21
  5. Signale verarbeiten
    Von sr-83 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 12.11.2007, 17:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •