Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 35

Thema: Winkelfunktionen

  1. #11
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    was kommt denn raus, wenn du ein einfach mal 3 zeilen awl eintippst.

    L 0
    COS
    T mw200
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  2. #12
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.402 Danke für 2.001 Beiträge

    Standard

    Hallo,
    vielleicht veröffentlichst du mal das ganze Script ...
    Du schreibst, dass du einen FC verwendest. Wenn du darin bedingt arbeitest kann es das Ergebnis auch schon erklären ...

    Gruß
    Larry

  3. #13
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    Hallo,
    vielleicht veröffentlichst du mal das ganze Script ...
    Du schreibst, dass du einen FC verwendest. Wenn du darin bedingt arbeitest kann es das Ergebnis auch schon erklären ...

    Gruß
    Larry
    Genau deswegen sollte er mal das Miniprogramm von mir laufen lassen. Das spart uns das Durchforsten seines Codes.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  4. #14
    zloyduh ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    11.12.2008
    Beiträge
    226
    Danke
    92
    Erhielt 2 Danke für 2 Beiträge

    Standard

    also ich habe mein Programm in eine andere Steuerung mit der FW2.6 übertragen und da wird alles richtig berechnetl

    in der Steuerung mit der FW3.3.7 nicht..

    es liegt scheinbar an der Steuerung oder evt. an meinem Programm::
    TEMP Variablen???
    Aber warum nur bei Cos()??
    sin() und tan() Funktionen werden richtig berechnet

    gibt es unterschiede zwischen FW2.6 und 3.3??
    Geändert von zloyduh (23.08.2012 um 13:42 Uhr)

  5. #15
    Registriert seit
    13.10.2007
    Beiträge
    12.038
    Danke
    2.789
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    Mit welchen TIA stand hast du deine Baustein erstellt, bei TIA ist es so, das es
    dort gerade bei SCL einige Probleme gab oder vielleicht noch gibt.

    Kannst du den nicht einmal mit Step 7 V5.5 testen.

  6. #16
    zloyduh ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    11.12.2008
    Beiträge
    226
    Danke
    92
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Mit welchen TIA stand hast du deine Baustein erstellt, bei TIA ist es so, das es
    dort gerade bei SCL einige Probleme gab oder vielleicht noch gibt.

    Kannst du den nicht einmal mit Step 7 V5.5 testen.

    TIA V11 SP2 update 4... also die letzte Version..
    Nein leider kann ich nicht mit V5.5 testen...

  7. #17
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    um auszuschliessen, dass es am compiler liegt kannst du doch einfach was in awl schreiben.
    so wie ich das verstanden habe tritt der fehler bei cos von 0 auf.

    also einfach mal

    L 0.0
    cos
    T MD200

    in einem baustein eingeben und beobachten.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  8. #18
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Wenn es denn ein Bug ist und Sinus funktioniert, dann vielleicht umwandeln.

    sin^2(x) + cos^2(x) = 1

    cos(x) = sqrt(1 - sin^2(x))
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  9. #19
    zloyduh ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    11.12.2008
    Beiträge
    226
    Danke
    92
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Habs getestet am Compiler liegt es scheinbar nicht.
    Was mich wundert: wenn das Programm falsch wäre da müsste es auch bei den Maschinen davor nicht funktioniert haben. Es hat aber funktioniert. Habe das gleiche Programm in eine andere Steuerung übertragen => da geht’s


    Das ist die erste Steuerung mit der FW3.3 und schon gibt’s Probleme…

  10. #20
    zloyduh ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    11.12.2008
    Beiträge
    226
    Danke
    92
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Ralle Beitrag anzeigen
    Wenn es denn ein Bug ist und Sinus funktioniert, dann vielleicht umwandeln.

    sin^2(x) + cos^2(x) = 1

    cos(x) = sqrt(1 - sin^2(x))
    ich werds versuchen::

Ähnliche Themen

  1. TwinCat - Winkelfunktionen
    Von nosti im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 28.07.2009, 22:31

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •