Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Vakuum Regelung, Brauch Hilfe

  1. #1
    Registriert seit
    02.07.2012
    Beiträge
    44
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo alle zusammen

    Ich hab ein Problem

    Ich hab eine ET200S mit CPU und benutze Tia V11
    bin leider noch kein Profie...

    mein Problem:
    Ich hab einen Vakuum Pumpstand.
    An einem HMI Display gebe ich einen Wert ein der ereicht werden soll,z.b. Wert X 0,5mb
    Die Pumpe läuft auf 100% bis die Drucksonde in den bereich von Wert X 0,5mb kommt.
    Danach sollte die Pumpe runteregeln und den Wert X halten.


    z.B. 0,6mb = 100%, 0,55mb = Reglung greift ein, Zwischen 0,55 und 0,45mb darf die regelung pendeln so das man mit einer abweichung von 10% den wert halten kann.

    habs zuerest ganz poplig realiesiert hab den wert vom Display so umgerechnet das ich die 10% +/- als wert habe sobald er dann bei 0,55 ankommt regelt er in festvorgeschriebenen schritten nach unten oder wieder hoch, das klapt nur nicht wirklich weil man den wert immer ändern kann und die pumpe unter 1mb mehr leistung brauch und über 2mb weniger leistung brauch.

    Kann mir vileicht jemand weiterhelfen, steh grad voll auf dem Schlauch..

    Hoff Ihr spürt was ich denk

    Danke schon mal im voraus.
    Gruß Philipp
    Zitieren Zitieren Vakuum Regelung, Brauch Hilfe  

  2. #2
    Registriert seit
    21.07.2008
    Beiträge
    1.066
    Danke
    51
    Erhielt 140 Danke für 136 Beiträge

    Standard

    Das heißt das deine Pumpenleistung nicht Proportional zu deinem Sollwert verläuft.

    Soetwas kann man über Tabellen realisieren (also wie muss der Sollwert aussehen, wenn ich um Xmb verringern will)

    Oder man legt den selbstgebauten Zweipunktregler zu Seite und greift zu den fertigen Regelbausteinen..

  3. #3
    Registriert seit
    02.07.2012
    Beiträge
    44
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ja, wen ich den sollwert von 0,5mb ereichen will muss die Pumpe z.b. so regeln 100%,90,80,70,60,... bei einem Sollwert von 2mb ist das aber schon wieder ganz anderst dort müsste man z.b. so regeln 100%,40,30,20

    Und meine Regelung hatt soweit schon Funktioniert aber nur bei unter 1mb und dann immer noch sehr ungenau.

    Was für Regelung kann ich da verwenden gibt es was bei dem ich sagen kann das ist mein sollwert bereich 0,55mb=100% und 0,45mb=10%(min.) und den soll er halten und das egal wie lang es dauert?

  4. #4
    Registriert seit
    21.07.2008
    Beiträge
    1.066
    Danke
    51
    Erhielt 140 Danke für 136 Beiträge

    Standard

    Schau dir mal soetwas an: http://cache.automation.siemens.com/...Bas105deDE.pdf -> Beispiel 4

  5. #5
    Registriert seit
    02.07.2012
    Beiträge
    44
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    so hab mich nochmal durch die ganzen anleitungen und beispiele von Siemens geblättert.

    hab danach dann versucht das über ein CONT_C PI-Regelung aufzubauen.

    Ich hab einen Istwert: über einen Analogen eingang 0-100 (PV_IN)
    dann hab ich den Sollwert: z.b. 10 (wariabel eingabe über Display) (SP_INT)
    und dann den Ausgang der spätter mit dem FU gekoppelt ist (LMN)

    Hab einige eistellungen ausprobiert, aber komm auf keinen grünnen zweig.

    das erste problem ist:
    Ich will es so haben - wen Sollwert 20 und istwert 30 dann sollte Am Ausgang 100% sein.
    Und so passiert es dann - Sollwert 20 und istwert 30 dann am ausgang 10%

    hab ich dann so gelöst dass ich den ausgang umscaliert habe (wen 0% ist dann wird Scalliert 100%)

    zweites Problem:
    wen der Sollwert einmal ereicht worden ist und der istwert wieder seteigt passiert erstmal ne zeitlang garnix (genau so wen er versucht vom istwer auf den sollwert zukommen) ich muss glaub mit dem istwert 40% höher kommen als der sollwert und dann begint er wieder zu regeln, das ist mir aber zu spätt und ich bekomms nicht anderst hin oder ich find nur die einstellung nicht!?

    KP bin total ratlos bin schon fast den ganzen tag nur am testen und probieren...

  6. #6
    Registriert seit
    29.03.2004
    Beiträge
    5.800
    Danke
    144
    Erhielt 1.710 Danke für 1.240 Beiträge

    Standard

    Zitat Zitat von PhSch105 Beitrag anzeigen
    das erste problem ist:
    Ich will es so haben - wen Sollwert 20 und istwert 30 dann sollte Am Ausgang 100% sein.
    Und so passiert es dann - Sollwert 20 und istwert 30 dann am ausgang 10%

    hab ich dann so gelöst dass ich den ausgang umscaliert habe (wen 0% ist dann wird Scalliert 100%)
    Du musst schon dem Regler die Regelung überlassen, deine weitere Skalierung stört eigentlich nur. Wenn du bei einer Regelabweichung von 10 eine Stellgröße von 100% haben willst machst du dieses rein über die Reglerparameter.
    In deinem Fall wäre für Kp (Gain) der Wert von 10,0 einzustellen. Dann würdest du bei einer Abweichung von 10,0 direkt unverzögert die Stellgröße 100,0 ausgegeben bekommen.
    Beträgt deine Regelabweichung hingegen z.B. 1,0 so wird direkt eine Stellgröße von 10,0 ausgegeben. Mal angenommen du hast als Nachstellzeit Ti 10 Sekunden eingestellt, wird die Stellgröße dann alle 10 Sekunden um weitere 10,0 erhöht (natürlich stetig und nicht stufig) und du kommst nach 90 Sekunden ebenfalls bei einer Stellgröße von 100 an.

    Macht dein Regler denn überhaupt etwas? Die Siemens Regler sind oftmals so aufgeblasen dass man schnell mal einen wichtigen Parameter übersieht.

  7. #7
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    575
    Danke
    57
    Erhielt 53 Danke für 47 Beiträge

    Standard

    Idee:
    schon mal angedacht die pumpe laufen zu lassen und eine

    ZULUFT zu regeln?
    also eine BElüftung.
    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)



  8. #8
    Registriert seit
    02.07.2012
    Beiträge
    44
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Erstmal Danke nochmal an alle.

    Senator42: Könnte man machen aber ist nicht gewolt und zudem will ich die Luft rausbekommen und nicht reinlassen und wen man schon ein FU hat dann lieber so.

    Thomas_V2.1: Das mit GAIN 10 Geht nicht bleibt drotz dem verdreht, hab aber rausbekommen wie es den wert richtig anzeigt. Wen ich den Wert In Der Grundeinstellung auf -10 einstellen will geht es nicht aber wen ich es in der Inbetriebnahme Software und am Regeler Selber unter GAIN reinschreibe übernimmt er es kommischerweisse und er zeigt mir den Wert so wie ich ihn brauch. Die Zeiten und die Tolleranz hab ich jetzt auch in den Griff bekommen.

    Habs mal Grob getestet und es hat zumindest schon mal so geregelt wie ich mir das vorgestellt habe, mal kucken was dann beim Test an der Anlage erauskommt.

    Danke nochmal
    Gruß Philipp

Ähnliche Themen

  1. Anfänger brauch hilfe
    Von joch im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.04.2012, 19:40
  2. Ich brauch eure Hilfe
    Von redscorpion im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 02.06.2011, 11:45
  3. Omron cpm1a brauch mal hilfe
    Von iq250 im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 30.01.2009, 21:21
  4. Brauch Hilfe (Schulaufgaben)
    Von Anonymous im Forum Programmierstrategien
    Antworten: 2
    Letzter Beitrag: 10.02.2006, 15:00
  5. Neuling brauch Hilfe
    Von baeckerei-riedel im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 26.08.2005, 12:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •