Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: TIA V11 Projekt von SPS S7-1200 in PG zurückladen

  1. #1
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So, nun muß ich das erste Mal das TIA Portal benutzen (ohne Schulung!) und habe auch gleich für mich unlösbare "Erfolgserlebnisse"

    1. Ich schaffe es nicht, das in einer SPS S7-1212C enthaltene Projekt (komplett: Programm und HW-Konfig) in mein PG zurückzuladen (in ein leeres Projekt). Die in der TIA-Hilfe beschriebenen Wege funktionieren nicht. Der Menübefehl "Online > Gerät in PG/PC laden" bleibt immer hellgrau/deaktiviert, egal was ich im Projektbaum vorher selektiere.
    Ich kann die SPS unter "Erreichbare Teilnehmer" sehen und auch online vorhandene Bausteine öffnen (z.B. OB1), jedoch kann ich nicht die PLC von "Erreichbare Teilnehmer" ins Projekt ziehen; nirgends im Projektbaum ist Drop möglich.
    Was mache ich falsch? Wie muß ich vorgehen, um das Projekt aus der PLC herauszuladen?
    Muß man zum Herausladen exakt die gleiche TIA-Version benutzen, mit der das Programm in die PLC geladen wurde?

    2. Der Lieferant des SPS-Schaltschranks hat uns nun sein "original"-Projekt mitgeliefert. Wenn ich es öffne und mit Online vergleiche, dann meldet mir TIA, daß sämtliche (!) Programmteile unterschiedlich seien ... als Aktion wird mir nur angeboten "In Gerät laden" ...
    Wo kann ich detailliert die Unterschiede Offline/Online sehen?

    Details zu meinen Fragen siehe die angehängten Screenshots.

    Harald
    Angehängte Grafiken Angehängte Grafiken
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet
    Zitieren Zitieren TIA V11 Projekt von SPS S7-1200 in PG zurückladen  

  2. #2
    Registriert seit
    03.11.2009
    Beiträge
    10
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Harald

    Ich hatte das gleiche Problem 1:1 bei einer 315-2DP mit gleicher Software-Konfiguration unter TIA-V11. Ich bin damals zurück auf S7-V5.5 gegangen und hab den Abzug damit gemacht. Ich weiss bis jetzt (so wie Du auch) nicht was ich falsch gemacht habe.

  3. #3
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard

    Vielleicht doch mal ne Schulung machen?!

    Nein im Ernst. Ich weiß, dass es geht, nur leider gerade nicht auswendig.
    Leg mal eine unspezifizierte S7-1200 an und lass dir die Hardware in der Gerätekonfiguration auslesen.
    Dann hättest du schonmal die Hardware. (Bin mir nicht sicher, ob die Bausteine auch geladen werden)

    Wenn du auf den Programmbausteinen einen rechten Mausklick machst, gibts die Option Vergleichen.
    Ich glaub da bist du bei dem letzten Bild schon.
    Dann mal einen rechten Klick auf den Bausteinen und Detailvergleich durchführen.

    Allerdings ungetestet, da ich gerade keine 1200-er zur Hand habe.

    Gruß wolder
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

  4. Folgender Benutzer sagt Danke zu wolder für den nützlichen Beitrag:

    PN/DP (02.10.2012)

  5. #4
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard

    bei der 300-er geht das mit dem auslesen nicht. noch nicht.
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

  6. #5
    Avatar von PN/DP
    PN/DP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    @Uncle Leo
    Zurückgehen auf V5.5 ist leider keine Option, weil S7-1200 ...

    @wolder
    Danke erstmal für die Antworten. Dann werde ich mal zu der SPS hingehen und Deine Vorschläge ausprobieren (auch wenn ich nicht einsehe, daß ich mir den SPS-Inhalt stückweise rauskopieren soll, zumal ich beim ersten mal mit dieser Steuerung dann nicht sicher bin, daß ich "Alles" habe).

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. #6
    Registriert seit
    26.05.2009
    Beiträge
    541
    Danke
    35
    Erhielt 78 Danke für 69 Beiträge

    Standard

    Was mir gerade noch einfällt.
    beim letzten Bild, bei dem Vergleich, kannst du noch auswählen was passieren soll.
    Da wo keine Aktion steht, kann man auch verschieben in beide Richtungen aussuchen.
    Ob das mit dem ganzen Bausteinordner geht kann ich jetzt nicht sagen.

    Vergleichen kannst du auch wenn du den Baustein online und offline nebeneinander legst.
    aber das ist nicht das was du suchst.

    Gruß wolder
    Wenn du denkst du denkst, dann denkst du nur, dass du denkst, denn beim Denken der Gedanken, kommt dir der Gedanke, dass das Denken der Gedanken ein gedankenloses Denken ist

  8. #7
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Wenn man online ist kann man zumindest den Ordner "Programmbausteine" vom Gerät laden. Die Funktion ist verfügbar wenn man online ist und den Programmbausteine-Ordner markiert. Der Abzug ist sogar weitestgehend vollständig, selbst Kommentare in einem DB bleiben erhalten. Nur ggf. ursprünglich angelegte Unterordner zur Programmstrukturierung sind nicht mehr vorhanden.

    Alternativ geht Drag&Drop bei einer bestimmten Konstellation, nämlich wenn der gesamte Ordner "Programmbausteine" aus dem Baum der erreichbaren Teilnehmer in den Programmordner des Offline Projekte geschoben wird. Der Mauszeiger bekommt dann irgendwann ein "+"-Zeichen.

    Was ich noch nicht hinbekommen habe ist sich die HW-Konfig vom Gerät zu laden. Man kann in das Projekt eine "nicht spezifizierte S7-1200" einfügen und dann einen Teil der Konfiguration aus der SPS holen, denn dann hat man zumindest die IP-Adresseinstellungen. Die HW-Konfig ist aber nicht vollständig, und die genauen Unterschiede lassen sich auch nicht herausfinden - zumindest habe ich noch nicht gefunden wie.

  9. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    PN/DP (02.10.2012)

  10. #8
    Avatar von PN/DP
    PN/DP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Über die Hilfskrücke des manuellen Einfügen der "unspezifizierten S7-1200" konnte ich TIA die HW-Konfig "ermitteln" und herauslesen lassen, anscheinend sogar vollständig und korrekt. Auch ein vorhandenes analoges Erweiterungsmodul SM1234 wurde mit herausgelesen. Ich kann aber noch nicht sagen, ob die E/A-Adressen nur Standard-Adressierung sind und ob man die HW-Konfig irgendwie vergleichen kann ...

    Die anderen Projektdaten (Programm, ...) konnte ich danach über "Online > Laden von Gerät" herausladen.
    Allerdings wäre ich da fast schon wieder gescheitert, diesmal am Dialog "Vorschau für das Laden vom Gerät", der erstmal voller wichtiger gelber Ausrufezeichen erklärt, daß "Ladevorgang wird nicht ausgeführt, da Vorbedingungen nicht erfüllt sind." Dabei will der Dialog einfach nur ein Häkchen für "Fortfahren" ...

    Das Detail-Vergleichen der Programmunterschiede hat sich erstmal erledigt, da TIA heute der Meinung ist, die Programmbausteine wären gleich (obwohl ich heute genau das gleiche wie gestern gemacht habe)
    Den Menüpunkt "Detailvergleich" im Kontextmenü habe ich gefunden, doch bleibt der mir bei einem DB mit "Die Daten sind unterschiedlich" trotzdem immer ausgegraut ...

    Leider war es jetzt nicht geplant und ich habe jetzt auch nicht die Zeit, das TIA zu erlernen. Ich merke nur, mit 15 Jahren SIMATIC-Programmierung bin ich für das bunte TIA nicht intuitiv genug. Eigentlich mußte ich nur in der PLC und dem HMI die IP-Adressen ändern, wozu der Lieferant nicht die Lust und das Können hat ...

    Mal sehen, vielleicht belästige ich auch nochmal den Siemens-Support mit der Frage, ob und wie denn das in der TIA-Hilfe beschriebene komplett-Herausladen aus der PLC in ein leeres Projekt funktioniert.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet
    Zitieren Zitieren Herausladen nun geglückt  

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 24.07.2013, 12:12
  2. Antworten: 3
    Letzter Beitrag: 15.05.2012, 17:18
  3. Antworten: 14
    Letzter Beitrag: 22.10.2011, 07:20
  4. S7 1200 Firmwareupdate und TIA V11
    Von ziede im Forum Simatic
    Antworten: 29
    Letzter Beitrag: 09.08.2011, 23:02
  5. TIA V11 Basic: kein Import von 10.5 Projekt
    Von D-DNRN im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 08.06.2011, 11:48

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •