Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 21

Thema: Verbindungsproblem TP 170B Color

  1. #1
    Registriert seit
    05.07.2010
    Beiträge
    68
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich stehe vor folgendem Problem:

    Ein HMI TP 170B Color soll ein neues Adminpasswort bekommen.
    - Ich habe das Projekt
    - Ich habe ProTool, in dem das Projekt einst geschrieben wurde
    - Ich habe WinCC flexible 2008 (mit dem ich besser umgehen kann)
    - Ich habe ein PPI Multimaster Kabel
    - Ich habe ein merkwürdigen Adapter namens CP511/CP5512 an einer PCMCIA Siemens Karte. Der Adapter hat einem 9-Pol SUB-D Stecker.

    Wie zum Geier kriege ich eine Verbindung zum Gerät zustande?
    Welche Schnittstelle am TP 170B ist die richtige zum projektieren? (das Ding hat 3 9-pol Schnittstellen)
    Was für ein Kabel benötige ich um mit dem o.g. Adapter eine Verbindung zum Gerät aufzubauen ? (z.B. Nullmodemkabel o.ä.?)
    Kann ich das TP über das Buskabel programmieren oder muss ich es zunächst vom Gerät abschrauben?

    Fragen über Fragen..... vorab danke.
    Zitieren Zitieren Verbindungsproblem TP 170B Color  

  2. #2
    Draco ist offline Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    68
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Nachtrag:
    besteht die Möglichkeit dies Projekt für WinCC flexible zu konvertieren? Falls ja, wie?

  3. #3
    Registriert seit
    02.10.2012
    Beiträge
    2
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    die Verbindung kann entweder über IF2 (RS232) oder über IF1B (RS485) hergestellt werden. Für die Kommunikation über IF2 benötigst du ein serielles Kabel (nicht Nullmodem!), für die Kommunikation über IF1B benötigst du den PCMCIA-CP und z.B. eine MPI-Steckleitung. In beiden Fällen muss die jeweilige Kommunikationsart in der Systemsteuerung des TPs aktiviert und konfiguriert sein.

    Viel Erfolg!

  4. #4
    Draco ist offline Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    68
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Danke, damit hast du mir zunächst geholfen. Ich muss erstmal passendes Equipment besorgen

  5. #5
    Draco ist offline Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    68
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    So, grade Post bekommen mit ein paar neuen Kabeln. Leider komme ich nicht wirklich weiter.
    Da sich an dem alten PG hier die integrierte serielle Schnittstelle schon länger verabschiedet hat und ich über keine passende PCMCIA Karte verfüge, fällt die serielle Möglichkeit wohl weg.
    Es sei denn, irgendwoher krieg ich ProTool, was unter WIndows 7 auf meinem aktuellen Rechner läuft...

    Im MPI Modus krieg ich keine Verbindung zustande, keine Ahnung warum. In ProTool finde ich unter Datei --> Transfer --> Einstellungen lediglich ein Dropdown ob seriell oder MPI. Keinerlei weitere Einstellmöglichkeiten. Hab dort MPI ausgewählt.
    Im TP 170B Control Panel unter Transfer hab ich Channel 1 disabled und bei Channel 2 MPI ausgewählt sowie Remote Control.

    Keine Verbindung kommt zustande...

  6. #6
    Registriert seit
    02.10.2012
    Beiträge
    2
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ProTool unter Windows7 kannst du vermutlich vergessen. Es sei denn, du bekommst es im XP-Modus (VM) zum Laufen, was ich aber nicht beurteilen kann.

    Die MPI-Schnittstelle muss hinsichtlich der Übertragungsrate auf beiden Seiten gleich konfiguriert sein. Am besten, du stellst in den MPI-Optionen auf dem TP 19,2kbps ein. Auf dem PC musst du in der Systemsteuerung nach "PG/PC-Schnittstelle einstellen" suchen. Dort musst du dann für Protool den Zugangspunkt MPI einstellen und ebenfalls auf 19,2kbps konfigurieren. Dann sollte es passen. Ggf kann man auch 187,5kbps wählen (bei beiden Teilnehmern!), um die Übertragungsdauer zu verkürzen.

  7. #7
    Draco ist offline Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    68
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Nichts zu machen, es gelingt mir nicht eine Verbindung aufzubauen.
    Am PC in der Systemsteuerung, PG/PC Schnittstelle kann ich diverse Zugangspunkte auswählen und die Übertragungsart einstellen. Ein Zugangspunkt namens "ProTool" o.ä. finde ich dort aber nicht.
    Ich habe zwischenzeitlich alle Zugangspunkte wahlweise mit CP5512/MPI sowie CP5512/Auto ausprobiert, alles ohne Erfolg. Die Übertragungsraten sind auf PC als auch im TP auf 19,2 konfiguriert.

    Ganz nebenbei mal so:
    Es ist zum kotzen, dass ein Verbindungsaufbau zwischen PC und Gerät bei Siemens ständig soviel Energie in Anspruch nimmt. Vorletzte Woche dauerte es Tage, bis ich eine erste Verbindung zwischen TP micro und PC hinbekam. Letztes Jahr gleiches Problem beim Verbindungsaufbau mit einer S7..... *nerv*

  8. #8
    Draco ist offline Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    68
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    So dele,

    dank eines freundlichen Users, der mir das Projekt auf WinCC flexible konvertiert hat, bin ich nun in der Lage, am modernen Notebook mit funktionierender serieller Schnittstelle via WinCC flex 2k8 eine Übertragung zu tätigen. THEORETISCH!
    Also das Projekt aufgemacht, als Schnittstelle "seriell" ausgewählt, in der Windows Systemsteuerung Baudrate 115200 eingestellt, gleiches in WinCC flex eingestellt. Im TP den Transfermodus MPI deaktiviert und...... nix geht. Auch über seriell ist kein Verbindungsaufbau möglich (IF2!).
    Zum Einsatz kam ein nagelneues serielles Verbindungskabel mit einer 1:1 Pinbelegung (durchgemessen und geprüft!)
    Auch der Wechsel auf andere Baudraten brachte bislang keinen Erfolg.

    Das TP170B, welches ich hier als Testobjekt liegen habe, kam im August 2012 aus einer Revision zurück und wurde von einer Fachfirma geprüft.

    Das gibts doch gar nicht ?!

  9. #9
    Draco ist offline Benutzer
    Themenstarter
    Registriert seit
    05.07.2010
    Beiträge
    68
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Kann es daran scheitern, dass meine serielle Schnittstelle am Notebook ein ExpressCard Adapter ist?

  10. #10
    Registriert seit
    18.12.2008
    Beiträge
    49
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Warum versuchst du es nicht via MPI? Die Bausrate dabei ist 187,5k. Mit einem Siemens PC USB Adapter geht das völlig problemlos.
    Die in der Systemsteuerung eingestellte Baudrate ist uninteressant, die im WinCC ist entscheidend.
    Ist im Panel die Transferart seriell ausgewählt?

Ähnliche Themen

  1. TP 170b StoppRuntime
    Von HorstPower im Forum HMI
    Antworten: 5
    Letzter Beitrag: 29.01.2012, 17:15
  2. TP 170B Color: RAM nach ROM kopieren
    Von Marco im Forum HMI
    Antworten: 9
    Letzter Beitrag: 02.07.2006, 13:22
  3. TP 170B Color Wandeinbau
    Von xpert im Forum HMI
    Antworten: 7
    Letzter Beitrag: 06.03.2006, 19:40
  4. Drucker an tp 170b
    Von Jochen Kühner im Forum HMI
    Antworten: 4
    Letzter Beitrag: 27.05.2005, 00:03
  5. TP 170B
    Von Lipperlandstern im Forum HMI
    Antworten: 2
    Letzter Beitrag: 10.05.2005, 09:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •