Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 9 von 10 ErsteErste ... 78910 LetzteLetzte
Ergebnis 81 bis 90 von 98

Thema: TCP-SOCKET Kommunikation mit WinAC RTX

  1. #81
    Avatar von rostiger Nagel
    rostiger Nagel ist offline Super-Moderator
    Themenstarter
    Registriert seit
    13.10.2007
    Beiträge
    12.032
    Danke
    2.787
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Thomas,
    das mit den Senden und Verbindung bekomme ich bei mir nicht nachgestellt.
    Ich habe einige Sachen im Büro versucht, also gesendet und die Verbindung
    stehen gelassen, ich bekam bei abgesteckten Stecker keinerlei Fehler.

    Wie geschrieben, denke ich das die Gegenseite mit den Auf und wieder Abbauen nicht
    klarkommt. Ein Handshake habe ich ja schon vorgeschlagen, dann kam ich sollte die Daten
    bei denen in eine Datei schreiben. Nur was ist wenn da wieder neue Probleme auftauchen.

    Was mich so ärgert, die CPU bekomm dieses ja mit, da die Diagnose Lampe angeht.
    Wir bewegen uns ja in der Automatisierungstechnik, da hätte ich erwartet das Siemens
    sich da bei Erstellung solcher Bausteine etwas professioneller verhält. Entweder Werten
    die einen solchen Ausfall aus oder die geben ein die Möglichkeit über ein paar Parameter
    da etwas zu stellen.

  2. #82
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Wenn du den Stecker gezogen hast, warte einfach mal bis zu einer Minute und versuch dann nochmal zu senden (ohne die Verbindung zu trennen). Vielleicht gibt es dann einen Fehler am Tsend-Baustein.
    Durch das TCP wird ein Paket das nicht bestätigt wurde automatisch nach einiger Zeit erneut versendet (glaub bis zu drei Versuche, die Zeit zwischen den Versuchen verlängert sich dabei). Wie Siemens die Zeiten eingestellt hat lässt sich aber in keinem Dokument finden.

    Bei Dalbi kommt ja unmittelbar ein Fehler, der hat aber auch soweit ich weiß eine Intel Netzwerkkarte. In der Step 7 Hardwarekonfiguration kann man bei der Netzwerkkarte die für die SPS zuständig ist nichts dergleichen einstellen. Auf der anderen Karte kann man hingegen die TCP-Keepalives oder auch den Timeout für den Verbindungsaufbau einstellen.

    Was steht denn im Diagnosepuffer wenn die SF Lampe angeht?

  3. #83
    Avatar von rostiger Nagel
    rostiger Nagel ist offline Super-Moderator
    Themenstarter
    Registriert seit
    13.10.2007
    Beiträge
    12.032
    Danke
    2.787
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Da muß ich morgen mal schauen....Fortsetzung folgt....!

  4. #84
    Avatar von rostiger Nagel
    rostiger Nagel ist offline Super-Moderator
    Themenstarter
    Registriert seit
    13.10.2007
    Beiträge
    12.032
    Danke
    2.787
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    so jetzt habe ich mal beobachtet, wann die Fehlermeldung kommt bei gezogenen Stecker, es dauert ca. 30sec., in
    dieser Zeit kann ich fröhlich senden und bekomme einen erfolgreichen Auftrag gemeldet.

  5. #85
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.181
    Danke
    923
    Erhielt 3.289 Danke für 2.658 Beiträge

    Standard

    Die roten SF- und BF-LED sollten aber sofort angehen bei Kabel abziehen. (?) Dann sollte das also auch irgendwie auswertbar sein ...

    Ich vertraue diesen Diagnosemeldungen aber ebenfalls nicht und lege mir immer noch irgendein Handshake oder Lifebit über die Kommunikation.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. #86
    Avatar von rostiger Nagel
    rostiger Nagel ist offline Super-Moderator
    Themenstarter
    Registriert seit
    13.10.2007
    Beiträge
    12.032
    Danke
    2.787
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Wie bereits geschrieben, die Lämpchen werden noch ausgewertet. Handshake ist auch mein
    Primärer Wunsch, leider geht der externe Maschinenbauer nicht darauf ein.

  7. #87
    Registriert seit
    11.08.2009
    Ort
    Bei Hamburg
    Beiträge
    100
    Danke
    19
    Erhielt 30 Danke für 18 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    so jetzt habe ich mal beobachtet, wann die Fehlermeldung kommt bei gezogenen Stecker, es dauert ca. 30sec., in
    dieser Zeit kann ich fröhlich senden
    und bekomme einen erfolgreichen Auftrag gemeldet.
    Eine Situation die am Ende zu einem fatalen Ereignis führen kann....und damit ein Argument für ein Handshake sein sollte.


    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Handshake ist auch mein
    Primärer Wunsch, leider geht der externe Maschinenbauer nicht darauf ein.
    Kann der Maschinenbauer seine (Verweigerungs-)Haltung denn einigermassen Begründen?

    Egal, für zukünftige Investitionen solltet Ihr überlegen ob in die technischen Vorgaben für den Datenaustausch ein Handshake vorschreibt.
    Erstmal alles zerlegen und auf alternative Nutzungsmöglichkeiten untersuchen.

  8. #88
    Registriert seit
    04.02.2011
    Beiträge
    5
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard

    In einer Anwendung bei mir habe ich es so gemacht, dass ich den Status des TRCV-Bausteins (FB64) auswerte und dort auf W#16#80A1 vergleiche, ein Status der eintritt, wenn man das Kabel rauszieht.

  9. #89
    Avatar von rostiger Nagel
    rostiger Nagel ist offline Super-Moderator
    Themenstarter
    Registriert seit
    13.10.2007
    Beiträge
    12.032
    Danke
    2.787
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Zitat Zitat von NochEinProgrammierer Beitrag anzeigen
    Eine Situation die am Ende zu einem fatalen Ereignis führen kann....und damit ein Argument für ein Handshake sein sollte.




    Kann der Maschinenbauer seine (Verweigerungs-)Haltung denn einigermassen Begründen?

    Egal, für zukünftige Investitionen solltet Ihr überlegen ob in die technischen Vorgaben für den Datenaustausch ein Handshake vorschreibt.
    Der andere Maschinenbauer hat eine andere Dimension, deren Open Socket Anwendung ist eine eigene in Hochsprache geschriebene Anwendung
    auf einen Beckhoff Rechner, diese wird in deren Konzern, bei allen Töchtern eingesetzt. Da schrauben die nichts dran rum, auch wenn ich mich auf dem Kopf stelle.

  10. #90
    Registriert seit
    11.08.2009
    Ort
    Bei Hamburg
    Beiträge
    100
    Danke
    19
    Erhielt 30 Danke für 18 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Autsch, also das allseits bekannte "Haben wir schon immer so gemacht und diskutieren da nicht drüber"-Argument.
    Erstmal alles zerlegen und auf alternative Nutzungsmöglichkeiten untersuchen.

Ähnliche Themen

  1. Antworten: 26
    Letzter Beitrag: 02.02.2011, 13:39
  2. Antworten: 10
    Letzter Beitrag: 26.10.2010, 11:24
  3. Antworten: 0
    Letzter Beitrag: 10.08.2010, 09:58
  4. Offene Kommunikation mit WinAC RTX
    Von berty78 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 15.09.2009, 14:01
  5. WinAC RTX + TCP/IP + Mobil Panel
    Von jabba im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 14.09.2008, 17:44

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •