Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 17

Thema: Zeitspeicher ???

  1. #1
    Registriert seit
    10.08.2010
    Beiträge
    770
    Danke
    1
    Erhielt 14 Danke für 13 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    kann mir jemand was zum Thema Zeitspeicher erklären?

    Folgendes ich habe einen FB in dem ich mehrere Zeiten verwende. Ich muss in diesen als Eingang mehrere Timer erstellen. Wenn ich ich einen OB den FB verwende soll ich an den FB die T1-T.. ansetzen. Setze ich diese T1-T.. nicht an funktioniert meine Funktion genau so. Warum kann mann nicht die Timer in STAT Variable ansetzen?

    Im Anhang ein Auszug aus dem DB
    Angehängte Grafiken Angehängte Grafiken
    Geändert von emilio20 (25.10.2012 um 22:14 Uhr)
    Zitieren Zitieren Zeitspeicher ???  

  2. #2
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Ich vermute mal, es geht darum, den FB mehrfach aufrufbar zu machen und bei jedem Aufruf verschiedene S7-Timer zu benutzen. Und das geht nun mal nur, wenn die S7-Timer von außen an den FB übergeben werden.

  3. #3
    Registriert seit
    10.08.2010
    Beiträge
    770
    Danke
    1
    Erhielt 14 Danke für 13 Beiträge

    Standard

    Hier noch ein auszug aus meinen FB und es funktioniert. Muss dazu sagen ich verwende eine Multiinstanz
    Angehängte Grafiken Angehängte Grafiken

  4. #4
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard

    Hast du jetzt fix einen S5 Timer in deinem FB verwendet?
    Dann wird dein Programm nicht funktionieren wenn du den FB öfters aufrufst!
    Verwende die IEC Timer, die kannst du in deinem stat Bereich ablegen.

  5. #5
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von emilio20 Beitrag anzeigen
    Hier noch ein auszug aus meinen FB und es funktioniert. Muss dazu sagen ich verwende eine Multiinstanz
    Sind das zwei verschiedene FB's?

  6. #6
    Registriert seit
    10.08.2010
    Beiträge
    770
    Danke
    1
    Erhielt 14 Danke für 13 Beiträge

    Standard

    Ich rufe in einen OB den FB 50 auf in diesen befinden sich der FB 210 (Belechtung) als Multiinstanz. Dieser existier dort mehrfach

  7. #7
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard

    Und im FB 210 verwendest du jetzt einen Timer?

  8. #8
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von emilio20 Beitrag anzeigen
    Ich rufe in einen OB den FB 50 auf in diesen befinden sich der FB 210 (Belechtung) als Multiinstanz. Dieser existier dort mehrfach
    Du rufst also den FB210 mehrfach auf und benutzt im FB210 2 oder mehr feste S7-Timer? (Wo die Instanz gespeichert ist, spielt dabei keine Rolle.)
    Dann können die verschiedenen Aufrufe eigentlich nicht unabhängig von einander funktionieren, denn woher sollen in diesem Fall die S7-Timer im FB210 wissen, welcher Aufruf gerade läuft und welcher Zeitablauf damit gerade gültig sein soll? Ein fester S7-Timer kann nicht zwischen mehreren Zeiten unterscheiden.

  9. #9
    Registriert seit
    10.08.2010
    Beiträge
    770
    Danke
    1
    Erhielt 14 Danke für 13 Beiträge

    Standard

    Hier mal das Projekt teste mal bei mir geht das
    Angehängte Dateien Angehängte Dateien

  10. #10
    Registriert seit
    03.01.2006
    Ort
    Im sonnigen Süden von Österreich!
    Beiträge
    1.377
    Danke
    227
    Erhielt 183 Danke für 168 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Bei mir funktioniert es nicht.
    Hast du es schon mit PLCSim oder mit der CPU getestet.
    Also bei mir Startet keine Zeit.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •