Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Drahtbruch Meldung bei S7-1200 mit SM1231

  1. #1
    Registriert seit
    02.11.2012
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich beschäftige mich im Moment ein bissel mit der S7-1200. Gelernt haben wir in der Schule jedoch auf S7-300.
    Viele Dinge kann man von der S7-300 auf die S7-1200 ableiten, aber eben nicht alles.

    Ich habe ein SM1231 Modul (Analogmodul für Thermoelemente) welches zwar eine Erkennung für einen Drahtbruch hat, aber ich weiß nicht, wie ich den Fehler "Drahtbruch" auswerten kann. Mir würde ein Signal im Datentyp Bool mehr als ausreichen. Aber irgendwie finde ich dazu überhaupt nichts, wo man den Fehler am Modul abfragen kann.
    Die LEDs am Modul reagieren so wie sie sollen auf einen simulierten Drahtbruch.

    Vielleicht kann mir ja jemand helfen...

    Viele Grüße,
    Kurven_Killer
    Zitieren Zitieren Drahtbruch Meldung bei S7-1200 mit SM1231  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Entweder, die wie ich finde ziemlich aufwändige Tour:
    http://support.automation.siemens.co...ew/de/42781105

    Oder, die von mir in aller Regel bevorzugte Variante:
    Mit 2 Vergleichern den Wert prüfen, ob er sich innerhalb der bezogen auf den Prozess möglichen Grenzen bewegt.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. #3
    Kurven_Killer ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.11.2012
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    viele Dank für deine Antwort.
    Bei mir kommt leider nur die 1. Variante in Frage. Bei der zweiten Variante funktioniert das leider nicht, da ein Drahtbruch gleich 0mv ist - und diese 0mV leider auch ein Temperaturwert haben (Messung zwischen -80mV und 80mV), welcher gemessen wird. Daher muss ich mich auf die Diagnose des Moduls verlassen. Eine andere Möglichkeit ergibt sich mir leider nicht.

    Ich verstehe aber nicht, wie ich mit dem OB82 umgehen soll. Ich benötige ja nur das Bit, welches ich im Fehlerfall einem Kanal zuordnen kann.
    Also quasi so: MW10 Bit 5 = Fehler Kanal 1 = Fehler Gewölbetemperaturfühler (wird dann im HMI angezeigt)

    Wie kann ich die Fehler in z.B. in ein MW schreiben, oder wenn das automatisch geht, wie kann ich den Fehler denn abfragen?

  4. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    a) Im Prinzip ist die OB82 Variante eine Ansammlung div. Vergleicher, womit festgestellt wird, welches Modul bzw. welcher Kanal fehlerhaft ist
    Da du ja nach eigenen Bekunden die S7-300 kennst, also ziemlich ähnlich.

    b) Das 0mV irgendeine Temperatur bedeutet mag wohl sein, aber wie dir sicherlich auffallen dürfte wird das Modul beim abklemmen imho auf 32767 oder -32768 springen.
    Wenn das mit den 0mV also so einfach wäre, dann würde die Drahtbrucherkennung generell nicht funktionieren.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. #5
    Kurven_Killer ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.11.2012
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Manuel,

    nochmal vielen Dank für deine Antwort.

    Zu a)
    Wie muss ich das genau machen? Ich habe auch bei der S7-300 den OB82 noch nicht verwendet, da ich bis jetzt immer die Variante mit -32767 bzw. 32768 oder 0 verwendet habe.
    Ich hab mir den von dir angehängten Link zur Siemens Seite angesehen, aber ganz klar wird es mir leider nicht.

    Zu b)

    Das dachte ich eben auch, aber dann hab ich in den technischen Daten zum SM1231 folgendes gelesen:
    Wenn der Drahtbruchalarm deaktiviert ist und in der Geberverdrahtung ein frei liegender Draht vorliegt, kann das Modul
    zufällige Werte melden.
    Damit klappt es ja mit den beiden oben genannten Werten ja nicht, oder?

    Vielen Dank,
    Simon

  6. #6
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.255
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Also die 1200er kenne ich nicht.
    Bei einer 300er Baugruppe gibts da unterschiedliche Voraussetzungen:
    Drahtbruch wird bei 4-20mA oder 1-5V erkannt (PT100 sowieso).
    ...weiters meist bei Thermoelementen und Thermowiderständen.
    Die Auswertung erfolgt, wie von Manuel beschrieben, im OB82.

    Bei der 7NF10 steht erstaunlicherweise:
    Drahtbruchprüfung

    Die Drahtbruchprüfung steht für Spannungsmessbereiche und den Strommessbereich von 4
    bis 20 mA zur Verfügung.
    Bei einem parametrierten Messbereich von ± 5V, 1 bis 5 V, ± 10 V, 4 bis 20 mA und
    aktivierter Drahtbruchprüung trät die Analogeingabebaugruppe bei Erreichen des
    Unterlaufs (3276 einen Drahtbruch in die Diagnose ein.
    Geändert von borromeus (25.11.2012 um 11:16 Uhr)

  7. #7
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Zitat Zitat von Kurven_Killer Beitrag anzeigen
    Zu b)
    Das dachte ich eben auch, aber dann hab ich in den technischen Daten zum SM1231 folgendes gelesen:
    Damit klappt es ja mit den beiden oben genannten Werten ja nicht, oder?
    Es hat aber nie wer behauptet, das du die Drahtbruchüberwachung abschalten solltest, das würde bei beiden Varianten nicht zum gewünschten Ergebnis führen.
    Hast du scheinbar ja auch nicht, sonst würde dich ja beim "künstlichen" Drahtbruch auch keine rote LED anleuchten.
    Wenn du jetzt beim Drahtbruch auf deinen Einganswert schaust, sollte da eigentlich der Unterlauf-Wert stehen.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  8. #8
    Kurven_Killer ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.11.2012
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo ihr zwei,

    nochmal vielen Dank für euere Hilfe...

    Ich habe es eben nochmal versucht - und es ist tatsächlich so, das wenn ich den Draht abklemme, dass ich dann als Wert 32767 angezeigt bekomme.
    Dann kann ich ja einfach mit dem CMP==1 arbeiten, dann sollte es ohne Probleme gehen.

    Sehr gut - vielen Dank euch beiden. Bin irgendwie total auf dem Schlauch gestanden...

    ____

    Im Moment ärgert mich das HMI noch etwas, ich versuche dort noch die Zeitsynchronisation mit der CPU, aber das will noch nicht so recht.
    Kennt sich da auch jemand aus?

    Vielen Dank,
    Simon

Ähnliche Themen

  1. Temperaturmessung mit NTC und SM1231 TC
    Von Eater_T im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 23.11.2012, 14:50
  2. Störmeldung mit DB Vergleich bei der S7-1200 ?
    Von buffi4711 im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 12.12.2011, 19:09
  3. Antworten: 1
    Letzter Beitrag: 25.06.2009, 18:57
  4. Antworten: 6
    Letzter Beitrag: 23.07.2008, 11:45
  5. Diagnose Drahtbruch bei Analogbaugruppen
    Von handyman im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 09.11.2006, 22:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •