Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 28

Thema: Rolladen S7 1200

  1. #11
    karl20 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    22.11.2011
    Beiträge
    6
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo,

    .. so hätte ich es nie hinbekommen, danke für deine Bemühungen und Verständnis für Anfänger.

    werd gleich loslegen


    DANKE

  2. #12
    Registriert seit
    29.11.2014
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Sorry, wenn ich diesen uralten Thread wieder ausgrabe, aber genau eine solche Funktion, wie von hucki beschrieben, suche ich für meine Rollos.
    Problem: Wenn ich die Software in der Form umsetze, passiert rein gar nichts. Die Eingänge wechseln zwar auf TRUE, bei Tastendruck, aber es wird nichts durchgeschalten.

    Was könnte ich falsch gemacht haben?
    Benutze TIA V13 und eine S7 1200 AC/DC/RLY

  3. #13
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Irgendwie ist meine Glaskugel defekt.


    Welche Bausteine hast Du denn erstellt? Wie hast Du sie dann instanziert? Und wie werden sie aufgerufen?

  4. #14
    Registriert seit
    29.11.2014
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Deine Bausteine aus Post #7 und Post #10

    Ich habe dein Beispiel mehr oder weniger 1:1 umgesetzt (siehe Anhang).

    Übrigens bin ich durch Sucherei auf den Thread gestoßen, weil meine ursprüngliche Umsetzung nicht 100%ig funktioniert hat: Rollosteuerung mit S7 1200 - STOPP-Funktion
    Problem ist hier, dass ich beim "Auffahren" das Rollo nicht mit dem "Zu-Taster" stoppen kann (fährt sofort wieder runter), beim Runterfahren ich aber schon mit dem "Auf-Taster" stoppen kann.
    Angehängte Grafiken Angehängte Grafiken
    Geändert von Imrazor (02.02.2015 um 20:27 Uhr)

  5. #15
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von Imrazor Beitrag anzeigen
    Deine Bausteine aus Post #7 und Post #10
    Ich kann da außer der Anpassung im NW2 Run erstmal weiter nichts Negatives erkennen. Ich persönlich würde dieses UND nicht einfügen, weil das bei Doppelbetätigung von AUF und AB die Dominanz vom STOP löscht.

    Übertragen nicht vergessen? Was zeigt das Beobachten der einzelnen Bausteine? Ist CPU auf RUN?



    Zitat Zitat von Imrazor Beitrag anzeigen
    Ich habe dein Beispiel mehr oder weniger 1:1 umgesetzt (siehe Anhang).Problem ist hier, dass ich beim "Auffahren" das Rollo nicht mit dem "Zu-Taster" stoppen kann (fährt sofort wieder runter), beim Runterfahren ich aber schon mit dem "Auf-Taster" stoppen kann.
    Das hängt meist damit zusammen, das ja nun mal der Baustein für die eine Richtung vor dem der anderen ausgeführt wird. Damit ist u.U. der überwachte Motorzustand dann beim Aufruf des 2. nicht mehr wie vorher. Da hilft meist nur ein statischer Zwischenspeicher der erst nach Ausführung beider Richtungen aktualisiert wird:



    Theoretisch müsste hier eigentlich der Zwischenspeicher für Motor_ab reichen, aber mit beiden sollte man auf Nummer sicher gehen.



    PS: Hab' das jetzt nicht getestet, bin mir aber ziemlich sicher, das dort die Ursache liegt.

  6. #16
    Registriert seit
    29.11.2014
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für deine Rückmeldung!

    Also die Taster AUF und AB kann man nicht gleichzeitig betätigen, da diese "hardwareseitig" gegeneinander verriegelt sind.

    Ich kommt jetzt grad nicht mehr mit
    Setze ich dein Beispiel um, passiert bei Tastendruck gar nichts. Obwohl der Tastendruck erkannt wurde.

    CPU ist auf RUN, DI wird an der CPU erkannt und auch Online im Programm sieht man einen Wechsel von FALSE auf TRUE...

    Das Problem mit dem Runterfahren anstatt zu stoppen, habe ich bei meiner Umsetzung in dem anderen Thread:
    Angehängte Grafiken Angehängte Grafiken
    Geändert von Imrazor (02.02.2015 um 21:38 Uhr)

  7. #17
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von Imrazor Beitrag anzeigen
    Das Problem mit dem Runterfahren anstatt zu stoppen, habe ich bei meiner Umsetzung in dem anderen Thread:
    Dort wird das gleiche Problem sein. Du prüfst in beiden Netzwerken Auffahren und Zufahren, von denen sich aber das Erstausgeführte zwischendurch ändern kann. Für die Abfrage der beiden Werte musst Du sicher auch statische Zwischenspeicher anlegen, die erst nach den beiden Richtungsnetzwerken aktualisiert werden (wie NW3 & 4 im vorigen Post). Wie gesagt, würde ich das auch für beide machen, auch wenn wahrscheinlich einer reichen würde. Kannst ja mal durchtesten.


    Zu meiner Variante:
    Ich kann leider momentan nicht noch mal testen, was ich da oben vor Jahren verbrochen habe. Und wie man im vorigen Post sieht, können sich auch bei jedem leicht Denk-Fehler einschleichen. Da muss ich Dich also leider vertrösten.
    Geändert von hucki (02.02.2015 um 22:02 Uhr)

  8. #18
    Registriert seit
    29.11.2014
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe es dann vorhin noch kapiert
    Ich denke auch fast, dass ein statischer Zwischenspeicher mein Problem lösen könnte. Werde es morgen vor Ort mal testen

    Kein Thema wegen den anderen Bausteinen, du hast mir auch so schon geholfen meiner Lösung näher zu kommen

  9. #19
    Registriert seit
    29.11.2014
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zur Info: mit dem statischen Zwischenspeichern des Motorstatus funktioniert es endlich wie gewollt Danke!

  10. #20
    Registriert seit
    17.06.2014
    Beiträge
    5
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    würde mich ineresieren mit welchm Programm, vielleicht könntest Du noch das funktionierende FB als Screenshot mit den Variablen einstellen ....
    Geändert von s7200user (02.06.2015 um 23:23 Uhr)

Ähnliche Themen

  1. Rolladen steuern mit CodeSys ST
    Von ez2000 im Forum Programmierstrategien
    Antworten: 10
    Letzter Beitrag: 27.02.2012, 14:06
  2. Rolladen und Aussenlicht steuern
    Von Kira2000 im Forum Sonstige Steuerungen
    Antworten: 11
    Letzter Beitrag: 17.12.2010, 14:55
  3. Rolladen Rohrmotor steuern
    Von Al Bundy im Forum Sonstige Steuerungen
    Antworten: 4
    Letzter Beitrag: 11.03.2010, 12:49
  4. Rolladen-/ Jalousiesteuerung mit S5 115U
    Von Joe99 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 14.01.2007, 19:40
  5. Einzeltastersteuerung (f. Rolladen)
    Von ukalou23 im Forum Sonstige Steuerungen
    Antworten: 8
    Letzter Beitrag: 12.07.2005, 11:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •