Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Datenverlust Siemens S7-300

  1. #1
    Registriert seit
    13.01.2009
    Beiträge
    27
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    Ich habe schon seit längerem bei unseren Anlagen beobachtet das die Daten in den Instanz DBs verloren gehen. Wir vermuten das es an kurzzeitigen Spannungseinbrüchen oder Spannungsspitzen liegen könnte. Der Verlust dieser Daten wie Betriebsstunden oder Anlageneinstellungen verursacht immer große Probleme. Es sind teilweise über 1000 Daten die dort dann verloren gehen.
    Der Siemens "super tipp" war es dann die Firmware upzudaten. Wir haben eine 317F 2PN/DP mit Version 2.6.6. Es gibt wohl schon 2.6.11.
    Aber da, dass auch schon seit 3 Jahren ein Thema ist, sollte dieser Fehler doch schon behoben sein?

    Wäre nett wenn ihr von euren Erfahrungen berichten könntet. Vielleicht habt ihr auch schon ähnliches festgestellt.

    Würde mich freuen wenn ihr mir schreibt.

    Mfg KNEFI
    Zitieren Zitieren Datenverlust Siemens S7-300  

  2. #2
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Aber wenn etwas in einem DB liegt, dann geht es doch nicht verloren (dachte ich bisher)
    Ich denke das Problem liegt an der Programmierung der Speicherfunktionen.
    An diesen Stellen würde ich nachschauen.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  3. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.207
    Danke
    927
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard

    Gegen diese "hochsporadischen" Aktualwertverluste hilft tatsächlich nur ein Firmwareupdate.

    Noch besser ist es, für die Daten vernünftige Initialwerte zu vergeben - bei Instanz DB allerdings oft nicht gut realisierbar und für Betriebsstundenzähler sinnlos. Weiters sollte man die CPU so selten wie möglich spannungslos machen und/oder ggf. eine USV einsetzen.

    Weitere Erfahrungen siehe mal Problem: Selbständiges Urlöschen der CPU nach Einschalten der Maschine

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  4. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.735
    Danke
    321
    Erhielt 1.523 Danke für 1.283 Beiträge

    Standard

    Siemens hat dieses Problem in div. Firmwareversionen immer mal wieder,
    und ja, von der Seite her ist der Tip sicherlich alles andere als falsch.
    Obendrein kannst du dir auf der Siemens-Page auch die behobenen Probleme der div. Firmwarestände anschauen.

    Wobei das Problem "Aktualwertverlust" allerdings meistens nur beim Hochlauf der CPU auftritt,
    jedenfalls ist das mein momentaner Kenntnis und Erfahrungsstand.
    Insofern ist auch der Tip von bike u.U. angebracht.

    Zu den Spannungsspitzen:
    Spendier der CPU doch einfach mal ein eigenes Netzteil ... ist definitiv der geringste Aufwand um diese Problematik auszuschließen.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. #5
    KNEFI ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.01.2009
    Beiträge
    27
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für eure Antworten.

    In meinem Fall besitz die CPU ein separates Netzteil von Siemens 5A...
    eine USV würde probleme mit der Spannungsversorgung beim generellen ausschaltern der CPU (Spannungsausfall über mehrere Stunden) nur verschieben und nicht beheben.
    initialwerte sind sicher nicht schlecht aber wie gesagt das geht auch nicht bei allen Daten.
    Außerdem haben wir eine CPU mit remanenten Speicher gekauft die nicht wirklich aus dem billig sektor kommt. Daher erwarte ich eigentlich das die Daten auch remanent sind.

    Gehen wir mal davon aus das die Firmware schuld ist. Warum wird man von Siemens nicht darüber benachrichtigt das es eine neue gibt? Soll ich jetzt jeden Tag gucken? Wir habe Maschinen auf der ganzen Welt würdet ihr die Firmware über remote ändern? Ich bestimmt nicht.

    lg Knefi
    Zitieren Zitieren re@ All  

  6. #6
    Registriert seit
    06.10.2003
    Beiträge
    3.414
    Danke
    451
    Erhielt 506 Danke für 408 Beiträge

    Standard

    Hallo Knefi,

    ist das fehlersichere Programm auch betroffen? Geht die CPU wenigstens in Stopp wenn der Fehler auftritt?


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  7. #7
    KNEFI ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    13.01.2009
    Beiträge
    27
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi
    Ich hätte dazusagen sollen das es Wahrscheinlich nach einem Spannungsausfall passiert ist. Die CPU ist dann wieder "leer" keine Informationen in keinem DB außer aktualwerte wieder gestartet.

    Im F-Bereich haben wir diese Fehler nicht feststellen können da wir keine DBs dort verwenden.
    Zitieren Zitieren Re  

  8. #8
    Registriert seit
    12.09.2006
    Beiträge
    125
    Danke
    26
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hallo,
    ich kenne dieses Problem im zusammenhang mit MMC Karten. Wenn bei dem DB unter Objekteigenschaften nicht der Haken DB_Link gesetzt wurde,waren die DB' nach jedem ausschalten leer. Bin mir aber im moment nicht sicher ob man den Haken setzen oder weg nehmen musste . Das konnte man in dem Fall gut nachstellen. Jedenfalls hat es damit nach aus/einschalten die DB's gerettet. Müsste ich an der Arbeit morgen nach sehen.....

  9. #9
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von KNEFI Beitrag anzeigen
    Im F-Bereich haben wir diese Fehler nicht feststellen können da wir keine DBs dort verwenden.
    Aber in den DB in der F-CPU ist doch auch die Hardware hinterlegt.
    Wenn es generelles Problem mit DB sein sollte müsste es doch Probleme mit der F-Steuerung geben.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  10. #10
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.493
    Danke
    1.142
    Erhielt 1.243 Danke für 974 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Bei uns hängen die CPUs mit eigenem Netzteil VOR dem Hauptschalter.
    Ich würde auf jedenfall die Firmware updaten UND eine neue Speicherkarte einsetzen.

    Bei einer normalen 317er hatte ich mal das Problem mit einer MMC kurz bevor die ganz den Geist aufgab.

    Gruß
    Dieter

Ähnliche Themen

  1. (Teil-) Datenverlust in einem DB
    Von Bär1971 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 12.02.2013, 11:40
  2. Ethernet - Datenverlust
    Von Ninja2602 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 10.04.2012, 14:27
  3. Datenverlust an VIPA S7?
    Von Chräshe im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 18.06.2010, 14:09
  4. schleichender/schlagartiger Datenverlust
    Von frogster im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 10.09.2009, 12:49
  5. Datenverlust?????
    Von Full Flavor im Forum PC- und Netzwerktechnik
    Antworten: 9
    Letzter Beitrag: 20.11.2008, 18:45

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •