Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: TIA Portal Bitmeldungen

  1. #1
    Registriert seit
    04.09.2012
    Beiträge
    252
    Danke
    45
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    hoffe ihr könnt mir weiterhelfen. Ich möchte gerne Fehlermeldugen projektieren. Wenn z.B. ein Zylinder nicht ausfährt, soll diese im Touchpanel angezeigt werden. Habe ein paar Beiträge gelesen, jedoch haben die mir auch nicht geholfen.
    Danke im voraus.

    Gruß
    Zitieren Zitieren TIA Portal Bitmeldungen  

  2. #2
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    [QUOTE=siegener19;421679]Habe ein paar Beiträge gelesen, jedoch haben die mir auch nicht geholfen.
    [/QUOTE

    Haste das hier nicht gefunden, da hab ich sogar ein Beispiel drin.

    Wo genau hängt es denn? Also was hast du bisher realisiert und was nicht?
    CPU/Panel/Softwarestand wären sicher auch hilfreich.

    MfG MK
    and we all support the team (S.King - Die Arena)

  3. #3
    siegener19 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.09.2012
    Beiträge
    252
    Danke
    45
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Ich habe mal mein Programm beigefügt. Wenn das vorkommt, soll im Touchpanel ein Meldetext angezeigt werden. Im Fehler-DB muss ich ja den Datentyp festlegen. Was ist dann mit den HMI-Meldungen?
    Angehängte Dateien Angehängte Dateien

  4. #4
    siegener19 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.09.2012
    Beiträge
    252
    Danke
    45
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Mein Problem. Welchen Datentyp muss ich nehmen im Fehlermedlungen-DB? Wenn ich kein BOOL nehme, habe ich Probleme in meinem FC-Fehler. Denn ich kann BOOL nicht mit einem anderen Datentyp verbinden.

  5. #5
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Zitat Zitat von siegener19 Beitrag anzeigen
    Im Fehler-DB muss ich ja den Datentyp festlegen. Was ist dann mit den HMI-Meldungen?
    Zitat Zitat von siegener19 Beitrag anzeigen
    Denn ich kann BOOL nicht mit einem anderen Datentyp verbinden.
    Warum das denn nicht?
    16Bit = 1Word = 2Byte, du kannst durchaus einzelne Bits einer Wordvariablen beschreiben.
    Einfachstes Beispiel ein Merker:


    Set
    = M50.0

    L MW50 //word ... der Wert ist w#16#1 (0000 0000 0000 0001)

    Meldungen:
    Die Fehlermeldungen werden dem Bit zugewiesen, aber als Word an das HMI übergeben.

    Empfehle nochmal meinen Link in Beitrag #2.
    and we all support the team (S.King - Die Arena)

  6. #6
    siegener19 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.09.2012
    Beiträge
    252
    Danke
    45
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Ich stehe kopmplett auf dem Schlauch. Verzweiflung

  7. #7
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    and we all support the team (S.King - Die Arena)

  8. #8
    siegener19 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.09.2012
    Beiträge
    252
    Danke
    45
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Soll ich etwa noch an den Einstellungen des Touchpanels arbeiten. Ich dachte die Fehlermeldungen werden automatisch angezeigt?!

  9. #9
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Selbstverständlich wird das Panel für sich projektiert.
    Vielleicht solltest du wirklich mal ein Beispiel anschauen.
    and we all support the team (S.King - Die Arena)

  10. #10
    siegener19 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    04.09.2012
    Beiträge
    252
    Danke
    45
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe jetzt eine Meldeanzeige auf ein Bild gezogen und es scheint zu klappen. Irgendwie muss ich das noch quittieren. Ich habe bei meinem Fehler-DB als Datentyp Struct genommen. Für jedes Bit dieses Structs nehme ich jetzt andere Fehlermeldungen. Dann habe ich einen Bit des DBs in die HMI-Variablentabelle genommen und es dort als word deklariert. Scheint irgendwie zu klappen

Ähnliche Themen

  1. Siemens TIA Portal: Bitmeldungen
    Von Leinad im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 26.12.2015, 21:07
  2. Bitmeldungen im TIA Portal
    Von Adrian26 im Forum HMI
    Antworten: 5
    Letzter Beitrag: 06.09.2012, 07:37
  3. Antworten: 0
    Letzter Beitrag: 06.04.2012, 08:37
  4. Antworten: 0
    Letzter Beitrag: 22.01.2012, 18:59
  5. TIA Portal
    Von BadTaste im Forum Simatic
    Antworten: 24
    Letzter Beitrag: 09.12.2011, 07:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •