Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: Durchfluss und Temperaturmessung mit 314IFM

  1. #1
    Registriert seit
    17.12.2007
    Beiträge
    40
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich hätte da mal ein Problem. Ich bin gerade dabei, eine Teststation für Temperiergeräte zu bauen.

    Ich habe eine CPU 314IFM. Dazu ein Touchpanel TP170A. Ich verwende 3 Analogeingänge:

    1. Temperatursensor PT100, angeschlossen über einen Messumformer: 0-200°C / 0-10V
    2. Temperatursensor 0-5 V (sonst keine Angaben?!)
    3. Durchflusssensor 0,5-5V 0-1800l/h

    Die Temperiergeräte haben keine eigene Steuerung, sondern werden an der Spritzgussmaschine von einer Zentralsteuerung gesteuert. Zum testen der einzelnen Geräte benötige ich aber diese Teststation.

    Den 1. Sensor kann ich ohne Probleme visualisieren:

    L PEW130
    L 2000
    *D
    L 27648
    / D
    T MW12

    Das MW12 lasse ich mir am TP anzeigen.


    Nun mein Problem: Wie kann ich die beiden anderen Sensoren anzeigen, bei einem habe ich keine richtigen Angaben, beim zweiten geht es erst bei 0,5V los. Im Moment habe ich auch schon einen INT-Wert für den dritten Sensor, obwohl noch kein Durchfluss ist. Wie kann ich dies alles festlegen? Ich habe mir schon mal den FC105Scale angeschaut, bin aber auch nicht schlau draus geworden?!

    Kann mir jemand helfen?

    Danke und viele Grüße,
    Dominik
    Dominik
    Zitieren Zitieren Durchfluss und Temperaturmessung mit 314IFM  

  2. #2
    Registriert seit
    09.08.2006
    Beiträge
    3.637
    Danke
    912
    Erhielt 661 Danke für 543 Beiträge

    Standard

    zu "3." http://www.sps-forum.de/showthread.p...0-0-10v-(fc106)

    zu "2." Wie wärs damit, mal auf den Sensor/Messumformer zu schauen, welchem Temperaturbereich die 0...5V entsprechen?

    gruß.

  3. #3
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.255
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    1. Du solltest alles mit dem FC105 machen!
    2. Was ist an diesem unklar? Peripheriewort hinschreiben, Obergrenze/Untergrenze und Du bekommst einen Wert im REAL-Format.
    3. Bei 0-5 V = x bis y °C/K kannst Du das nur empirisch ermitteln mit einem Kalibrator der den Sensor auf definierte Werte aufheizt (oder einfach schätzen)
    4. Beim 0,5V bis 5V = 0-1800 l/h einfach als Untergrenze -200.0 und Obergrenze 1800.0 einstellen- da entspricht dann 0l/h 0,5V
    Geändert von borromeus (31.01.2013 um 14:06 Uhr)

  4. #4
    Registriert seit
    22.07.2009
    Ort
    NRW
    Beiträge
    90
    Danke
    1
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Ganz einfach

    OG_Ab-UG_Ab
    ----------------- x (Ana_In - UG_EB) + UG_Ab = Ausgangswert
    OG_EB-UG_EB

    So nun noch schnell nen FC mit IN / OUT und alles ist Prima !!

    Grüße
    wiesel

  5. #5
    Registriert seit
    17.12.2007
    Beiträge
    40
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke,

    so bin ich weitergekommen! Nur mit der Untergrenze von -200 komme ich nicht ganz hin. Ich habe mich rangetastet. Habe jetzt bei einem Wert von -98 einen Anzeigewert von 0.
    Den zweiten Temperatursensor habe ich auch richtig einstellen können. Hat jetzt nahezu den gleichen Wert wie der PT100.

    Nun muss ich NUR noch einen Dreipunktregler mit Kühlventil und Heizung programmieren... noch nie vorher gemacht
    Dominik

  6. #6
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.255
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Zitat Zitat von Dominik2606 Beitrag anzeigen
    Danke,

    so bin ich weitergekommen! Nur mit der Untergrenze von -200 komme ich nicht ganz hin. Ich habe mich rangetastet. Habe jetzt bei einem Wert von -98 einen Anzeigewert von 0.
    Das ist m.E. mit an Sicherheit grenzende Wahrscheinlichkeit gemäß Deinen Angaben falsch.
    Es muss -200.0 sein.

    Ist schon ein Medium im Durchflussmesser?
    Was für eine Spannung gibt der gerade aus? (gemessen)
    Bist Du sicher, dass der 0.5 bis 5 V ausgibt? Ist nämlich eher unüblich.
    Wie heisst das Gerät? Datenblatt?

  7. Folgender Benutzer sagt Danke zu borromeus für den nützlichen Beitrag:

    ducati (01.02.2013)

  8. #7
    Registriert seit
    09.08.2006
    Beiträge
    3.637
    Danke
    912
    Erhielt 661 Danke für 543 Beiträge

    Standard

    Zitat Zitat von Dominik2606 Beitrag anzeigen
    Ich habe mich rangetastet. Habe jetzt bei einem Wert von -98 einen Anzeigewert von 0.
    Manchmal sollte man nicht so viel rumprobieren sondern lieber mal nachdenken und zielgerichtet arbeiten... Aber das ist wie immer nur meine persönliche Meinung...

  9. Folgender Benutzer sagt Danke zu ducati für den nützlichen Beitrag:

    borromeus (01.02.2013)

  10. #8
    Registriert seit
    17.12.2007
    Beiträge
    40
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ohne Wasser hat er fast genau 0,5V.
    Mit -200 komme ich nicht hin?!

    Der Sensor ist von Fa. Regloplas. Datenblatt habe ich leider noch keins. Werd ich aber noch bekommen.
    Dominik

  11. #9
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.255
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Wenn das zB ein IDM ist, und noch keine Flüssigkeit drinnen, zeigt der irgendwas an.

    Bei Regloplas finde ich nur Temperiergeräte.

  12. #10
    Registriert seit
    17.12.2007
    Beiträge
    40
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Regloplas UF100

    Hab grad noch mal nachgemessen:
    Mit Wasser: 0,503V
    Ohne Wasser: 0,521V
    Dominik

Ähnliche Themen

  1. Durchfluss berechnen mit Qh Kurve
    Von omit im Forum Simatic
    Antworten: 30
    Letzter Beitrag: 21.09.2014, 22:10
  2. Temperaturmessung mit NTC und SM1231 TC
    Von Eater_T im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 23.11.2012, 14:50
  3. Biete S7-300 CPU 314IFM mit Ethernet CP
    Von kekerossberg im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 07.03.2011, 21:41
  4. Berechnung Wärme und Durchfluss
    Von SAL im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 01.06.2010, 17:12
  5. Problem mit 314IFM
    Von MSB im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 02.03.2007, 11:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •