Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Pt100

  1. #1
    Registriert seit
    20.07.2012
    Beiträge
    31
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin Leute,
    Ich habe eine S7 CPU 314 IFM und möchte einen PT100 einbinden.
    Momentan besuche ich eine Technikerschule und habe noch keine Erfahrungen mit Analog-Werten.
    Der Messumformer des PT´s gibt ein Signal von 4-20mA aus und bei einer Änderung von einem Grad bei 0,16mA.
    In meiner CPU kann ich nicht direkt einstellen das ich einen PT100 verwende.
    Ich habe lediglich Analoge Eingänge für 0-10V und 0-20mA.
    Es wäre schön wenn mir jemand helfen könnte wie ich den PT100 so einbinde das ich ein Grad Celsius Wert anzeigen kann.

    Mit freundlichen Grüßen Nico Kühn
    Zitieren Zitieren Pt100  

  2. #2
    Registriert seit
    31.03.2010
    Beiträge
    335
    Danke
    3
    Erhielt 33 Danke für 32 Beiträge

    Standard

    Hallo.

    Also du bekommst vom Analog Eingangsmodul Werte zwischen 0 und 27648 welcher dan 0mA bzw. 20mA entspricht!
    Diesen kannst du dann mit dem Functionsbaustein "Scale" an deine Werte anpassen!Diesen findest du in der Standart Library!

    Bei High Limit schreibst du deinen Temperatur Wert welchen du bei 20mA hast.Bei Lo Limit den welchen du bei 0mA hast!
    Danach must du nur noch die Invariable beschalten und Bipolar auf False setzen! Am Ausgang Out steht dann deine aktuell eingelesene Temperatur in der Anwendereinheit!

    Gruß
    Wer aufhört, besser zu werden, hat aufgehört, gut zu sein!

  3. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.166
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Bei LO_LIM gibst Du den Wert an, den Du theoretisch bei 0 mA hättest, wenn Du die Skalierung 4-20 auf 0-20 erweiterst.
    Das ist einfach nur Mathematik.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  4. #4
    Registriert seit
    20.07.2012
    Beiträge
    31
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Vielen dank erstmal für die schnellen Antworten.
    So wie ich das jetzt verstehe soll ich im fc105 für das lo_lim Signal den Wert bei 0mA eingeben den der Sensor nie erreichen wird.
    Bei den Werten +50 Grad = 20mA Und bei -50 Grad = 4mA habe ich einen Temperatur Koeffizienten von 0,16mA pro Kelvin. Das heißt mein lo Signal liegt bei -75 Grad.

  5. #5
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Wenn der 4-20mA von -50°C bis +50°C geht ist dies absolut korrekt.

  6. #6
    Registriert seit
    09.08.2006
    Beiträge
    3.626
    Danke
    911
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Einen Haken hat die Sache jedoch:

    Da manche Sensoren im Fehlerfall 3,6mA rausgeben, würdest Du diesen Wert als fehlerfreien Messwert interpretieren.
    Aber wenn Du diesen Sensorfehler nicht benötigst bzw. da ein Sensorfehler bei Dir in der Schule keinen anlagenkritischen Zustand darstellt, ist das ok so, wie Du es machst. Aber für die spätere Praxis solltest Du das wissen. Besser ne Karte mit 4...20mA einsetzen.

    Gruß.

  7. #7
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Ducati hat recht, Du könntest Dir aber auch bei Unterschreitung von -52,5°C einen internen Alarm bilden.
    Diese angesprochene Grenze(n) nennt sich NAMUR-Grenze. Der Wertebereich liegt zwischen 3,6 und 21 mA

  8. #8
    Registriert seit
    20.07.2012
    Beiträge
    31
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Super... Ich danke euch für die schnelle Hilfe.

Ähnliche Themen

  1. Pt100 Kalibrierung
    Von Magni im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 18.04.2011, 10:50
  2. Pt100
    Von c.wehn im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 20.07.2010, 10:50
  3. Antworten: 10
    Letzter Beitrag: 04.04.2010, 15:47
  4. Pt100
    Von Much2k im Forum Sonstige Steuerungen
    Antworten: 5
    Letzter Beitrag: 07.06.2006, 21:39
  5. PT100 an CPU313C
    Von Ronnie im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 18.05.2006, 10:13

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •