Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 6 von 6 ErsteErste ... 456
Ergebnis 51 bis 55 von 55

Thema: TIA und Step7 erzeugen unterschiedliche Array-Offsets?

  1. #51
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von LowLevelMahn Beitrag anzeigen
    kannst den hier Posten?
    http://support.automation.siemens.co...ew/de/58112582

  2. #52
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Aus dem Liesmich zum TIA Update für V11 SP2 unter Update 4:
    Hantierung von String-Arrays in S7-1200
    Bei CPUs der S7-1200-Baureihe wird dringend empfohlen, ausschließlich eine geradzahlige
    Stringlänge in Arrays zu verwenden. Ansonsten können bei der Verwendung der Anweisung
    "Move: Wert kopieren" Werte überschrieben werden.
    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. #53
    LowLevelMahn ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    22.11.2007
    Beiträge
    731
    Danke
    6
    Erhielt 89 Danke für 62 Beiträge

    Standard

    ACHTUNG KORREKTUR ZU GUSTEN VON SIEMENS: http://www.sps-forum.de/showthread.p...694#post435694
    Geändert von LowLevelMahn (25.03.2013 um 16:30 Uhr)

  4. #54
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Das sieht doch schon besser aus.

    Vielleicht wurde es bei der 1200 nicht korrigiert weil da schon zu viele Geräte von auf dem Markt sind.

    Wobei die 1200er noch ein paar andere Merkwürdigkeiten aufweist. Wenn man z.B. einen Taktimpuls mit dem TON erzeugen will, kann man nicht mehr wie bei der 300/400er einfach den Q negiert auf IN legen. Der Timer läuft dann zwar, aber danach kann man Q nicht mehr als Flanke abfragen. Mal gucken ob da bei V12 auch was korrigiert wurde.

  5. #55
    LowLevelMahn ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    22.11.2007
    Beiträge
    731
    Danke
    6
    Erhielt 89 Danke für 62 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Möglicherweise wurden die anderen Fehler ja auch schon gefixt
    Zitieren Zitieren Jetzt müsste man die anderen hier gemeldeten Fehler testen  

Ähnliche Themen

  1. B+R Automation Studio und Siemens STEP7, TIA und WinCC flexible
    Von Sudoku im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 18.09.2012, 07:57
  2. Step7/TIA und Wago safety
    Von mrtommyt im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 12.12.2011, 08:02
  3. Antworten: 15
    Letzter Beitrag: 07.07.2011, 22:15
  4. WinCC und Step7 Software automatisch erzeugen
    Von WinCC_Novize im Forum HMI
    Antworten: 4
    Letzter Beitrag: 05.11.2010, 00:00
  5. Unterschiedliche Bestellnummern in Step7 v5.3
    Von Anonymous im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 03.10.2005, 16:16

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •