Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 23

Thema: SIMATIC CFC-Programm Test

  1. #11
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    aber klar, als ZIP
    Grüße Frank

  2. #12
    DI87 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.02.2013
    Beiträge
    22
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Habe das Projekt in seiner Schlichtheit mit dran gehängt

    Norbert
    Angehängte Dateien Angehängte Dateien

  3. #13
    Registriert seit
    29.03.2004
    Beiträge
    5.731
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Wo liegt denn das genaue Problem?
    Also beobachten kann ich zumindest alles.
    Nur wird der Ausgang nie geschaltet, das liegt aber an deinem Programm.

    Plan in Plan nutze ich selber nie. Du hast in deinem übergeordneten Plan aber unbeschaltete Ein- und Ausgänge.

  4. #14
    Registriert seit
    09.08.2006
    Beiträge
    3.626
    Danke
    911
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Ich kann alles beobachten, mach mal nen Screenshot, von der Seite die nicht geht. Und schreib mal ausfürhlich was über Dein System, welche SW Versionen etc.

    Gruß.

    PS: nebenbei, les mal in der CFC Bibliothek unter ELEM_300 beim RESTART FC70 die Hilfe, hat zwar nix mit Deinem Problem zu tun, aber für nen sauberes Programm fehlt der noch.
    Geändert von ducati (22.02.2013 um 09:12 Uhr)

  5. #15
    DI87 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.02.2013
    Beiträge
    22
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich hoffe die Pdf Datei mit den screenshots hilft bei der Erklärung des Problems.
    Vielleicht sehe ich auch den Wald vor lauter Bäumen nicht und das Problem liegt wirklich im Programm.
    Ich finde aber keinen Unterschied zum funktionierenden CoDeSys Programm,.......oder......???

    besten Dank an alle die Ihre Zeit opfern

    Norbert
    Geändert von DI87 (22.02.2013 um 17:01 Uhr)

  6. #16
    Registriert seit
    29.03.2004
    Beiträge
    5.731
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Was das mit dem Bobachten auf sich hat kann ich mir auch nicht erklären. Ich habe die gleiche CFC Version wie du. Bist du denn schon an realer Hardware, oder testest du in Plcsim?

    Außerdem sind deine beiden Programme nicht identisch.
    In deinem Codesys Programm geht das Signal "Ein" auf den Rücksetzeingang des FlipFlop, in deinem Siemens Programm aber nicht, dafür hast du dort aber das eine Lichtschrankensignal aufgelegt.
    Bei den Siemens CFC Flipflop muss man auch aufpassen, mit der Dominanz ist es dort nämlich komplett anders als man es aus Siemens FUP kennt. Ich weiß nicht wie sich die Codesys Flilpflops verhalten, würde das aber nochmal überprüfen.

  7. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    DI87 (22.02.2013)

  8. #17
    Registriert seit
    09.08.2006
    Beiträge
    3.626
    Danke
    911
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Zitat Zitat von DI87 Beitrag anzeigen
    das Problem liegt wirklich im Programm.
    Nee, im Programm liegt das Problem (mit dem Beobachten) nicht, da wir ja alles beobachten können. Kann nur mit Deiner Installation oder Art der Simulation oder wie Du beobachtest liegen...

    PS: leg mal in der HW-Konfig EAs an, und teste dann nochmal
    Geändert von ducati (22.02.2013 um 11:22 Uhr)

  9. #18
    DI87 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.02.2013
    Beiträge
    22
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wie konnte es anders sein, natürlich war das Programm fehlerhaft geschrieben. Bei all dem probieren und hin-und-her geschiebe dem löschen und neu-verschalten der Anschlüsse ist wohl einiges durcheinander geraten. Habe die Sachen nochmals als ZIP im Anhang zugefügt. Könnte jemand bitte dieses bei sich ausprobieren und einen Blick über den Ablaufplan werfen. Ich bin einfach ratlos ! Vielleicht liegt es ja wirklich an meiner Installation ...aber wohl eher doch an mir.

    Gruß Norbert

    PS nur in PLCSIM getestet
    Geändert von DI87 (22.02.2013 um 17:03 Uhr)

  10. #19
    Registriert seit
    09.08.2006
    Beiträge
    3.626
    Danke
    911
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Hast Du aus CFC heraus übersetzt und geladen? Nicht im Simaticmanager? MAch im CFC nochmal Gesamtübersetzen und Gesamtladen.

    Gruß.

    PS: und nicht die 2 Probleme durcheinanderwürfeln. Welches lösen wir jetzt zuerst, das Problem mit dem Beobachten oder dass das Programm nicht funktioniert?

    ist die CPU in RUN-P ?

    Du solltest doch mal EAs in der HW Konfig einfügen.

    und was ist mit RESTART ?
    Geändert von ducati (22.02.2013 um 12:59 Uhr)

  11. #20
    Registriert seit
    09.08.2006
    Beiträge
    3.626
    Danke
    911
    Erhielt 656 Danke für 542 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also ich kann das Programm beobachten, und wenn ich die Ein- und Ausgänge mit realen EAs verbinde bekomme ich mit PLCSIM auch den Motor an...

    Gruß.

    PS: in Deinem Plan CFC(1) brauchst Du keine Plananschlüsse. Die brauchst Du nur in Deinem inneren PlanImPlan Foerdern.
    Geändert von ducati (22.02.2013 um 13:31 Uhr)

Ähnliche Themen

  1. Antworten: 7
    Letzter Beitrag: 17.05.2011, 23:18
  2. Programm Simulation &Test
    Von duMMbatz im Forum Simatic
    Antworten: 37
    Letzter Beitrag: 19.04.2011, 08:31
  3. Codesys VISU bzw. Programm Test probleme
    Von mkRE im Forum CODESYS und IEC61131
    Antworten: 9
    Letzter Beitrag: 15.12.2009, 15:26
  4. Test Programm
    Von dido21 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 28.10.2008, 13:32
  5. Simatic CFC: 6.1 mit 7.0 lizens ?
    Von Wiggi0606 im Forum PC- und Netzwerktechnik
    Antworten: 5
    Letzter Beitrag: 06.02.2008, 13:02

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •