Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 22

Thema: Temperaturregler mit PT100

  1. #1
    Registriert seit
    07.12.2005
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Ich habe folgendes Problem, unzwar bin ich neuling auf dem Gebiet SPS technik, und ich möchte mit einer S5 115 U und einer Analogbaugruppe (6es5 465) einen Temperaturregler Realiesieren. Ich habe keine Annung wie Ich erstmal den Analogwert auslesen kann geschweige denn irgendwas zu regeln.
    Eine kleine anregung wäre SUPER.

    Es soll ein zweipunktregler werden.

    vielen dank schon mal im Vorraus
    Zitieren Zitieren Temperaturregler mit PT100  

  2. #2
    Registriert seit
    14.01.2004
    Ort
    Hattorf
    Beiträge
    3.201
    Danke
    297
    Erhielt 311 Danke für 266 Beiträge

    Standard

    Hallo,
    am besten schaust Du dir mal das Handbuch zur 115 an, da ist auch ein Beispiel mit dabei.
    mfg

    dietmar

    Nichts ist so beständig wie ein Provisorium.

  3. #3
    Ronny ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2005
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    mmh....

    Das habe ich gemacht, habe die AWL so abgetipelt wie sie da drin steht. Ich habe die Analogbaugruppe auf steckplatz 0 gesteckt, und habe in dem PB KY 0,4 (Kanal 0 ) denk ich mal .

    Die cpu schreibt quitierungsverzug der Perepherie?

    vieleicht wisst ihr ja eine Lösung.

  4. #4
    Anonymous Gast

    Standard

    so ganz einfach ist das nicht. Wen Du ganz neu bist haste Dir was vorgenommen.
    Bin etwas eingerostetaber.
    Fehler:quitierungsverzug der Perepherie d.H. Baugruppe kann nicht angesprochen werden, oder ist nicht vorhanden.

    1. welchen Baugruppenträger hast Du. Bei Zentralgerät CR700-0(6ES5 700-OLB11) und CR700-3 kannst Du den Steckplatz 0 nicht verwenden (siehe Handbuch Kap. 3).
    2. ist auf dem "IM" Steckplatz (der letzte) eine IM-Baugruppe gesteckt? Wenn ja, welche, IM 305 oder IM 306. Bei IM 305 ist die Adressierung fest vorgegeben. IM 306, hier kann jedem Steckplatz eine Adresse zugewiesen werden. Siehe Handbuch kapitel 5. Feste Steckplatz-Adreßzuweisung und Variable Steckplatz-Adreßzuweisung.
    Wenn garkeine IM, also der IM Steckplatz frei ist, dann muß die Buchsenleiste mit einer Kappe abgedeckt sein (in der Kappe befindet sich eine Drahtbrücke). Ohne diese Kappe ist der Baugruppenträger nicht brauchbar.

  5. #5
    Ronny ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2005
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Gast,

    Ich habe mitlerweile das Problem gelöst es war die Freigabe Leitung die nicht angeschlossen habe.
    Nun habe ich das nächste Problem ich kann zwar den eingang auslesen der Wert den ich auslese schwankt zwischen drei und sechs einheiten.

    gruss Ronny

  6. #6
    Registriert seit
    09.01.2006
    Beiträge
    31
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Prüf mal ob alle Klemm und Steckverbindungen richtig festgezogen sind, daran hab ich mir auch schon mal die Karten gelegt

  7. #7
    Registriert seit
    09.01.2006
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Ronny, hatte letztes mal vergessen mich einzuloggen (Gast).

    ich weis ja nicht in wie weit Du mit der Step5 Programierung vertraut bist.
    Um einen Analogwert (Eingang) erstmal richtig darzustellen, mußt Du das Eingabewort noch dementsprechend aufbereiten. Hierzu ein kleines Beispiel

    L PW128 Analogwert einlesen
    SLW 3 Wort um drei stellen nach links schieben (die ersten 3 Bits zur Auswertung ausblenden, siehe Kap. 10-Seite 24).
    T MW128 jetzt gültigen Analogwert ins Merkerwort 128 Transferieren

    als zweites nimmt man eine Normierung vor, dadurch wird der Wert dann für den dusseligen Menschen übersichtlicher.
    Es ist allerding sehr schwierig eine Ferndiagnose zu stellen, da ich dein Step5 Programm nicht kenn, vieleicht hast Du dies alles ja schon vorgenommen.

  8. #8
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    bit 0-2 sind die fehlerbits.

    also srw3
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  9. #9
    Ronny ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2005
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo endel,

    Ich habe das wie folgt gemacht :

    SPA FB 250

    BG : KF +192

    KNKT :KY 1,4
    ogr :KF +27000
    ugr :KF -27000
    einz :M 0.0
    XA :Mw 10
    FB : m 0.0
    BU :m 0.0
    TBIT :m0.0

    So steht es im Handbuch auf Seite: 10-66. Im MW 10 steht der Wert, aber wenn Ich an den Ausgang einen 100Ohm Wiederstandt anschließe (bei PT 100 0 Crad dann müsten teoredisch im MW 10 O einheiten sein, aber es schwankt zwischen -11 und - 14.

    Meine Kentnisse in step 5 stehen auf dem Anfängerstand (denk ich mal). Ich bekomme zwar ohne Problemme ein und Ausgänge zu schalten etc. aber an der Aufgabe scheine Ich gleglich zu scheitern. Mit deiner AWL habe ich es noch nicht Probiert werde es aber heute mal machen.

    noch zum schluss: Ich arbeite mit s5 für Windows

    gruss Ronny

  10. #10
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Welche Toleranz hat denn Dein 100 Ohm Widerstand, das würde die negative Zahl erklären; die Schwankung ist normal, man nennt das Digitalisierungsfehler bzw -rauschen. Wie bei einem Digitalmultimeter, wo auch nie die letzte Stelle zur Ruhe kommt.

Ähnliche Themen

  1. Antworten: 10
    Letzter Beitrag: 04.04.2010, 15:47
  2. Temperaturregler mit Heizpatrone
    Von 00schneider im Forum Simatic
    Antworten: 28
    Letzter Beitrag: 10.01.2010, 11:44
  3. FB 58 Temperaturregler
    Von rainer-step5 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 19.03.2008, 23:39
  4. Erfahrungswerte Temperaturregler
    Von birdracoon im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 13.03.2006, 21:49
  5. Temperaturregler FB58 kaskadieren
    Von plc_tippser im Forum Programmierstrategien
    Antworten: 5
    Letzter Beitrag: 27.07.2005, 08:52

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •