Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Problem Tranfer von Zeit in S5

  1. #1
    Registriert seit
    09.11.2012
    Beiträge
    82
    Danke
    42
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe folgendes Problem,

    ein Zeitwert aus einem Datenbaustein soll auf eine BCD Anzeige angezeigt werden.

    Was vorhanden ist:

    Ein Panel wo man Sollzeit einstellen kann, sowie die Istzeit angezeigt wird.

    Die Istzeit wird in einem FB berechnet und wird in einem Datenbaustein (DB107 DW0 KF=Zeit) transferiert.

    Ich möchte jetzt gern die Zeit aus dem Datenbaustein DB107 DW0 in BCD auf das AW20 bekommen.

    Die Zeit wird, so wie es für mich aussieht in hex angezeigt.

    Die CPU ist eine 105U

    Die Befehle DTB und ITB funktionieren weder im PB noch in einem FB nicht.
    Einen Timer habe ich auch nicht, sonst könnte ich ja die DEZ stelle nehmen.

    Hoffe irgendjemand hat eine Idee und kann mir da helfen.


    Vielen Dank im vorraus

    Thorsten
    Zitieren Zitieren Problem Tranfer von Zeit in S5  

  2. #2
    Registriert seit
    15.04.2011
    Beiträge
    1.122
    Danke
    229
    Erhielt 208 Danke für 176 Beiträge

    Standard

    Zitat Zitat von bone Beitrag anzeigen
    Die CPU ist eine 105U
    Stimmt die Angabe? Eine 105 kenne ich nur als R, nicht als U.
    Gruß
    190B

  3. #3
    bone ist offline Benutzer
    Themenstarter
    Registriert seit
    09.11.2012
    Beiträge
    82
    Danke
    42
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Oh entschuldige, ist keine 105U sondern eine 115U.

  4. #4
    Registriert seit
    15.04.2011
    Beiträge
    1.122
    Danke
    229
    Erhielt 208 Danke für 176 Beiträge

    Standard

    Die 115U hat einen integrierten FB (FB 241), welcher eine Dual in eine BCD-Zahl wandelt (siehe Anhang).
    Angehängte Dateien Angehängte Dateien
    Gruß
    190B

  5. #5
    bone ist offline Benutzer
    Themenstarter
    Registriert seit
    09.11.2012
    Beiträge
    82
    Danke
    42
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ui super! Funktioniert jetzt!

    Besten Dank

    Gruß Thorsten

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 19.12.2011, 17:42
  2. SIMIT cycle zeit problem
    Von kuldeep im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 31.03.2010, 07:53
  3. Pro Tool / Pro V6.0 Tranfer Problem
    Von Nickel im Forum HMI
    Antworten: 13
    Letzter Beitrag: 28.09.2007, 18:52
  4. Antworten: 0
    Letzter Beitrag: 01.07.2005, 15:38
  5. Ich habe da ein kleines Problem......! Die Zeit läuft!
    Von Anonymous im Forum Sonstige Steuerungen
    Antworten: 6
    Letzter Beitrag: 16.01.2004, 11:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •