Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 27

Thema: Sicherheitsprogramm: Interner CPU-Fehler

  1. #11
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Fenix Beitrag anzeigen
    So, ich hab jetzt mal das Orginalprogramm geladen. Und wieder tritt das Prolem nach ca. 2 Stunden auf.
    Wenn ich den Betriebsartenschalter auf STOP und wieder auf RUN schalte läuft sie wieder eine gewisse Zeit weiter.
    das Orginalprogramm läuft in einer vielzahl von Machienen Problemlos.
    Kann der "Sicherheitsprogramm: Interner CPU-Fehler" mit dem Fehlen der Profibushardware zusammenhängen?
    OB82, OB85 und OB86 ist galden.
    Das mit dem Programm rausrücken ist leider bei uns in der Firma nicht so einfach.
    Bekomme da ärger und wenn ich frage leider ein "No"
    Zu welcher Baugruppe gehört der DB504?
    An dieser Baugruppe ist vermutlich das Problem.
    Wobei ich auch einmal den Abschlusswiderstand/Abschlussplatte von der IM prüfen würde.

    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  2. #12
    Registriert seit
    20.06.2010
    Beiträge
    169
    Danke
    14
    Erhielt 18 Danke für 12 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    Zu welcher Baugruppe gehört der DB504?
    An dieser Baugruppe ist vermutlich das Problem.
    Wobei ich auch einmal den Abschlusswiderstand/Abschlussplatte von der IM prüfen würde.

    bike
    Hi zusammen,

    ich tippe mal einfach dass das Standardprogramm die gleichen Merker M400.x beschreibt wie das F-Programm und dass daher irgendein Prüfprogramm eine Datenverfälschung feststellt.

    Gruß
    Johannes

  3. #13
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Zitat Zitat von JOHKU Beitrag anzeigen
    Hi zusammen,

    ich tippe mal einfach dass das Standardprogramm die gleichen Merker M400.x beschreibt wie das F-Programm und dass daher irgendein Prüfprogramm eine Datenverfälschung feststellt.

    Gruß
    Johannes


    Mit dem Merker 400.x hat es nichts zu tund. der wird jetzt nicht mehr beschrieben, die Symptome sind leider gleich. Nach 2 Stunden ist die CPU tot.

  4. #14
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    Zu welcher Baugruppe gehört der DB504?
    An dieser Baugruppe ist vermutlich das Problem.
    Wobei ich auch einmal den Abschlusswiderstand/Abschlussplatte von der IM prüfen würde.

    bike
    also im Stack steht: 1.DB 2.DB
    OB35 CYC_INT5 DB390 ---
    FC1 F_CALL --- DB504
    FB502 F_CTRL_2 DB500 DB504

    wobei DB 504 Instanz-DB zu FB502 ist
    FB502 ist ja der CTRL_2

    im System sind 2 Sicherheitsklemmen konfiguriert. Eine ist Momentan am PB
    Beide sind auf 2 WAGO Feldbusknoten aufgeteilt.

  5. #15
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard

    ...eins noch,
    Euer Interesse ist wirklich toll!

  6. #16
    Registriert seit
    21.07.2008
    Beiträge
    1.066
    Danke
    51
    Erhielt 140 Danke für 136 Beiträge

    Standard

    Tja.. ich würde das Programm komplett ausdünnen, bis nur noch der entsprechende Sicherheitsbaustein aufgerufen wird. Also das ST-Programm erstmal ausklammern.

    Hardwareprobleme würdest du ja im Diagnosepuffer sehen, aber auch das würde ich beobachten.

    Erstelle mal ein Ticket beim Siemens Support, nicht das es ein Problem mit der CPU Version/ D.Safety Version gibt.

  7. #17
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Also ohne Profibusverbindung zum I/O-Knoten läuft das ganze.
    Jetzt ist mir nur nicht ganz klar, wie der Knoten am Profibus einen Internen CPU-Fehler verursachen kann.

  8. #18
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Fenix Beitrag anzeigen
    Also ohne Profibusverbindung zum I/O-Knoten läuft das ganze.
    Jetzt ist mir nur nicht ganz klar, wie der Knoten am Profibus einen Internen CPU-Fehler verursachen kann.
    Was ist denn ein interner CPU Fehler?
    Das kann alles und nichts sein.

    Ich vermute, dass eine der Zwei CPUs sich verhaspeln und nicht genau einen Fehler ausgeben können.
    Ist an dem Modul die Abschlussplatte richtig montiert?
    Ist das eine neue oder ältere Maschine?
    Hast du Hardwarekonfigration geprüpft, dass die E /A richtig paramtriert sind?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  9. #19
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Was ist denn ein interner CPU Fehler?
    Das kann alles und nichts sein.


    Diagnosepuffereintrag bei Stop:

    Ereignis 1 von 100: Ereignis-ID 16# 457F
    STOP durch STOP-Befehl
    Unterbrechungstelle im Anwenderprogramm: Weckalarm-OB (OB 35)
    Prioritätsklasse: 12
    FB-Nummer: 502
    Bausteinadresse: 180
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)
    interner Fehler, kommendes Ereignis
    14:11:06.391 19.04.2013
    (Kodierung: 16# 457F FF84 8E70 0C23 01F6 00B4)


    Ereignis 2 von 100: Ereignis-ID 16# 75D1
    Sicherheitsprogramm: Interner CPU-Fehler
    Interne Fehlerinformation: 404:0000
    Instanz-DB-Nr. des verursachenden F-Systembausteins: 504
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP
    interner Fehler, kommendes Ereignis
    14:11:06.380 19.04.2013
    (Kodierung: 16# 75D1 9F84 C47A 01F8 0194 0000)


    Ereignis 3 von 100: Ereignis-ID 16# 39B1
    Peripherie-Zugriffsfehler bei Prozeßabbildaktualisierung der Eingänge
    Zugriffsfehler aufgetreten bei Nutzdaten
    Teilprozeßabbild-Nr.: 0
    Anfangsadresse des betroffenen E/A-Bereichs: 308, Länge des Bereichs: 20
    Angeforderter OB: Programmablauffehler-OB (OB 85)
    Prioritätsklasse: 26
    externer Fehler, kommendes Ereignis
    14:11:06.350 19.04.2013
    (Kodierung: 16# 39B1 1A55 5750 2942 0014 0134)

    Ich vermute, dass eine der Zwei CPUs sich verhaspeln und nicht genau einen Fehler ausgeben können.

    Ich hab bei 2 CPU mit unterschiedlicher Firmware das selbe Problem (V2.6.4 und V2.6.6)

    Ist an dem Modul die Abschlussplatte richtig montiert?
    Ja, liegt bei mir aufm Schreibtisch

    Ist das eine neue oder ältere Maschine?
    Nur ein Versuchsaufbau liegt bei mir aufm Schreibtisch. Komponenten sind schon einige Jahre alt.

    Hast du Hardwarekonfigration geprüpft, dass die E /A richtig paramtriert sind?
    Ja, Hardwarekonfiguration wurde mit dem Hersteller der Sicherheitsklemme durchgesprochen und entspricht
    der Konfiguration die 100derte male im Feld läuft.

  10. #20
    Registriert seit
    06.10.2003
    Beiträge
    3.405
    Danke
    447
    Erhielt 502 Danke für 406 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Fenix Beitrag anzeigen
    ..Ereignis 3 von 100: Ereignis-ID 16# 39B1
    Peripherie-Zugriffsfehler bei Prozeßabbildaktualisierung der Eingänge
    Zugriffsfehler aufgetreten bei Nutzdaten
    Teilprozeßabbild-Nr.: 0
    Anfangsadresse des betroffenen E/A-Bereichs: 308, Länge des Bereichs: 20
    Angeforderter OB: Programmablauffehler-OB (OB 85)
    Prioritätsklasse: 26
    externer Fehler, kommendes Ereignis
    14:11:06.350 19.04.2013
    (Kodierung: 16# 39B1 1A55 5750 2942 0014 0134)..
    Das ist doch ein handfester Hinweis auf eine bestimmte Adresse bzw. Baugruppe. Ereignis 1 und 2 würde ich zunächst einmal als Ulk verbuchen. Die auslösende Fehlerursache ist wahrscheinlich Ereignis 3. Wenn du die Funktion "Systemfehler melden" nutzen würdest, bekämst du eventuell konkrete Hinweise auf die Fehlerursache. "Systemfehler melden" projektieren ist in der Onlinehilfe beschrieben.


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

Ähnliche Themen

  1. interner Fehler beim Transferieren!
    Von sago im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 09.02.2009, 13:20
  2. wincc flexible interner FEHLER
    Von sali im Forum HMI
    Antworten: 13
    Letzter Beitrag: 23.07.2008, 12:23
  3. 315-F CPU Passwort Sicherheitsprogramm
    Von mitchih im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 05.07.2007, 21:33
  4. ProTool Fehlermeldung E3499 Interner Fehler?!
    Von plc_tippser im Forum HMI
    Antworten: 7
    Letzter Beitrag: 01.01.2007, 14:37
  5. pdiag - interner fehler
    Von sbbb im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 23.03.2004, 20:16

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •