Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 27

Thema: Sicherheitsprogramm: Interner CPU-Fehler

  1. #1
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen,

    habe leider folgendes Problem mit CPU 315F 2DB Firmware 2.6.4 das die CPU nach einiger zeit in Stop geht
    mit der Meldung: Sicherheitsprogramm:
    Interner CPU-Fehler

    Ereignis 6 von 100: Ereignis-ID 16# 75D1
    Sicherheitsprogramm: Interner CPU-Fehler
    Interne Fehlerinformation: 404:0000
    Instanz-DB-Nr. des verursachenden F-Systembausteins: 504
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP
    interner Fehler, kommendes Ereignis
    10:14:00.455 19.04.2013
    (Kodierung: 16# 75D1 9F84 C47A 01F8 0194 0000)



    Der Fehler kommt erst nach ca. 1-2 Stunden im RUN.
    SPS-Programm wurde zu einem Serienprogramm nur leicht modifiziert und Sicherheitsprogamm neu generiert.

    An der CPU selbst sollte es nicht liegen, da ich die Hardware bereits getauscht habe und das Problem geblieben ist.

    Und nun?
    Zitieren Zitieren Sicherheitsprogramm: Interner CPU-Fehler  

  2. #2
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Hallo,

    ich habe auf der Homepage vom großen S etwas gefunden, evtl. hilft es dir weiter...?

    Gruß
    DerMatze

  3. #3
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard

    danke für den Hinweis,
    den beitrag kannte ich schon von einem anderen Fall aber habs mir nochmals durchgeschaut.
    Die angesprochenen Punkte lösen nicht mein Problem.

    Meine Änderung zum orginal Serienprogramm:

    Ich hab im F_Programmbaustein 4 Netzwerke eingefügt.
    Jedes Netzwerk hat nur eine Verknüpfung.
    NW1 ) UND NICHT E4.0 = M400.0
    NW2) UND NICHT E4.1 = M400.1
    NW3) UND NICHT E4.2 = M400.2
    NW4) UND NICHT E4.3 = M400.1
    (das ganze eben in F-KOP)
    (E4.1 bis E4.3 Sind Sicherheitseingänge)

    ermutlich habe ich gegen irgendeine regel verstoßen, die er beim generieren des Sicherhheitsprogramms nicht anmeckert.
    Wie gesagt, das Programm läuft 1-2 Stunden.
    Geändert von Fenix (19.04.2013 um 14:45 Uhr)

  4. #4
    Registriert seit
    03.04.2008
    Beiträge
    6.205
    Danke
    237
    Erhielt 817 Danke für 691 Beiträge

    Standard

    Wem gehört der DB 504? Das ist vermulich ein IDB.
    Und was ist mit deinem E 4.0?
    Wie sind die Eingänge konfiguriert?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  5. #5
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo,

    DB504 ist ein Instanz Datenbaustein zu FB502 also ein generierter F-DB.
    Die Eingänge sind als SIL 2 Eingänge parametriert

    Ich hab jetzt mal meine Änderung aus dem Sicherheitsprogramm wieder entfernt.
    Leider ist das Ergebis immer noch:

    Ereignis 2 von 100: Ereignis-ID 16# 75D1
    Sicherheitsprogramm: Interner CPU-Fehler
    Interne Fehlerinformation: 404:0000
    Instanz-DB-Nr. des verursachenden F-Systembausteins: 504
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP
    interner Fehler, kommendes Ereignis
    14:11:06.380 19.04.2013
    (Kodierung: 16# 75D1 9F84 C47A 01F8 0194 0000)

    aber wie gesagt, die CPU läuft für ungef 1 Stunde und steigt dann mit dem Fehler aus.
    Geändert von Fenix (19.04.2013 um 15:03 Uhr)

  6. #6
    Registriert seit
    03.04.2008
    Beiträge
    6.205
    Danke
    237
    Erhielt 817 Danke für 691 Beiträge

    Standard

    Ist das der Baustein für das Eingangsmodul 4?
    Oder ist das Problem in einer anderen Ecke vielleicht.
    Steht die Maschine zu dem Zeitpunkt wenn die CPU streikt oder was geschieht in dem Umfeld.
    War das Projekt, bevor du es angefasst hast, fertig übersetzt und hat auch mit der Quersumme mit dem in der CPU übereinstimmt?

    Wenn möglich lade das Projekt hoch, dann kann man schauen wo es zwickt.
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  7. #7
    Registriert seit
    06.10.2003
    Beiträge
    3.445
    Danke
    453
    Erhielt 509 Danke für 411 Beiträge

    Standard

    Zitat Zitat von DerMatze Beitrag anzeigen
    Hallo,

    ich habe auf der Homepage vom großen S etwas gefunden, evtl. hilft es dir weiter...?

    Gruß
    DerMatze
    Zumindest beschreibt der Beitrag das Ereignis 16#75D1.


    @Fenix
    Kannst du Fehler im Standardprogramm ausschließen?
    Hast du mal "Bausteinkonsistenz prüfen" ausgeführt?
    Ein Firmwareupdate auf V.2.6.11 könnte auch nicht schaden.


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  8. #8
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Guten Morgen,

    das Projekt ist konsisten. Ich lade mal in die Steuerung das Orginalprojekt und schaue ob es läuft.
    Also mein Problem spielt sich nur im Büro ab, nicht an einer Maschiene draußen.
    Im Büro ist nur die CPU mit einem Profibusfeldbusknoten mit IOs. Drausen würden noch FUs, usw dran hängen.
    Firmware Update kann ich noch versuchen.
    Das Projekt kann ich leider nicht hochladen.

  9. #9
    Registriert seit
    03.04.2008
    Beiträge
    6.205
    Danke
    237
    Erhielt 817 Danke für 691 Beiträge

    Standard

    Also ich will dein Programm nicht wirklich
    Aber wie soll ich oder andere sehen wo dein Probelm liegt, wenn wir nicht schauen können?
    Ist dein Safeteil auch so geheim?
    Denn eine Firmware brauch ich nicht, ich habe eigene F-CPUs


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  10. #10
    Fenix ist offline Benutzer
    Themenstarter
    Registriert seit
    30.10.2008
    Beiträge
    77
    Danke
    5
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So, ich hab jetzt mal das Orginalprogramm geladen. Und wieder tritt das Prolem nach ca. 2 Stunden auf.
    Wenn ich den Betriebsartenschalter auf STOP und wieder auf RUN schalte läuft sie wieder eine gewisse Zeit weiter.
    das Orginalprogramm läuft in einer vielzahl von Machienen Problemlos.
    Kann der "Sicherheitsprogramm: Interner CPU-Fehler" mit dem Fehlen der Profibushardware zusammenhängen?
    OB82, OB85 und OB86 ist galden.
    Das mit dem Programm rausrücken ist leider bei uns in der Firma nicht so einfach.
    Bekomme da ärger und wenn ich frage leider ein "No"

Ähnliche Themen

  1. interner Fehler beim Transferieren!
    Von sago im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 09.02.2009, 13:20
  2. wincc flexible interner FEHLER
    Von sali im Forum HMI
    Antworten: 13
    Letzter Beitrag: 23.07.2008, 12:23
  3. 315-F CPU Passwort Sicherheitsprogramm
    Von mitchih im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 05.07.2007, 21:33
  4. ProTool Fehlermeldung E3499 Interner Fehler?!
    Von plc_tippser im Forum HMI
    Antworten: 7
    Letzter Beitrag: 01.01.2007, 14:37
  5. pdiag - interner fehler
    Von sbbb im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 23.03.2004, 20:16

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •