Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Finde keine erreichbaren Teilnehmer

  1. #1
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich bin Student, eher Einsteiger im SPS-Bereich und jetzt beauftragt, mich um eine Anlage zu kümmern. Und zwar geht es zuerst darum, vom PC aus Zugang zur CPU zu bekommen um das Programm auslesen und den Anlagenaufbau nachvollziehen zu können. Leider ist das Programm nirgends offline verfügbar.
    Allerdings bekomme ich überhaupt keine erreichbaren Teilnehmer angezeigt. Ich benutze Simatic und gehe über einen USB-Adapter (die Kombination funktioniert bei anderen Anlagen wunderbar) in einen RS 485-Repeater in die Anlage. Habe auch schon versucht direkt in die CPU zu gehen, aber auch ohne Erfolg.

    Zur Anlage: Es handelt sich um eine CPU 414-2DP (414-2XG01-0A0B). Daneben befindet sich ein CP443-1 - Modul und sonst hängt (ich vermute mal über Profibus) einiges anderes dran, wie gesagt auch der RS 485-Repeater.

    An der CPU scheint so manches nicht in Ordnung zu sein. Und zwar leuchtet INTF rot, EXTF für drei Sekunden nach Umstellen auf run auch rot, erlischt dann aber wieder. Desweiteren hat CRST oranges Leuchten, genauso wie STOP (Programm läuft also vermutlich gar nicht ab).
    Rechts daneben gibt's noch ein paar LEDs für DP: rot leuchtet jeweils EXTF und BUSF, INTF ist normal (also keine LED an).

    Da sich hier im Institut niemand sonst mit der Anlage auskennt (war einst nur zu Versuchszwecken aktiv) bin ich sehr auf Hilfe von außerhalb angewiesen. Es super, wenn mir jemand nen Tipp geben könnte, wie ich zumindest mit der CPU kommunizieren kann um überhaupt Aufschluss über Programm und Anlagenkonfiguration zu bekommen.

    Herzlichen Dank und Gruß
    Christoph
    Zitieren Zitieren Gelöst: Finde keine erreichbaren Teilnehmer  

  2. "Danke, konnte jetzt per MPI und Rumprobieren der Baudrate ne Verbindung zur CPU herstellen und die Bausteine auslesen. Der Profibus ist aber aus unerklärlichen Gründen lahmgelegt und somit läuft die Anlage auch nicht an. Gibt's die Möglichkeit den Fehler im Bus irgendwie zu diagnostizieren???
    Und ansonsten hab ich noch das Problem, dass mir die Symboltabelle fehlt und somit viele Adressierungen nicht entschlüsseln kann. Wo wird die Symboltabelle in der CPU hinterlegt - gibt's die Möglichkeit an die ran zu kommen???

    Christoph"


  3. #2
    Registriert seit
    25.07.2005
    Ort
    Vogelsbergkreis
    Beiträge
    1.715
    Danke
    48
    Erhielt 68 Danke für 60 Beiträge

    Standard

    Zitat Zitat von Gigo
    Hallo,

    ich bin Student, eher Einsteiger im SPS-Bereich und jetzt beauftragt, mich um eine Anlage zu kümmern. Und zwar geht es zuerst darum, vom PC aus Zugang zur CPU zu bekommen um das Programm auslesen und den Anlagenaufbau nachvollziehen zu können. Leider ist das Programm nirgends offline verfügbar.
    Allerdings bekomme ich überhaupt keine erreichbaren Teilnehmer angezeigt. Ich benutze Simatic und gehe über einen USB-Adapter (die Kombination funktioniert bei anderen Anlagen wunderbar) in einen RS 485-Repeater in die Anlage. Habe auch schon versucht direkt in die CPU zu gehen, aber auch ohne Erfolg.

    Zur Anlage: Es handelt sich um eine CPU 414-2DP (414-2XG01-0A0B). Daneben befindet sich ein CP443-1 - Modul und sonst hängt (ich vermute mal über Profibus) einiges anderes dran, wie gesagt auch der RS 485-Repeater.

    An der CPU scheint so manches nicht in Ordnung zu sein. Und zwar leuchtet INTF rot, EXTF für drei Sekunden nach Umstellen auf run auch rot, erlischt dann aber wieder. Desweiteren hat CRST oranges Leuchten, genauso wie STOP (Programm läuft also vermutlich gar nicht ab).
    Rechts daneben gibt's noch ein paar LEDs für DP: rot leuchtet jeweils EXTF und BUSF, INTF ist normal (also keine LED an).

    Da sich hier im Institut niemand sonst mit der Anlage auskennt (war einst nur zu Versuchszwecken aktiv) bin ich sehr auf Hilfe von außerhalb angewiesen. Es super, wenn mir jemand nen Tipp geben könnte, wie ich zumindest mit der CPU kommunizieren kann um überhaupt Aufschluss über Programm und Anlagenkonfiguration zu bekommen.

    Herzlichen Dank und Gruß
    Christoph
    Hast du es über MPI oder PROFIBUS versucht. Du musst jeweils die Schnittstelle umstellen. Würde beides mal probieren und auch mal die PG-Adresse mal wechseln.
    Zitieren Zitieren Re: Finde keine erreichbaren Teilnehmer  

  4. #3
    Anonymous Gast

    Standard

    Danke, konnte jetzt per MPI und Rumprobieren der Baudrate ne Verbindung zur CPU herstellen und die Bausteine auslesen. Der Profibus ist aber aus unerklärlichen Gründen lahmgelegt und somit läuft die Anlage auch nicht an. Gibt's die Möglichkeit den Fehler im Bus irgendwie zu diagnostizieren???
    Und ansonsten hab ich noch das Problem, dass mir die Symboltabelle fehlt und somit viele Adressierungen nicht entschlüsseln kann. Wo wird die Symboltabelle in der CPU hinterlegt - gibt's die Möglichkeit an die ran zu kommen???

    Christoph

  5. #4
    Registriert seit
    25.07.2005
    Ort
    Vogelsbergkreis
    Beiträge
    1.715
    Danke
    48
    Erhielt 68 Danke für 60 Beiträge

    Standard

    Zitat Zitat von Gigo
    Danke, konnte jetzt per MPI und Rumprobieren der Baudrate ne Verbindung zur CPU herstellen und die Bausteine auslesen. Der Profibus ist aber aus unerklärlichen Gründen lahmgelegt und somit läuft die Anlage auch nicht an. Gibt's die Möglichkeit den Fehler im Bus irgendwie zu diagnostizieren???
    Und ansonsten hab ich noch das Problem, dass mir die Symboltabelle fehlt und somit viele Adressierungen nicht entschlüsseln kann. Wo wird die Symboltabelle in der CPU hinterlegt - gibt's die Möglichkeit an die ran zu kommen???

    Christoph
    Die wird garnicht hinterlegt... Naja ich kenn deine Anlage nicht. Dein Profibus-Problem kann viele Ursachen haben.

  6. #5
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.209
    Danke
    629
    Erhielt 952 Danke für 766 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn das Projekt nicht auf die Memorykarte übertragen wurde, dann gibt es keine Symbole und auch keine Kommentare in der SPS. Da bleibt nur der nackte Code übrig
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

Ähnliche Themen

  1. PC erkennt keinen Erreichbaren Teilnehmer
    Von Robotiker im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 22.11.2011, 08:47
  2. Finde keine Siwarex FTA in der HWconfig
    Von edijump im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 04.05.2011, 09:36
  3. Wie finde ich PEW/PAW
    Von Microby im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 31.03.2009, 22:00
  4. Antworten: 1
    Letzter Beitrag: 06.02.2009, 22:36
  5. Wo finde ich den FB29
    Von Quintarus im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 14.05.2007, 21:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •