Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: FC12: Systemfehler bzw. unzulässiger Parametertyp

  1. #1
    Registriert seit
    07.02.2013
    Beiträge
    4
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebes Forum,

    ich möchte einen Gasanalyseschrank (IM 153-3PN) über eine CP 343-1 Lean an meine SPS anbinden und auslesen.
    Die Verbindung über Profinet sollte ok sein. Ich kann den Gasanalyseschrank anpingen und sowohl der CP als auch das IM blinken keinen Fehler. (alles grün )

    Um die Daten aus dem Gasanalyseschrank auszulesen verwende ich den FC12 "PNIO_RECV". Dieser schreibt aber die Kanäle nicht in den DB den ich dem FC12 übergebe.
    An den Ausgängen zeigt der FC12: NDR 0; ERROR 1; STATS 8184;
    was, laut Hilfe, "Systemfehler bzw. unzulässiger Parametertyp" bedeutet.

    Mit diesem Hinweis kann ich jetzt leider herzlich wenig anfangen.
    Hat jemand ne Idee wo mein Fehler liegt, bzw wo ich suchen muss?

    Vielen Dank für eure Hilfe und mit freundlichen Grüßen,
    TUM_LES
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren FC12: Systemfehler bzw. unzulässiger Parametertyp  

  2. #2
    Registriert seit
    01.11.2007
    Beiträge
    1.237
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    Versorg den IOPS mal mit "P#DB17.DBX16.0 BYTE 2", in der Hilfe steht dass es ein ANY mit VARTYPE BYTE sein muss.

    Grüße von HaDi

  3. Folgender Benutzer sagt Danke zu HaDi für den nützlichen Beitrag:

    LES_TUM (27.05.2013)

  4. #3
    LES_TUM ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.02.2013
    Beiträge
    4
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke für den Tip, ich hab den Fehler gefunden.
    Die Adressierung des Eintrags im DB funktioniert so schon wie ich das hatte.
    Der Datentyp im DB war aber WORD, wenn ich einen Struct vom Datentyp BYTE mach der 2 Byte lang ist funktionert es.
    Blöder Fehler meinerseits :-/

    Vielen Dank für die schnelle Hilfe!!

Ähnliche Themen

  1. Profinet FC11 + FC12
    Von Pinguino im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 29.12.2014, 17:48
  2. Step 7 Systemfehler
    Von ka1978 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 04.05.2013, 14:11
  3. S7 313 Systemfehler
    Von Licht9885 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 05.09.2012, 11:44
  4. Unzulässiger Befehl im Baustein???
    Von Andy_Scheck im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 17.02.2010, 15:21
  5. Parametertyp S7_ARRAY
    Von hoT im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 22.10.2009, 18:14

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •