Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 24 von 24

Thema: Werrte flackern im DB

  1. #21
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.710
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Stimmt ... du hast Recht ... da hatte ich mich total verguckt ... (Schäm) - ich weiß nicht, was ich da wieder gesehen habe ...

    Dann hast du mit deinem Beitrag #15 Recht, wo du schreibst, dass du absolute Instanz (zumindestens die "time neg blockade eva 2") schon mal 2mal verwendet wird.
    Ungeachtet dessen sollte man die IEC-Timer (zumindestens in einem FB) so schon mal nicht verwenden sondern besser so, wie von mir in Beitrag #14 beschrieben.

    Gruß
    Larry

  2. #22
    Registriert seit
    11.09.2007
    Ort
    Suedwestpfalz
    Beiträge
    917
    Danke
    81
    Erhielt 209 Danke für 192 Beiträge

    Standard

    Jepp. mit den Instanzen kann man(n) sich ganz ordentlich in die Knie schiessen...

    Apropos, schau mal in Dein Postfach... dsa für PNs...
    Das Grauen lauert in der Zwischenablage !!

  3. #23
    Registriert seit
    24.08.2012
    Beiträge
    56
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also Danke mal Larry ich werde es mir merken komischerweise funktioniert es auch so?.

  4. #24
    Registriert seit
    08.04.2010
    Beiträge
    21
    Danke
    3
    Erhielt 6 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich denke der Fehler liegt im Aufruf der Zeit-FB's.
    Diese benötigen einen Instanz-DB, oder komfortabler den Aufruf als Multiinstanz generieren.

    Die IN-Variablen
    time_conveyor_forward : TIME ;
    time_blockade_pos : TIME ;
    time_blockade_neg : TIME ;
    time_conveyor_backward : TIME ;
    haben im SFB-Aufruf nichts zu suchen. Steht darin die entsprechende Zeit dann am Parameter IN des SFB, wird die abgelaufene Zeit im übergeordneten Baustein gebraucht dann am Parameter ET

    Ich hoffe es ist hilfreich

    Rainer

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 28.11.2012, 13:19
  2. Probleme mit Beckhoff Dimmer (KL2751) - flackern
    Von ohm200x im Forum CODESYS und IEC61131
    Antworten: 21
    Letzter Beitrag: 01.02.2011, 22:49
  3. Flackern von Tooltips und Anwendungen
    Von demmy86 im Forum PC- und Netzwerktechnik
    Antworten: 9
    Letzter Beitrag: 09.12.2008, 19:50
  4. S7-200 ASi Bus Eingänge flackern
    Von Daimonion im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 14.08.2008, 18:43
  5. Antworten: 30
    Letzter Beitrag: 01.10.2007, 14:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •