Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Sporadischer Ausfall Profinet WLAN Leckwellenleiter Verbindung zu IO-Devices

  1. #1
    Registriert seit
    03.12.2009
    Beiträge
    64
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe folgende Konstellation.

    Eine S7 319 kommuniziert mit ca 20 ET200 CPU's via Profinet. Dazu sind an der 319 drei Scalance angeschlossen die über einen Leckwellenleiter eine WLAN Verbindung zu den ET CPU's aufbauen. Diese haben einen Scalance Client als Empfänger für das Leckwellensignal. Darüber läuft eine sichere Kommunikation (Not-Halt) und eine unsichere Kommunikation (50 Bytes). Die ET200 sind als I-Device eingebunden. Die ET 200 steuern Fahrzeuge die einen Kurs entlang fahren. Dieser ist ca. 150 m lang, deshalb drei Access Points.

    Das ganze funktioniert auch.

    Nun habe ich aber gelegentlich, ca. 2 mal in 24h, das eine Scalance Client einen Ausfall meldet. Das passiert nicht unbedingt wo sich die Leckwellenleiter treffen (Roaming), sondern irgendwo auf der Strecke.
    In den Accesspoints ist IPCF konfiguriert, mit einer Aktualisierungszeit von 128 ms.

    Ich hatte dieses Problem des Kommunikationsverlustes schon mal bei einer anderen Linie, daraufhin habe ich die Aktualisierungszeit höhergestellt und das Problem war weg. Das könnte ich diesmal auch tun, aber da zwischen den Fahrzeugen eine Regelung stattfindet, würde diese immer träger werden.

    Nun meine Frage. In der Konfiguration der Profinetschnittstelle der Slaves kann ich parametrieren:
    Kommunikationsanteil : steht auf 100%
    Sendetakt : steht auf 4ms
    Modus : steht auf automatisch
    Aktualisierungszeit : steht auf 128 ms ( nur lesbar)

    Im Master steht dasselbe, nur der Modus steht auf fixer Faktor, 128 ms.

    Nun begreife ich nicht ganz den Zusammenhang zwischen dem Sendetakt und der Aktualisierungszeit. In der Simatic Net Hilfe steht alles mögliche, daraus werde ich aber nicht schlau.
    Kann es etwas bringen, den Sendetakt zu verkürzen?

    Es sieht halt so aus, als ob gelegentlich aufgrund des Netzwerkverkehrs die Aktualisierung nicht innerhalb der Grenzen abgearbeitet wird und deshalb die Scalance einen Ausfall melden.

    Das WLAN Netz ist schon von Siemens vermessen worden, daran liegt es nicht.

    Ist wahrscheinlich keine Anwendung in der viele Leute Erfahrung haben, aber vielleicht kennt sich ja jemand gut aus und kann mir einen Tip geben.

    Gruss

    Oliver
    Zitieren Zitieren Sporadischer Ausfall Profinet WLAN Leckwellenleiter Verbindung zu IO-Devices  

  2. #2
    Registriert seit
    07.08.2013
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Oliver,

    wir haben eine ähnliche Anlage und leider das gleiche Problem. Hast du vielleicht eine Lösung, uns fällt hier auch nichts mehr zu ein.

    Danke
    Malte
    Zitieren Zitieren Selbes Problem  

  3. #3
    Registriert seit
    03.12.2009
    Beiträge
    64
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Malte,

    mittlerweile läuft das WLAN bei mir ganz gut.
    Ich habe folgende Modifikationen gemacht.

    - einen mechanischen Schutz (aus Metall) an einer Seite der Antenne abgebrochen. Das gab 10 DB mehr an Antennengewinn
    - Die Aktualisierungszeiten der Profinetverbindung auf 256 ms gesetzt. Pro WLAN Client braucht das System 3 ms plus 30ms Overhead. Da ich bis zu 15 Clients auf einmal in einem Segment habe bedeutet das : 15*3 +30 =75 ms. Laut Siemens soll mann diesen Wert verdoppeln um die Verbindung sicherzustellen, ergibt 150ms, also auf 256 einstellen.

    Nun habe ich zwar lange Updatezeiten, die mir jede Menge andere Probleme eingebracht haben, dafür läuft das Wlan stabil.

    Du musst beim RCOAX auf die Ausrichtung des Kabels achten, die Seite mit den leicht erkennbaren Noppen gehört Richtung Empfangsantenne, gegenüberliegend ist dann eine Art "Streifen" an den Kabel.

Ähnliche Themen

  1. Step 7 Profinet sporadischer Teilnehmerausfall
    Von Pico1184 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 10.05.2013, 14:37
  2. Antworten: 7
    Letzter Beitrag: 11.01.2013, 14:49
  3. Profinet I/O-über WLAN anbinden
    Von sailor im Forum Feldbusse
    Antworten: 15
    Letzter Beitrag: 07.05.2012, 08:34
  4. Profinet Ausfall
    Von daudel im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 18.05.2011, 20:24
  5. Ausfall eines IO-Devices
    Von Serdar G im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 13.11.2009, 12:37

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •