Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: einfacher Datenaustausch von zwei S7 CPU über Profinet

  1. #11
    Registriert seit
    28.03.2012
    Ort
    Hessen
    Beiträge
    116
    Danke
    4
    Erhielt 20 Danke für 18 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Ottmar Beitrag anzeigen
    Soweit ich mich erinnern kann, kann weder die 317-2 PN/DP noch die 315-2 PN/DP als I-Device konfiguriert werden.
    Beide können I-Device ab V3.2

    http://support.automation.siemens.co...ew/de/45172118


    EDITH sagt: sorry, JesperMP war schneller und habe sein Beitrag übersehen
    Geändert von olliew (12.07.2013 um 09:57 Uhr)
    Kaum macht man es richtig, schon funktioniert es.

  2. Folgender Benutzer sagt Danke zu olliew für den nützlichen Beitrag:

    Ottmar (12.07.2013)

  3. #12
    SPS_79 ist offline Benutzer
    Themenstarter
    Registriert seit
    17.10.2006
    Beiträge
    40
    Danke
    4
    Erhielt 3 Danke für 2 Beiträge

    Standard

    Danke für die schnelle Antwort
    ich werde mir das Dokument gleich mal anschauen

  4. #13
    Registriert seit
    26.04.2010
    Beiträge
    292
    Danke
    31
    Erhielt 51 Danke für 50 Beiträge

    Standard

    Hi!

    Zitat Zitat von JesperMP Beitrag anzeigen
    Doch. Alle S7-300 PN CPUs ab Firmware 3.2 können I-device.

    Hier lesen:
    https://www.automation.siemens.com/m...Id=21041185419
    Bestätige - hatte den HW-Katalog nicht auf dem aktuellsten Stand.

    Danke,


    Gruß,

    Ottmar

  5. #14
    SPS_79 ist offline Benutzer
    Themenstarter
    Registriert seit
    17.10.2006
    Beiträge
    40
    Danke
    4
    Erhielt 3 Danke für 2 Beiträge

    Standard

    Hey,

    also ich habe mir das jetzt mit dem I-Device mal genauer angeschaut und auch ein Projekt so aufgebaut.
    In der einen CPU habe ich den i-Device generiert (GSD Datei erstellt) und in der anderen CPU habe ich diese GSD Datei projektiert.
    Der Datenaustausch soll mit dem SFC 14/15 stattfinden.
    Ich möchte 246 Byte konsistent hin und her schicken.
    Bei dem I-Device fängt die Adresse bei 1000 an und ist 246 Byte lang.
    Die beiden CPU's sind über eine Ethernet Leitung miteinander verbunden.
    Die IP Adressen befinden sich im gleichen Nummerkreis.
    Aber irgendwie bekomme ich keine Kommunikation zustande.
    Wenn ich in die online Ansicht der HW-Konfig schaue, in welcher der I-Device eingefügt ist wird dieser dort nicht erkannt.
    Muss ich irgendwelche Dinge besonders beachten?
    Verkabelung, besonder Einstellungen bei Erzeugen der GSD des I-Device, IP Adressen etc.

  6. #15
    Registriert seit
    31.03.2010
    Beiträge
    335
    Danke
    3
    Erhielt 33 Danke für 32 Beiträge

    Standard

    Passt den der Name des I_Devices in der Station wo du die GSD eingefügt hast?

    Denn Siemens hat da anscheinend einen fehler drinnen denn der name wird umbenannt.
    Jedoch muss der Name des I-Device genau so sein wie die der Controllers.

    Gruß
    Wer aufhört, besser zu werden, hat aufgehört, gut zu sein!

  7. Folgender Benutzer sagt Danke zu SCM für den nützlichen Beitrag:

    SPS_79 (31.10.2013)

  8. #16
    SPS_79 ist offline Benutzer
    Themenstarter
    Registriert seit
    17.10.2006
    Beiträge
    40
    Danke
    4
    Erhielt 3 Danke für 2 Beiträge

    Standard

    Was meinst du mit der Name des I-Device muss genau so sein wie der des Controllers.
    Ich kann doch beim erzeugen der GSD einen Namen frei wählen.
    Was für einen Namen sollte ich da den verwenden?
    Mir ist schon aufgefallen, dass der Name beim Einfügen der GSD automatisch geändert wird. Meinst du das?

    Gruß und Danke

  9. #17
    Registriert seit
    31.03.2010
    Beiträge
    335
    Danke
    3
    Erhielt 33 Danke für 32 Beiträge

    Standard

    Ja genau der Name wird automatisch geändert. Das ist der Fehler!
    Und du darfst den auch nicht frei wählen.
    Der Gerätename des I-Device muss genau so sein wie der Gerätename der PNIO Schnittstelle der CPU.
    Anders hab ich es noch nie zum Laufen bekommen.

    Bei mir wird beim einfügen immer zum Gerätenamen automatisch -1 eingefügt. Das musst du weglöschen dann sollte es gehen.

    Gruß
    Geändert von SCM (31.10.2013 um 08:03 Uhr)
    Wer aufhört, besser zu werden, hat aufgehört, gut zu sein!

  10. #18
    SPS_79 ist offline Benutzer
    Themenstarter
    Registriert seit
    17.10.2006
    Beiträge
    40
    Danke
    4
    Erhielt 3 Danke für 2 Beiträge

    Standard

    Den Namen der PNIO Schnittstelle kann ich aber ändern oder?
    Ich muss dann nur den I-Device Namen genau so wählen und beim einfügen darauf achten, dass sich dieser nicht ändert?
    Meinst du so wie in meinem Beispiel?


    CPU wo I-Device erzeugt wird

    CPU_wo_I-Device_erzeugt_wird.jpg



    CPU wo I-Device eingefügt wird

    CPU_wo_I-Device_eingefügt_wird.jpg

    Wenn das alles war werde ich verrückt
    Kann dies leider erst wieder nächste Woche testen.

    Schon mal Danke

  11. #19
    Registriert seit
    31.03.2010
    Beiträge
    335
    Danke
    3
    Erhielt 33 Danke für 32 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja den Namen bei der CPU kannst ändern.
    I-DEVICE muss dann halt wieder angepasst werden.

    So wie du es jetzt hast sollte es passen.

    Gruß
    Wer aufhört, besser zu werden, hat aufgehört, gut zu sein!

  12. Folgender Benutzer sagt Danke zu SCM für den nützlichen Beitrag:

    SPS_79 (31.10.2013)

Ähnliche Themen

  1. Step 7 Datenaustausch über profinet SFC14 und SFC15
    Von daudel im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 06.05.2013, 19:27
  2. Datenaustausch Ethernet/Profinet CPU 300
    Von Heizerfraktion im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 18.09.2011, 21:38
  3. Datenaustausch von 2 CPU über MPI
    Von seppi82 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 04.10.2010, 09:29
  4. Vernetzung von zwei S7-300 über Profinet
    Von sascha-nrw im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 03.03.2009, 11:09
  5. Antworten: 8
    Letzter Beitrag: 14.07.2003, 10:04

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •