Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Bit wird nicht gesetzt

  1. #1
    Registriert seit
    19.01.2012
    Ort
    Mitte Deutschlands
    Beiträge
    77
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich habe da gleich nochmal eine andere Frage.
    Ich möchte mein Projekt ändern, verbessern und habe jetzt zum Testen nur mal was versucht.
    Im Netzwerk 1 wird das Bit gleich gesetzt auf 1, warum weis ich nicht, aber ist auch egal. Das wäre auch gut.
    Wenn ich in Netzwerk 2 das Bit setze, wird in Netzwerk 1 das nicht zurückgesetzt.
    Ich weis nur nicht warum.

    Zitieren Zitieren Bit wird nicht gesetzt  

  2. #2
    Registriert seit
    19.01.2012
    Ort
    Mitte Deutschlands
    Beiträge
    77
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also,
    kann es sein, weil die beiden Merker nur tem sind, in einem FB wo ich die als Staic deklariert habe geht es.

  3. #3
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von Der Dreschi Beitrag anzeigen
    kann es sein, weil die beiden Merker nur tem sind, in einem FB wo ich die als Staic deklariert habe geht es.
    Richtig!
    Du benutzt "HM-Hand-BA" und "HM-Auto-BA" für SR-Flipflops, die ihren Zustand über den aktuellen Zyklus hinaus behalten sollen!

    Länger als im aktuellen Zyklus = Static.
    Nur im aktuellen Zyklus und erst zuweisen, dann lesen = Temp möglich.


  4. Folgender Benutzer sagt Danke zu hucki für den nützlichen Beitrag:

    Der Dreschi (20.07.2013)

  5. #4
    Registriert seit
    19.01.2012
    Ort
    Mitte Deutschlands
    Beiträge
    77
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ha,
    so langsam....lerne ich was dazu.

  6. #5
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von Der Dreschi Beitrag anzeigen
    so langsam....lerne ich was dazu.
    Ja, wirklich?

    Klassische Frage - Flanke und Flankenmerker -> wie deklarieren und warum?

  7. #6
    Registriert seit
    14.10.2010
    Ort
    Telgte
    Beiträge
    654
    Danke
    97
    Erhielt 129 Danke für 99 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja, wirklich?
    Sarkasmus
    Manchmal kommt ausprobieren VOR den Basics...
    Ob das gut ist steht auf nem anderem Blatt!

    Gruß, Toki
    Programmierumgebung: Step7 V5.5, WinCCflex2008-SP3, TIA-PortalV13, MicroWinV4.0

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 07.02.2013, 21:43
  2. Merker wird nicht gesetzt. Programm?
    Von maninthedark im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 25.07.2011, 22:11
  3. Wert in Schrittkette wird nicht gesetzt
    Von tymanis im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 18.05.2010, 16:44
  4. Antworten: 5
    Letzter Beitrag: 05.03.2010, 11:45
  5. OP77B: Bit wird unkontrolliert gesetzt
    Von Grimsey im Forum HMI
    Antworten: 3
    Letzter Beitrag: 29.05.2009, 09:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •