Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 14 von 14

Thema: siemens logo simulation probleme

  1. #11
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.713
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von EMZ Beitrag anzeigen
    Also erstens, habe ich ja schonmal gesagt dass es nur so ein "test" ist. Ich habe das nur auf die schnelle hingeklascht um was zu probieren.
    Du musst mit klar kommen und auch damit leben, wenn z.B. ich mir das nicht antun will.



    Zitat Zitat von EMZ Beitrag anzeigen
    I1 bis I3 sind Störungseingänge.
    I4 Quittiertaster
    habe ich aber schon oben bei der vorherigen Nachricht hingeschrieben.
    Hab' ich erst gesehen, nachdem ich meinen Post veröffentlicht hatte.
    Hatte aber keine Lust mehr, meinen Post noch nach zu bearbeiten.



    Zitat Zitat von EMZ Beitrag anzeigen
    Hier hab ich mal die unnötigen Sachen weggepackt und einbisschen aufgeräumt.

    So jetzt ists besser.
    Ja, war es wirklich.
    Und trotzdem hab' ich noch etwas mehr aufgeräumt:





    Zitat Zitat von EMZ Beitrag anzeigen
    Kommen wir zur eigentlichen Problematik.
    Meinst du es liegt an den Timern?
    Ja!
    Wie man sieht, haben 3 Timer Starteingänge, die immer mal min. ein Zyklus aus sind. Dadurch kommt es zu Verschiebungen, die nicht in der Timerzeit enthalten sind. Das dürfte vor allem auf B006 gegenüber B004 und B005 Auswirkung haben. Das war auch der Grund, warum ich nur einen Timer verwendet habe, auch wenn die Auswertung etwas aufwendiger ist.


    Möchtest Du wirklich mit mehreren Timern arbeiten, sollten sie immer synchron ein- und ausgeschaltet werden.
    In Deinem Fall reichen ja dann auch 2 Timer, die ständig laufen und damit synchron bleiben sollten:
    Q2 ist erst 6 Sekunden an, dann 3 Sekunden aus (beginnend mit EIN)
    Q3 ist erst 3 Sekunden aus, dann 6 Sekunden an (beginnend mit AUS)
    Q1 ist immer dann an, wenn Q2 und Q3 nicht gemeinsam an sind (NAND)





    Zitat Zitat von EMZ Beitrag anzeigen
    Wenn einer von I1 - I3 ein Signal bekommt, soll der entsprechende Verbraucher I1 = Q1 ausgehen und andere zwei solange anbleiben bis der Fehler behoben wurde bzw. quittiert wurde.
    Wirklich nett, wenn so was hinterher kommt, nachdem man Arbeit in eine Version ohne diese Features gesteckt hat. Oft verändern diese Anforderung das ganze Programm.
    PS: Da muss ich mich aber bei Dir entschuldigen. Du hattest ja gar nicht um Hilfe beim Programm gebeten (das hatte ich nur mal so zum Spaß gemacht), sondern um Rat bei der Simulation. Also sorry für mein "Gemaule".


    Alles der Reihe nach eingebaut ->

    Freigabe/Verriegelung:




    Fehlerspeicherung mit Quittierung (Störung dominant):




    Automatische Quittierung bei Programmstart durch den Anlaufmerker M8:




    Ständige Aktivierung des Ausgangs, bei Störung (fehlender Freigabe) eines anderen Ausgangs:




    Und voilà!
    Angehängte Dateien Angehängte Dateien
    Geändert von hucki (13.08.2013 um 17:24 Uhr) Grund: unbegründetes Maulen meinerseits

  2. Folgender Benutzer sagt Danke zu hucki für den nützlichen Beitrag:

    EMZ (13.08.2013)

  3. #12
    EMZ ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.10.2012
    Beiträge
    202
    Danke
    25
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hi danke für die Lösungen. Sehr hilfreich.
    Aber selbst bei deinem letzten Beispiel bzw. mein aufgeräumtes und verbessertes (von dir) sind Timer-Verschiebungen zu sehen. Auch wenn es nur ca. 0,006 sek. sind.
    Bei deinem Beispiel mit dem Zähler kommt sowas nicht vor. Nur muss man erstmal darauf kommen es nach deiner Programmierart zu programmieren. Wär ich nie draufgekommen.
    Das ist ja mal blöd, selbst bei 2 Zählern verschieben sich die Zeiten.
    Eine Frage, warum hast du den Impulsgeber bei deiner Version mit den Zählern so programmiert, dass der Impulsgeber 1 sek. Impulsbreite und 2 sek. Impulspausenbreite hat?
    Ist mir klar das es irgendwie 3 sek. sind, aber wie ?

    LG
    EMZ

  4. #13
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.713
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Das ist eigentlich recht zufällig.
    PS: Der Zähler zählt immer bei der 0-1-Flanke an seinem Zähleingang, egal wie lange das Signal dann ansteht. Und 1s und 2s ließen sich am einfachsten einstellen.

    Die Summe aus Breite und Pause mußte auf jeden Fall 3 Sekunden sein, denn es sollte ja alle 3 Sekunden umgeschaltet werden.
    Jetzt mußte ich noch etwas grübeln, dass auch das erste Zählen erst nach 3 Sekunden und nicht eher passiert. Deshalb hab' ich den Timer mit der Pause begonnen (gesetzter Eingang INV), dann der Impuls und erst mit der negativen Flanke des Impulses (nach Ablauf der kompletten 3s) den Zähler weiter geschaltet.
    Wie Du siehst, ist somit die genaue Breite des Impulses egal.

    Übrigens ist durch die Invertierung die Pause 1s und die Impulsbreite 2s.
    Geändert von hucki (13.08.2013 um 18:27 Uhr)

  5. #14
    EMZ ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.10.2012
    Beiträge
    202
    Danke
    25
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ok vielen vielen Dank hucki

    Also muss man indem Fall einfach mit der negativen Flanke den Zähler zählen lassen.

    Danke ich glaube diese Version läuft am stabilsten und ist auch die einfachste, wenn man die mal gesehen hat
    ( Davor nicht )

    LG
    EMZ

Ähnliche Themen

  1. Probleme mit meiner Siemens LOGO
    Von Napie im Forum Sonstige Steuerungen
    Antworten: 8
    Letzter Beitrag: 24.09.2012, 19:43
  2. Probleme mit Simulation
    Von TimoB im Forum HMI
    Antworten: 1
    Letzter Beitrag: 19.07.2010, 12:23
  3. Antworten: 11
    Letzter Beitrag: 16.12.2008, 12:16
  4. Logo!Soft Comfort Simulation
    Von loki im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 15.01.2008, 17:08
  5. Simulation von Logo beschleunigen ?
    Von X-Master im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 26.09.2007, 17:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •