Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Alarm aktivieren S7-200

  1. #1
    Registriert seit
    06.10.2004
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Hat vielleicht jemand ein Beispiel für das aktivieren von Alarmen für ein TD-200 v3.x, denn bei mir funktioniert es einfach nicht obwohl ich das Unterprogramm (TD_ALM_0) aufrufe und das Alarmfreigabebit für die entsprechende Meldung gesetzt habe.
    Leider findet man auch in der Hilfe keine brauchbaren Tipps

    Gruß aus Niederbayern
    Zitieren Zitieren Alarm aktivieren S7-200  

  2. #2
    Anonymous Gast

    Standard

    Versuch mal das mitgelieferte. Du findest es im Sample Ordner im Microwin Installationsverzeichnis.
    TD200_TD200C_Standard_Faceplate_a.mwp

    Alternativ können dir diese vielleicht weiter helfen.
    http://www.s7-200.net/Scripts/entry....y_ID=41&Part=3
    http://www.s7-200.net/Scripts/entry....y_ID=39&Part=3

  3. #3
    Oeder ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.10.2004
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    Jetzt endlich habe ich es geschafft, nur weis ich nicht genau warum?!
    Da die Musterprojekte von Siemens funktionierten und kein Unterschied erkennbar war, war das endlose herumprobieren angesagt
    Durch Zufall schrieb ich den Aufruf für die Alarmmeldung (TD_ALM_X) in einen anderen Baustein, und siehe da es funktionierte
    Der einzig erkennbare Unterschied zwischen den beiden Bausteinen in denen aufgerufen wurde war, dass beim funktionierenden keine Lokaldaten verwendet wurden.
    Jetzt stellt sich mir die Frage warum ist das so

  4. #4
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Du benutzt höchstwahrscheinlich nicht initialisierte Lokaldaten.

    Erklärung:
    OUT, TEMP Parameter müssen grundsätzlich am Anfang des Bausteins (Subroutine) initialisiert werden.

    Der benötigte (allokierte) Speicher für das Unterprogramm kann irgendeinen Wert haben. Bei S7-200 wirkt sich dieses meist erst ab Benutzung eines zweiten Bausteins mit Lokaldaten aus.

Ähnliche Themen

  1. Phoenix IB IL AI 4/U-PAC aktivieren?
    Von r.haunreiter im Forum PHOENIX CONTACT
    Antworten: 2
    Letzter Beitrag: 11.05.2011, 12:13
  2. PTO Aktivieren
    Von brezeldieb im Forum Programmierstrategien
    Antworten: 8
    Letzter Beitrag: 23.11.2010, 21:25
  3. Lichtgitter aktivieren
    Von sps-welt im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 15.02.2010, 17:20
  4. 95U interne Uhr im DB1 aktivieren
    Von Köbes11 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 07.05.2008, 13:56
  5. Antworten: 1
    Letzter Beitrag: 31.08.2006, 16:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •