Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Ausgang bei CPU-STOP auf "1" setzen

  1. #1
    Registriert seit
    17.08.2013
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen
    ich habe schon ein bissl gesucht, habe aber zu meiner Frage noch keine befriedigende Antwort gefunden.

    Daher probiere ich es mal hier und hoffe, dass mir die Profis fix weiterhelfen können.

    Ich werde demnächst eine SPS programmieren müssen. Jetzt habe ich vor, dass nach einem Neustart eine LED
    blinken soll, was ja kein Problem ist. Wenn aber die CPU in Stop geht, soll die LED dauerhaft leuchten (kein blinken mehr).

    Nun weiß ich, dass bei analogen Ausgängen möglich ist, verschiedene Werte für den Zustand des Ausgangs bei CPU-Stop vorzugeben (Spannungs-/Stromfrei, Letzter Wert bleibt oder Ersatzwert aufschalten).

    Nun die eigentliche Frage: Besteht die Möglichkeit auch für digitale Ausgänge ? Dass man da sozusagen die logische "1" bei CPU-STOP als Ersatzwert aufschalten kann ? Ich habe leider nur für Analogausgänge was gefunden, daher fürchte ich, es gibt das nicht für Digitalausgänge.

    Ich hätte ja selbst schon nachgeschaut, aber ich habe weder die Baugruppen, noch die Software zur Verfügung, möchte aber im Vorfeld schon wissen, ob ich noch ein bissl was am Proggi ändern muss und wie ich das anstellen soll.
    Wird ja etwas komplizierter, wenn man mit dem Analogausgang arbeiten muss.. aber egal...

    Vielen Dank im Voraus....
    Duffy
    Zitieren Zitieren Ausgang bei CPU-STOP auf "1" setzen  

  2. #2
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.787
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Mal eine ganze einfache Lösung
    • Ausgang im Mainprogramm, immer auf '1' schalten.
    • An den betreffenden Ausgang ein Relais.
    • Vom Relais einen Öffner zum ansteuern eines Leuchtmelders nutzen.

  3. #3
    Duffy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.08.2013
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo rostiger Nagel,

    danke für die Antwort.... finde ich persönlich aber nicht ganz so einfach....
    Also, nicht dass es zu kompliziert zum Verstehen wäre... ich finde es zu aufwändig, außerdem wurde noch nicht berücksichtigt, dass derselbe Ausgang nach einem "CPU-Neustart" auch die LED zum Blinken bringen soll.

    Zudem birgt jedes neue Bauteil (in diesem Falle das Relais) auch wieder eine neue Fehlerquelle, ich versuche deshalb immer so einfach wie möglich bei der Gestaltung zu denken.... was nicht unbedingt sein muss, kommt mir auch nicht in meine Elektronik rein...

    Ich werde wohl nicht daran vorbeikommen, einen analogen Ausgang zu verwenden... Da ist zwar das "Blinken" nach einem Wiederanlauf der CPU etwas komplizierter zu Realisieren... aber dafür ist das Verhalten bei CPU-STOP um so einfacher zu gestalten....

    Danke nochmals für Deinen Vorschlag.

  4. #4
    Duffy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.08.2013
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    muss hier eigentlich jede neue antwort von nem moderator freigeschaltet werden? oder mache ich was falsch... mehr als antworten anklicken kann ich ja nu auch nicht... *kopfkratz*

  5. #5
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 303 Danke für 223 Beiträge

    Standard

    Also da ich nicht weiß was für eine Steuerung.......

    Es geht bei einer S7-200 und es geht bei der S7-1200 mit CPU in STOP und Ausgang auf 1
    Wenn du eine S7-300 oder 400 hast dann wie "rostiger Nagel" schreibt.

  6. #6
    Duffy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.08.2013
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke, UniMog...
    Es ist ne S7 300...
    Und da weiß ich halt mit Sicherheit, dass die Analogausgänge derart konfigurierbar sind....

    Tja.. habe eben eine Antwort auf "rostiger Nagels" Beitrag geschrieben... aber die ist irgendwo hingegangen... keine Ahnung wohin das geht, wenn man direkt was ins Antwortfeld eingibt und dann auf "Antworten" klickt.. danach sollte der Beitrag wieder von einem Moderator geprüft werden..... hab ich vllt versehentlich damit ein neues Thema erstellt ?

  7. #7
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.787
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Zitat Zitat von Duffy Beitrag anzeigen
    muss hier eigentlich jede neue antwort von nem moderator freigeschaltet werden? oder mache ich was falsch... mehr als antworten anklicken kann ich ja nu auch nicht... *kopfkratz*
    Du landest zZ immer in die Spamabwehr.

    Zur Verwendung eines Analogausganges, solltest du Bedenken das dieser
    relativ teuer und nicht gerade belastbar ist.
    Ein Relais kann man übrigens auch Takten und anfällig sind Sie eigentlich auch
    nicht. Bei deine Abwendung wird es wahrscheinlich sehr sehr lange leben.
    Geht es doch kaputt wird wahrscheinlich auch die Störlampe angehen.

    Warum geht überhaupt deine CPU in den Stop, das gibt es doch garnicht?

  8. #8
    Registriert seit
    20.01.2012
    Beiträge
    36
    Danke
    1
    Erhielt 14 Danke für 11 Beiträge

    Standard

    hallo,

    in dem beschrieben Fall verwende doch einfach Baugruppen die Ersatzwerte unterstützen. Verwendest du diese Module legst du in der Hardwarekonfiguration das Verhalten des Moduls oder der einzelnen Kanäle fest. Dort ist es auch möglich für Analogwerte Ersatzwerte zu parametrieren. Das scheint mir die schnellste und einfachste Lösung.

    Das Verhalten ist unabhängig von der CPU. (300/400/1200/1500/200/Wago/usw)

    Viele Grüße

  9. #9
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 303 Danke für 223 Beiträge

    Standard

    Zitat Zitat von hans.mustermann Beitrag anzeigen
    hallo,

    in dem beschrieben Fall verwende doch einfach Baugruppen die Ersatzwerte unterstützen. Verwendest du diese Module legst du in der Hardwarekonfiguration das Verhalten des Moduls oder der einzelnen Kanäle fest. Dort ist es auch möglich für Analogwerte Ersatzwerte zu parametrieren. Das scheint mir die schnellste und einfachste Lösung.

    Das Verhalten ist unabhängig von der CPU. (300/400/1200/1500/200/Wago/usw)

    Viele Grüße
    Danke Mustermann aber das weiß er ja selber..... Seine Frage war ob das auch bei Digitalbaugruppen möglich ist mit einem Ersatzwert zu arbeiten.
    Ja bei S7-200 / S7-1200
    Nein bei S7-300 / S7-400

  10. #10
    Duffy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.08.2013
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also, um es kurz zu machen.... ich glaube, meine eigentliche Frage ist durch UniMog bereits beantwortet worden... nämlich ob man einen digitalen Ausgang bei einer S7 300 mit einer "1" beaufschlagen kann bei CPU STOP--- nämlich nicht !!

    Ok, für alle die es interessieren sollte...

    Es handelt sich um folgende Baugruppe:

    SIMATIC S7-300, CPU 313C,
    KOMPAKT CPU MIT MPI, 24 DE/16 DA, 4AE,
    2AA, 1 PT100

    @rostiger Nagel:
    Also, egal wie teuer die analogen Ausgänge auch immer sein sollten... wenn sie eh brach liegen und nicht genutzt werden, kann ich sie ja mal für meine zwecke einsetzen.... sollten die irgendwann gebraucht werden, kann ich mir immer noch eine andere Lösung überlegen...
    Und ne Leuchtdiode braucht ja auch nur 20 mA, das sollte ja machbar sein.... wegen Belastbarkeit...

    Warum geht meine CPU in STOP ??

    Nun, tut sie ja nicht... hoffe ich jedenfalls... aber was wenn doch.. das soll dann sofort jemand mitbekommen..

Ähnliche Themen

  1. mit "K-Taste" Ausgang setzen
    Von spsbroesel im Forum HMI
    Antworten: 17
    Letzter Beitrag: 23.12.2014, 11:25
  2. Antworten: 8
    Letzter Beitrag: 01.07.2013, 17:16
  3. Antworten: 6
    Letzter Beitrag: 16.03.2012, 18:20
  4. Step7 Ausgang "direkt" setzen
    Von Detto im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 06.10.2011, 15:17
  5. Antworten: 36
    Letzter Beitrag: 17.04.2011, 10:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •