Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: PCS7 OS und PLCSim auf einem Rechner

  1. #1
    Registriert seit
    13.09.2008
    Beiträge
    34
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich scheitere gerade beim Versuch das GettingStarted Projekt für PCS7 zu testen.
    Ich habe vor alles auf einem Rechner laufen zu lassen (OS, PLCSim,ES).

    Wie muss ich da mit den IP Adressen umgehen zwecks PLCSim und OS (WinnCCApp?).
    Beiden die gleiche (also die vom PC geht ja nicht; kommt ein Fehler beim Übersetzen)
    Zitieren Zitieren PCS7 OS und PLCSim auf einem Rechner  

  2. #2
    Registriert seit
    03.04.2008
    Beiträge
    6.205
    Danke
    237
    Erhielt 817 Danke für 691 Beiträge

    Standard

    Also ich starte PLCSim, übersetze und übertrage die Bausteine, dann starte ich WinCC und starte die Runtime.

    Ist PLCSim auf TCP eingestellt?
    Welchen Fehler bekommst du denn, wenn du PlcSim und WInCC startest, ohne an den Adressen zu schrauben?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  3. #3
    knubbl ist offline Benutzer
    Themenstarter
    Registriert seit
    13.09.2008
    Beiträge
    34
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich muss doch bei der Projektierung sowohl für die SPS (in diesem Fall PLCSim) als auch für die OS eine IP Adresse angeben oder nicht?

  4. #4
    Registriert seit
    03.04.2008
    Beiträge
    6.205
    Danke
    237
    Erhielt 817 Danke für 691 Beiträge

    Standard

    Klar das musst du.
    Doch in der Simulation sollte es auch funktionieren, wenn du PLCSim startest und das Projekt übertragen hast, dann funktioniert WinCC.
    Du musst ggF den Servernamen anpassen.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  5. #5
    Registriert seit
    09.08.2006
    Beiträge
    3.638
    Danke
    912
    Erhielt 661 Danke für 543 Beiträge

    Standard

    Zitat Zitat von knubbl Beitrag anzeigen
    Ich muss doch bei der Projektierung sowohl für die SPS (in diesem Fall PLCSim) als auch für die OS eine IP Adresse angeben oder nicht?
    Ich geh mal davon aus Du bist grad bei "Ersten Kennenlernen" und nicht beim "Getting started" ? Weil Erstes Kennenlernen verwendet PLCSIM und "Getting Started" ne reale CPU.

    Die OS bekommt die IP von Deinem Rechner, die SPS ne freie andere beliebige im gleichen Subnetz. z.B. OS: 192.168.200.201 und SPS: 192.168.200.202


    Gruß.

    Schritt Aktion1 Markieren Sie in der Komponentensicht die SIMATIC 400-Station und wählen Sie denMenübefehl Bearbeiten > Objekt öffnen.HW Konfig wird geöffnet.2 Öffnen Sie das Kontextmenü der Baugruppe CPU 414-3 im Anschluss X5 (PN-IO) undwählen Sie den Menübefehl Objekteigenschaften.Das Dialogfeld "Eigenschaften - PN-IO (R0/S3.5)" wird geöffnet.3 ● Wälen Sie das Register "Allgemein".● Klicken Sie im Bereich "Schnittstelle" auf die Schaltflähe "Eigenschaften".Das Dialogfeld "Eigenschaften - Ethernet Schnittstelle PN-IO (R0/S3.5)" wird geöfnet.● Ädern Sie den Eintrag im Eingabefeld "IP-Adresse" auf eine freie Adresse innerhalbdes Adressbands Ihres Rechners.Hinweis: Informationen zum Adressband Ihres Rechners erhalten Sie üer dasBefehlszeilenprogramm "ipconfig".● Klicken Sie im Bereich "Subnetz" auf die Schaltflähe "Neu".Das Dialogfeld "Eigenschaften - Neues Subnetz Industrial Ethernet" wird geöfnet.● Tragen Sie im Eingabefeld "Name" einen Namen fü den Kommunikationsweg ein, z. B."Anlagenbus".● Klicken Sie im Dialogfeld "Eigenschaften - Neues Subnetz Industrial Ethernet" auf dieSchaltflähe "OK". Das Dialogfeld wird geschlossen.● Im Dialogfeld "Eigenschaften - Ethernet Schnittstelle PN-IO (R0/S3.5)" wird jetzt in derListe im Bereich "Subnetz" der Eintrag "Anlagenbus" angezeigt.● Klicken Sie auf die Schaltflähe "OK". Das Dialogfeld wird geschlossen.● Klicken Sie im Dialogfeld "Eigenschaften - PN-IO (R0/S3.5)" auf Die Schaltflähe "OK".
    Das Dialogfeld wird geschlossen.
    Geändert von ducati (20.08.2013 um 13:20 Uhr)

  6. Folgender Benutzer sagt Danke zu ducati für den nützlichen Beitrag:

    knubbl (20.08.2013)

  7. #6
    knubbl ist offline Benutzer
    Themenstarter
    Registriert seit
    13.09.2008
    Beiträge
    34
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    jetzt siehts ganz gut aus.
    Bekomme nur noch diese Meldung:

    Verbindung zur Baugruppe Stationmanager (Index 125) in der Station PCS7-VM konnte nicht aufgebaut werden.

  8. #7
    Registriert seit
    15.12.2007
    Beiträge
    716
    Danke
    84
    Erhielt 106 Danke für 95 Beiträge

    Standard

    Was auch ein typischer Fehler ist:
    "Normalerweise" benutzt man in einem PCS7-Projekt zwischen AS und OS die Verbindung "Named Connections". Damit wird auch die OS übersetzt.
    Das wird von PLCSim allerdings nicht unterstützt und die OS muss mit TCP/IP übersetzt werden, damit man eine Verbindung herstellen kann.
    Prüfe mal die Verbindung deiner OS zum AS im Übersetzungsassistenten.

  9. #8
    Registriert seit
    09.08.2006
    Beiträge
    3.638
    Danke
    912
    Erhielt 661 Danke für 543 Beiträge

    Standard

    Wir wissen ja nicht, was Du dort alles treibst... Aber wenn Du das "Erste Kennenlernen" Schritt für Schritt abarbeitest, sollte sowas eigentlich nicht auftreten. Es sei denn, Deine PCS7-Installation ist schon im Eimer...

    Schreib hier erstmal (viel) mehr Infos.

    Gruß.

  10. #9
    knubbl ist offline Benutzer
    Themenstarter
    Registriert seit
    13.09.2008
    Beiträge
    34
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe das GettingStarted durchgearbeitet und bin jetzt erst durch diesen Thread auf das "ErsteKennenlernen" gekommen.
    Ich werd das mal durchschauen und vielleicht klärt sich dann vieles

  11. #10
    Registriert seit
    09.08.2006
    Beiträge
    3.638
    Danke
    912
    Erhielt 661 Danke für 543 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Naja, wie gesagt, das "Getting Started" arbeitet mit einer realen S7-400. Wenn Du das auf PLCSIM laufen lassen willst musst Du einiges in der Schritt für Schritt Anleitung modifizieren und einiges wird auch so wie beschrieben nicht/anders funktionieren. Aber frag mich jetzt bitte nicht, was alles!

    Ansonsten, welche PCS7 Version verwendest Du überhaupt?

    Gruß.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 24.09.2012, 18:09
  2. Antworten: 6
    Letzter Beitrag: 14.05.2010, 21:48
  3. PLCSIM 5.4 und WinCC 6.2 auf einem Rechner
    Von bob robsen im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 05.01.2009, 10:23
  4. InTouch 7 + 8 + 9 auf einem Rechner möglich?
    Von plc_tippser im Forum HMI
    Antworten: 2
    Letzter Beitrag: 29.11.2005, 17:54
  5. SP5 und SP7 auf einem Rechner
    Von Anonymous im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 07.09.2003, 23:10

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •