Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: S7-300 mit Thermoelement und RTD Kompensation

  1. #1
    Registriert seit
    28.08.2013
    Beiträge
    2
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Anhang 21569Anhang 21572Hallo,
    ich bin neu hier und habe vermutlich direkt mal eine frage an die Profis

    Ich habe ein größeres Projekt bekommen. In diesem Projekt sind Thermoelemente an eine SPS angeschlossen und mit einer RTD Baugruppe mit Thermowiderständen (NI100) welche je ein der Thermoelemente kompensieren soll.

    Mein Problem ist:
    ich bekomme keine korrekten Temperaturen angeben. Sie sind etwa 20°C geringer als die wahren Temperaturen. Die Kompensation scheint zu funktionieren denn wenn ich die Ausgleichstemperaturen verändere änder sich auch der Wert des Thermoelementbaugruppeneingangs. Ich übergebe gemäß der Baugruppenanleitung den Datensatz 2 der RTD Baugruppe mit Hilfe des SFC58 die Busybits blinken und es schein so als arbeitet die Kompensation korrekt. wenn ich die Funktion lösche bekomme ich auch einen Überlauf am Eingang der TC (TC= Thermoelement) Baugruppen, so sollte es auch sein denke ich. Will aber ein Programmierfehler auch nicht ausschließen.

    Die Thermoelemente unterscheiden sich um etwa 10°C von den Ausgleichsstellen. An den Ausgleichstellen sind mehre Klemmverbindung pro Thermoelement, diese haben aber alle die gleiche Temperatur.

    Bitte schaut mal in den FC mit der Kompensation vielleicht mache ich da etwas falsch S7-300 Baugruppendaten S.385 ff Steht das mit dem Datensatz 2...
    Vielleicht sind auch meine Einstellungen falsch siehe unten...


    Thermoelement Typ E ist verbaut. -> AI6xTC
    Ni100 zur Kompensation -> AI8xRTD

    Normale Temp am System: 40°C vs. angezeigter Temp am System: 14°C
    (Normale Temp an Klemmstelle 10°C)

    In der Hardwarconfig habe ich gewählt:
    unter der TC Baugruppe:Thermoelement Typ E, TC-EL Thermoelement (ext. Vergl. linear), Remote RTD, keine Glättung
    unter der RTD Baugruppe: NI100 Std als RTD 4 Leiter Messung. Koeffizient:.00616

    Vielen Dank für eure Hilfe

    Gruß
    TZU
    Geändert von TZU (31.08.2013 um 08:47 Uhr)
    Zitieren Zitieren S7-300 mit Thermoelement und Remote RTD Kompensation  

  2. #2
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Frage: liest Du an den Ni100 die korrekte Temperatur ein?
    Ich habe das vor einem halben jahr mit einer 400er auch so gemacht, allerdings mit FeCuNi/J und PT100.

    Achso, ich habe einen Tipp:
    Du liest Ni100 als Standard ein und schreibst aber ins MB0 einen 1er. Das benötigt aber m.E. eine Einstellung "Klima". weil nur die misst auf Hundertstel.
    Da hast Du dann statt 26.2 Grad eben eine Kompensation von 2.62 Grad und das erklärt Deine ungefähr 20K falsche Werte.
    Geändert von borromeus (29.08.2013 um 07:28 Uhr)

  3. Folgender Benutzer sagt Danke zu borromeus für den nützlichen Beitrag:

    TZU (29.08.2013)

  4. #3
    TZU ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.08.2013
    Beiträge
    2
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vielen vielen dank, das war die lösung! :d

Ähnliche Themen

  1. PID-Regler mit EM231 RTD
    Von micha2010 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 15.03.2010, 13:30
  2. PT 100 und Thermoelement Typ K
    Von mpexx im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 15.06.2008, 13:40
  3. Suche AI RTD (PT 100) für S7-300 oder DP
    Von HaSchi im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 05.06.2006, 10:00
  4. Thermoelement und SM331
    Von agoschina im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.05.2006, 23:17
  5. Antworten: 5
    Letzter Beitrag: 20.12.2005, 09:31

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •