Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: Analogwertverarbeitung (mehrere Probleme)

  1. #1
    Registriert seit
    06.09.2013
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Unglücklich


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich bin neu hier und suche schon seit 2 Wochen hier und bei Dr. Google nach Lösungen. Ich bin schon ein paar Schritte weiter gekommen, jedoch hänge ich jetzt wieder fest und kann es mir aber nicht erlauben, weil ich an meinem Abschlussprojekt bin. Ich bin Mechatroniker im 4. LJ.

    ich möchte eine Strommessung durchführen und diesen mit einem Sollwert vergleichen. Inzwischen habe ich FC105 kennengelernt und mich damit auseinandergesetzt. Danke dafür SPS-Forum!

    Probleme:
    Ich finde nirgends die Adresse für meine Analogeingänge. Habe schon von PEW256 gehört aber finde nichts dazu.

    Mein Strommessrelais welches 4-20mA ausgibt ist an der Klemme 9&10 verdrahtet. Meine SPS: Simatic S7-300 CPU314 IFM V1.2
    Im OB1 "call"e ich FC3. In dem befindet sich mein FC105. Wenn man sich den Baustein FC105 aus der bib (bei mir in FC3) holt, erscheint er Automatisch auch in der Bausteinauflistung.

    Sobald ich alles auf die S7 lade, bekomme ich einen SF.
    Diagnosepuffer: siehe Anhang

    Also - wer hilft mir?!

    Weitere Fragen stelle ich später Danke im vorraus
    LG
    Angehängte Dateien Angehängte Dateien
    Zitieren Zitieren Analogwertverarbeitung (mehrere Probleme)  

  2. #2
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.849
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    mit welchen adressen was belegt ist findest du in der hw-config.
    s7-manager->projekt anklicken-> doppelklick auf hardware

    das was du dort siehst muss aber nicht unbedingt schon in der cpu sein wenn du die hw-config noch nie übertragen hast.
    Geändert von volker (06.09.2013 um 09:44 Uhr)
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  3. #3
    Immer Besser ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.09.2013
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das hilft mir aber nur bei den DI nicht bei den Analogen!? Ich weiß nicht welchen PEW/EW ich in meinem FC105 zuweisen soll.
    Hardware:Anhang 21669
    Mein FC105 bis jetzt: Anhang 21668

  4. #4
    Registriert seit
    24.05.2005
    Ort
    Westmünsterland
    Beiträge
    214
    Danke
    8
    Erhielt 45 Danke für 37 Beiträge

    Standard

    Hallo

    Bei der 314 IFM sieht man in HW- Konfig nur ein Eingangsbereich z.b von 124 bis 135 und ein Ausgangsbereich
    von 124-129. In diesem Bereich sind die Digitalen und die Analogen Ein-Ausgänge „versteckt“.

    E-Bereich: 124.0 – 126.3 20 Digitaleingänge
    128 – 135 4 Analogeingänge
    A-Bereich 124.0 – 125.7 16 Digitalausgänge
    128 - 129 1 Analogausgang

    Gruß Per
    Suche nicht nach Fehlern, suche nach Lösungen. [Henry Ford]
    Zitieren Zitieren 314 ifm  

  5. Folgender Benutzer sagt Danke zu Per für den nützlichen Beitrag:

    Immer Besser (06.09.2013)

  6. #5
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.333
    Danke
    448
    Erhielt 688 Danke für 513 Beiträge

    Standard

    EDIT: Deleted

    Duh! CPU314IFM, Jep Per hat recht und ich bin doof... oder schlaf noch.
    Geändert von RONIN (06.09.2013 um 10:49 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  7. #6
    Immer Besser ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.09.2013
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @per: Danke! ich krieg mit PEW128 jetzt einen Wert rein. WE gerettet!
    @RONIN: ne, bei steht wie per schon sagte alles versteckt.

    jetzt liegt es daran mir einen REELLEN wert anzeigen zu lassen. Ich kriege 4-20mA rein und möchte das nach meinem FC105 auch, dass ich diesen Wert sehe.
    Wenn ich in HI LIM 20.0 eingebe macht er "2.000000e+001" daraus. mache ich also was falsch? brauche ich ein Signal am Bipolar-Eingang?

  8. #7
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.333
    Danke
    448
    Erhielt 688 Danke für 513 Beiträge

    Standard

    Nope Bipolar brauchst du wenn du am Eingang ein biploares Signal hast. z.b.: +/-10V

    Sag uns doch mal welchen Bereich deine Sonde hat (4mA ^= x ; 20mA ^= y) und vor allem den dezimalen Wert den du im Moment an deinem PEW angezeigt bekommst.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  9. Folgender Benutzer sagt Danke zu RONIN für den nützlichen Beitrag:

    Immer Besser (06.09.2013)

  10. #8
    Immer Besser ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.09.2013
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Mein Strommessumformer gibt 4-20mA.
    Ich habe gerade eine Glühbirne angeschlossen.
    PEW: 448
    OUT: 00000000.125
    Und als Bild:
    FC105-Funktion.png

  11. #9
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.333
    Danke
    448
    Erhielt 688 Danke für 513 Beiträge

    Standard

    Sieht doch ganz gut aus.... oder? Jetzt gibt er nicht mehr 20.0 aus...

    Das heißt also dein Stommessumformer geht von 0 bis 20A?

    Noch als kleine Info zur Analogdarstellung von PEWs
    Minimum ^= 4mA ^= 0dez
    Maximum ^= 20mA ^= 27648dez
    Das ist der Bereich in dem die SPS deinen Analogwerteingang darstellt, jeder Wert der sich außerhalb dieses Fensters bewegt ist fehlerhaft (außer bei bipolaren Messungen).
    Wenn man das weiß kann man die Wandlung noch einmal nachchecken, aber der FC105 hat das schon im Griff.

    Außer bei Temperaturmessungen (PT100, Ni1000, etc.) sieht es anders aus.
    Geändert von RONIN (06.09.2013 um 11:11 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  12. #10
    Immer Besser ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.09.2013
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja, im Eingang hat der Messumformer 0-20A. An die SPS gibt er aber 0-20mA. Und ich möchte das nach dem FC105 ein Wert von 0 bis 20 rauskommt. Das ist doch möglich oder?
    Also was muss ich genau bei HI LIM und Lo LIM eingeben?

Ähnliche Themen

  1. Step 7 Probleme bei der Analogwertverarbeitung mit FC105
    Von gti-yoshi im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 05.06.2013, 01:19
  2. Probleme mit Analogwertverarbeitung
    Von SebastianSPS im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 02.09.2010, 23:29
  3. Probleme Analogwertverarbeitung bei S5 115U
    Von zieglerstadt im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 22.03.2010, 13:37
  4. Probleme Analogwertverarbeitung S5 115U
    Von zieglerstadt im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 20.03.2010, 15:40
  5. Mehrere NetLinks im im Netzwerk - Probleme
    Von Nais im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 25.02.2007, 10:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •