Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Simulation SCL Anfänger benötigt Hilfe

  1. #1
    Registriert seit
    09.10.2012
    Beiträge
    202
    Danke
    25
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Leute,

    ich bin gerade dabei TIA Portal und SCL zu lernen. Bin noch ganz neu in der Ebene. Und deshalb wende ich mich mal gleich hier an euch. Ich will eine ganz einfache SCL Programmierung simulieren, aber das bekomme ich nicht hin. Vielleicht habe ich es auch falsch programmiert oder bei mein OB1 gibts fehler. Ich habe mein OB 1 die Programmsteuerung Call FC 2 (indem Fall) verwendet.


    Hier mein Programm

    SCL Programm.jpg

    %TAG1 ist Eingang E 124.0
    %TAG 3 ist Ausgang A 124.0

    Es tauchen folgende Fehler auf


    STOP durch Programmierfehler (OB nicht geladen oder nicht möglich, bzw. kein FRB vorhanden )
    Unterbrechungstelle im Anwenderprogramm: Zyklisches Programm (OB 1)
    Prioritätsklasse: 1
    OB-Nummer: 1
    Bausteinadresse: 0
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)


    SCL Diagnosepuffer Übersicht.jpg


    Danke im Voraus für jede Hilfe.


    LG

    EMZ
    Geändert von EMZ (10.09.2013 um 19:46 Uhr)
    Zitieren Zitieren Simulation SCL Anfänger benötigt Hilfe  

  2. #2
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.618
    Danke
    776
    Erhielt 646 Danke für 492 Beiträge

    Standard

    Du rufst in OB1 offenbar einen FC auf den es noch nicht gibt.

    hast du FC2 auch wirklich runtergeladen?
    Konsistent laden.


    mfg René

  3. #3
    EMZ ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.10.2012
    Beiträge
    202
    Danke
    25
    Erhielt 1 Danke für 1 Beitrag

    Standard

    hast du FC2 auch wirklich runtergeladen?
    Konsistent laden
    Wie krieg ich das hin, wenn ich Konsistens laden anwähle, kann ich nicht mehr laden.

    hab jetzt alles in FC 1 reingeschrieben, davor war dort ein Programm in FUP das auch Funktioniert hat.

    Trotzdem kommt dieser Fehler:

    SCL Fehler.jpg

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.400 Danke für 2.000 Beiträge

    Standard

    ... du könntest ja auch mal deinen Code posten. Vielleicht liegt der Fehler ja auch da drin ...

    Gruß
    Larry

  5. #5
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Du könntest es auch einfach mal mit LESEN probieren, da steht ganz klar:
    Baustein_1 Fehlerhaft übersetzt, Fehlendes Semikolon also fehlt dir irgendwo ein ";"
    So wie ich das bei dem Bildchen im ersten Post erkenne nach dem "true".
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  6. #6
    EMZ ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.10.2012
    Beiträge
    202
    Danke
    25
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich dreh am Raaaad. Bin zu blöd glaub um die SImulation anzuschmeissen
    Hab ein " ; " nach dem true einefügt aber jetzt meint er, er muss trotzdem streiken

    Fehler -.-.jpg

  7. #7
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von EMZ Beitrag anzeigen
    Hab ein " ; " nach dem true einefügt aber jetzt meint er, er muss trotzdem streiken
    Nachdem der Baustein in der Onlinesicht noch Grün ist obwohl du ihn geändert hast, bedeut das er noch nicht übersetzt wurde.
    Am besten mal Offline gehen > Software komplett übersetzen > und übertragen, dann sollte es gehen.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

Ähnliche Themen

  1. Sonstiges Dringend Hilfe zu 2 AI HS U benötigt !!
    Von MarkusP im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 24.05.2013, 23:19
  2. Hilfe benötigt
    Von Fugger im Forum Simatic
    Antworten: 34
    Letzter Beitrag: 30.03.2012, 13:48
  3. Schnelle Hilfe benötigt
    Von E-Techniker im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 14.04.2008, 15:06
  4. SCL Anfänger sucht Hilfe!
    Von hans55 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 11.12.2007, 22:48
  5. Anfänger braucht hilfe zur simulation
    Von MacDeath im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 13.03.2007, 14:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •